]> git.wh0rd.org - dump.git/blame - dump.spec
Bug in getvol() when making a wrong answer to the 'Mount next volume' prompt.
[dump.git] / dump.spec
CommitLineData
1d568d1b
SP
1%define _sbindir /sbin
2# XXX --enable-kerberos needs krcmd
86fab47e 3%define myoptions --with-binmode=6755 --with-manowner=root --with-mangrp=root --with-manmode=0644 --with-dumpdates="%{_sysconfdir}/dumpdates" --enable-readline --enable-largefile --enable-qfa
1d568d1b 4
2fa54f1c 5Summary: Programs for backing up and restoring ext2/ext3 filesystems.
c154548c 6Name: dump
9081ea90 7Version: 0.4b22
c154548c 8Release: 1
aa73f847 9License: BSD
c154548c 10Group: Applications/Archiving
aa73f847 11Source: http://download.sourceforge.net/dump/dump-%{version}.tar.gz
c154548c 12Requires: rmt
2fa54f1c 13BuildPrereq: e2fsprogs-devel, libtermcap-devel, readline-devel
1d568d1b 14BuildRoot: %{_tmppath}/%{name}-root
c154548c
SP
15
16%description
17The dump package contains both dump and restore. Dump examines files in
18a filesystem, determines which ones need to be backed up, and copies
19those files to a specified disk, tape or other storage medium. The
20restore command performs the inverse function of dump; it can restore a
21full backup of a filesystem. Subsequent incremental backups can then be
22layered on top of the full backup. Single files and directory subtrees
23may also be restored from full or partial backups.
24
25Install dump if you need a system for both backing up filesystems and
26restoring filesystems after backups.
27
28%package -n rmt
29Summary: Provides certain programs with access to remote tape devices.
30Group: Applications/Archiving
31
32%description -n rmt
33The rmt utility provides remote access to tape devices for programs
34like dump (a filesystem backup program), restore (a program for
35restoring files from a backup) and tar (an archiving program).
36
dc8d1876 37%package -n dump-static
8954518f 38Summary: Statically linked versions of dump and restore.
dc8d1876
SP
39Group: Applications/Archiving
40
41%description -n dump-static
42The dump package contains both dump and restore. Dump examines files in
43a filesystem, determines which ones need to be backed up, and copies
44those files to a specified disk, tape or other storage medium. The
45restore command performs the inverse function of dump; it can restore a
46full backup of a filesystem. Subsequent incremental backups can then be
47layered on top of the full backup. Single files and directory subtrees
48may also be restored from full or partial backups.
49
50Install dump if you need a system for both backing up filesystems and
51restoring filesystems after backups.
52
53This packages contains statically linked versions of dump and restore.
54
c154548c
SP
55%prep
56%setup -q
57
58%build
1d568d1b 59%configure %{myoptions} --enable-static
dc8d1876 60
2fa54f1c
SP
61%ifarch alpha
62RPM_OPT_FLAGS=""
63%endif
64make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes \
65 -Wmissing-prototypes -Wno-char-subscripts"
dc8d1876
SP
66
67mv dump/dump dump/dump.static
68mv restore/restore restore/restore.static
69
70make distclean
71
1d568d1b 72%configure %{myoptions} --enable-rmt
c154548c 73
2fa54f1c
SP
74make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes \
75 -Wmissing-prototypes -Wno-char-subscripts"
c154548c
SP
76
77%install
1d568d1b
SP
78rm -rf %{buildroot}
79mkdir -p %{buildroot}%{_sbindir}
80mkdir -p %{buildroot}%{_mandir}/man8
81
60d46c35 82%makeinstall SBINDIR=%{buildroot}%{_sbindir} MANDIR=%{buildroot}%{_mandir}/man8 BINOWNER=$(id -un) BINGRP=$(id -gn) MANOWNER=$(id -un) MANGRP=$(id -gn)
1d568d1b
SP
83
84cp dump/dump.static %{buildroot}%{_sbindir}
85cp restore/restore.static %{buildroot}%{_sbindir}
86
87{ cd %{buildroot}
88 strip .%{_sbindir}/* || :
89 ln -sf dump .%{_sbindir}/rdump
90 ln -sf dump.static .%{_sbindir}/rdump.static
91 ln -sf restore .%{_sbindir}/rrestore
92 ln -sf restore.static .%{_sbindir}/rrestore.static
93 chmod ug-s .%{_sbindir}/rmt
94 mkdir -p .%{_sysconfdir}
95 > .%{_sysconfdir}/dumpdates
96 ln -sf ..%{_sbindir}/rmt .%{_sysconfdir}/rmt
c154548c
SP
97}
98
99%clean
1d568d1b 100rm -rf %{buildroot}
c154548c
SP
101
102%files
103%defattr(-,root,root)
1d568d1b
SP
104%doc CHANGES COPYRIGHT KNOWNBUGS MAINTAINERS README REPORTING-BUGS THANKS TODO
105%doc dump.lsm
106%attr(0664,root,disk) %config(noreplace) %{_sysconfdir}/dumpdates
107%attr(0755,root,root) %{_sbindir}/dump
108%{_sbindir}/rdump
109%attr(0755,root,root) %{_sbindir}/restore
110%{_sbindir}/rrestore
111%{_mandir}/man8/dump.*
112%{_mandir}/man8/rdump.*
113%{_mandir}/man8/restore.*
114%{_mandir}/man8/rrestore.*
c154548c
SP
115
116%files -n rmt
117%defattr(-,root,root)
1d568d1b
SP
118%attr(0755,root,root) %{_sbindir}/rmt
119%{_sysconfdir}/rmt
120%{_mandir}/man8/rmt.*
c154548c 121
dc8d1876
SP
122%files -n dump-static
123%defattr(-,root,root)
1d568d1b
SP
124%attr(0755,root,root) %{_sbindir}/dump.static
125%{_sbindir}/rdump.static
126%attr(0755,root,root) %{_sbindir}/restore.static
127%{_sbindir}/rrestore.static
dc8d1876 128
c154548c 129%changelog
9081ea90
SP
130* Sat May 12 2001 Stelian Pop <pop@noos.fr>
131- dump 0.4b22 released, first packaging.
132
35e850a4
SP
133* Sat Jan 30 2001 Stelian Pop <pop@noos.fr>
134- dump 0.4b21 released, first packaging.
135
109e9e1d 136* Fri Nov 10 2000 Stelian Pop <pop@noos.fr>
e93e901d
SP
137- dump 0.4b20 released, first packaging.
138
109e9e1d 139* Sun Aug 20 2000 Stelian Pop <pop@noos.fr>
d56b7aa4
SP
140- dump 0.4b19 released, first packaging.
141
109e9e1d 142* Thu Jun 30 2000 Stelian Pop <pop@noos.fr>
8cca05cc
SP
143- dump 0.4b18 released, first packaging.
144
109e9e1d 145* Thu Jun 1 2000 Stelian Pop <pop@noos.fr>
ac443b63
SP
146- dump 0.4b17 released, first packaging.
147
109e9e1d 148* Sat Mar 11 2000 Stelian Pop <pop@noos.fr>
107a347c
SP
149- dump 0.4b16 released, first packaging.
150
109e9e1d 151* Thu Mar 2 2000 Stelian Pop <pop@noos.fr>
2f7e72ce
SP
152- dump 0.4b15 released, first packaging.
153
109e9e1d 154* Thu Feb 10 2000 Stelian Pop <pop@noos.fr>
688653ea
SP
155- dump 0.4b14 released, first packaging.
156
109e9e1d 157* Fri Jan 21 2000 Stelian Pop <pop@noos.fr>
d4b74b5c
SP
158- dump 0.4b13 released, first packaging.
159
109e9e1d 160* Fri Jan 8 2000 Stelian Pop <pop@noos.fr>
df172bbb
SP
161- dump 0.4b12 released, first packaging.
162
109e9e1d 163* Sun Dec 5 1999 Stelian Pop <pop@noos.fr>
cf9aab8e
SP
164- dump 0.4b11 released, first packaging.
165
109e9e1d 166* Sun Nov 21 1999 Stelian Pop <pop@noos.fr>
c930abff
SP
167- dump 0.4b10 released, first packaging.
168
109e9e1d 169* Thu Nov 11 1999 Stelian Pop <pop@noos.fr>
dc8d1876
SP
170- make static versions also for rescue purposes.
171
109e9e1d 172* Wed Nov 5 1999 Stelian Pop <pop@noos.fr>
08ebf8d7
SP
173- dump 0.4b9 released, first packaging.
174
109e9e1d 175* Wed Nov 3 1999 Stelian Pop <pop@noos.fr>
c154548c
SP
176- dump 0.4b8 released, first packaging.
177
109e9e1d 178* Thu Oct 8 1999 Stelian Pop <pop@noos.fr>
c154548c
SP
179- dump 0.4b7 released, first packaging.
180
109e9e1d 181* Thu Sep 30 1999 Stelian Pop <pop@noos.fr>
c154548c
SP
182- dump 0.4b6 released, first packaging.
183
184* Fri Sep 10 1999 Jeff Johnson <jbj@redhat.com>
185- recompile with e2fsprogs = 1.15 (#4962).
186
187* Sat Jul 31 1999 Jeff Johnson <jbj@redhat.com>
188- workaround egcs bug (#4281) that caused dump problems (#2989).
189- use sigjmp_buf, not jmp_buf (#3260).
190- invoke /etc/rmt (instead of rmt) like other unices. (#3272).
191- use glibc21 err/glob rather than the internal compatibility routines.
192- wire $(OPT) throughout Makefile's.
193- fix many printf problems, mostly lint clean.
194- merge SuSE, Debian and many OpenBSD fixes.
195
196* Thu Mar 25 1999 Jeff Johnson <jbj@redhat.com>
197- remove setuid/setgid bits from /sbin/rmt (dump/restore are OK).
198
199* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
200- auto rebuild in the new build environment (release 6)
201
202* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
203- strip binaries.
204
205* Thu Mar 18 1999 Jeff Johnson <jbj@redhat.com>
206- Fix dangling symlinks (#1551).
207
208* Wed Mar 17 1999 Michael Maher <mike@redhat.com>
209- Top O' the morning, build root's fixed for man pages.
210
211* Fri Feb 19 1999 Preston Brown <pbrown@redhat.com>
212- upgraded to dump 0.4b4, massaged patches.
213
214* Tue Feb 02 1999 Ian A Cameron <I.A.Cameron@open.ac.uk>
215- added patch from Derrick J Brashear for traverse.c to stop bread errors
216
217* Wed Jan 20 1999 Jeff Johnson <jbj@redhat.com>
218- restore original 6755 root.tty to dump/restore, defattr did tty->root (#684).
219- mark /etc/dumpdates as noreplace.
220
221* Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
222- add build root.
223
224* Tue May 05 1998 Prospector System <bugs@redhat.com>
225- translations modified for de, fr, tr
226
227* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
228- added a patch for resolving linux/types.h and sys/types.h conflicts
229
230* Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
231- added prototype of llseek() so dump would work on large partitions
232
233* Thu Oct 30 1997 Donnie Barnes <djb@redhat.com>
234- made all symlinks relative instead of absolute
235
236* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
237- built against glibc
238
239* Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
240- Moved rmt to its own package.
241
242* Tue Feb 11 1997 Michael Fulbright <msf@redhat.com>
243- Added endian cleanups for SPARC
244
245* Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
246- Made /etc/dumpdates writeable by group disk.