]> git.wh0rd.org - dump.git/blame - dump.spec
Readline cleanups (warning compiles)
[dump.git] / dump.spec
CommitLineData
1d568d1b
SP
1%define _sbindir /sbin
2# XXX --enable-kerberos needs krcmd
86fab47e 3%define myoptions --with-binmode=6755 --with-manowner=root --with-mangrp=root --with-manmode=0644 --with-dumpdates="%{_sysconfdir}/dumpdates" --enable-readline --enable-largefile --enable-qfa
1d568d1b 4
2fa54f1c 5Summary: Programs for backing up and restoring ext2/ext3 filesystems.
c154548c 6Name: dump
490aeb91 7Version: 0.4b26
c154548c 8Release: 1
aa73f847 9License: BSD
132daf88 10URL: http://dump.sourceforge.net
c154548c 11Group: Applications/Archiving
aa73f847 12Source: http://download.sourceforge.net/dump/dump-%{version}.tar.gz
fe246763 13BuildPrereq: e2fsprogs-devel >= 1.18, libtermcap-devel, readline-devel
caea5c76 14Requires: rmt
1d568d1b 15BuildRoot: %{_tmppath}/%{name}-root
c154548c
SP
16
17%description
caea5c76
SP
18The dump package contains both dump and restore. Dump examines files
19in a filesystem, determines which ones need to be backed up, and
20copies those files to a specified disk, tape, or other storage medium.
21The restore command performs the inverse function of dump; it can
22restore a full backup of a filesystem. Subsequent incremental backups
23can then be layered on top of the full backup. Single files and
24directory subtrees may also be restored from full or partial backups.
c154548c
SP
25
26Install dump if you need a system for both backing up filesystems and
27restoring filesystems after backups.
28
29%package -n rmt
30Summary: Provides certain programs with access to remote tape devices.
31Group: Applications/Archiving
32
33%description -n rmt
34The rmt utility provides remote access to tape devices for programs
35like dump (a filesystem backup program), restore (a program for
caea5c76 36restoring files from a backup), and tar (an archiving program).
c154548c 37
dc8d1876 38%package -n dump-static
8954518f 39Summary: Statically linked versions of dump and restore.
dc8d1876
SP
40Group: Applications/Archiving
41
42%description -n dump-static
caea5c76 43The dump package contains both dump and restore. Dump examines files in
dc8d1876 44a filesystem, determines which ones need to be backed up, and copies
caea5c76 45those files to a specified disk, tape, or other storage medium. The
dc8d1876 46restore command performs the inverse function of dump; it can restore a
caea5c76
SP
47full backup of a filesystem. Subsequent incremental backups can then be
48layered on top of the full backup. Single files and directory subtrees
dc8d1876
SP
49may also be restored from full or partial backups.
50
51Install dump if you need a system for both backing up filesystems and
52restoring filesystems after backups.
53
caea5c76 54This package contains statically linked versions of dump and restore.
dc8d1876 55
c154548c
SP
56%prep
57%setup -q
58
59%build
1d568d1b 60%configure %{myoptions} --enable-static
dc8d1876 61
2fa54f1c
SP
62%ifarch alpha
63RPM_OPT_FLAGS=""
64%endif
65make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes \
66 -Wmissing-prototypes -Wno-char-subscripts"
dc8d1876
SP
67
68mv dump/dump dump/dump.static
69mv restore/restore restore/restore.static
70
71make distclean
72
1d568d1b 73%configure %{myoptions} --enable-rmt
c154548c 74
2fa54f1c
SP
75make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes \
76 -Wmissing-prototypes -Wno-char-subscripts"
c154548c
SP
77
78%install
1d568d1b
SP
79rm -rf %{buildroot}
80mkdir -p %{buildroot}%{_sbindir}
81mkdir -p %{buildroot}%{_mandir}/man8
82
60d46c35 83%makeinstall SBINDIR=%{buildroot}%{_sbindir} MANDIR=%{buildroot}%{_mandir}/man8 BINOWNER=$(id -un) BINGRP=$(id -gn) MANOWNER=$(id -un) MANGRP=$(id -gn)
caea5c76 84mkdir -p $RPM_BUILD_ROOT/usr/sbin
1d568d1b
SP
85
86cp dump/dump.static %{buildroot}%{_sbindir}
87cp restore/restore.static %{buildroot}%{_sbindir}
88
caea5c76 89pushd $RPM_BUILD_ROOT
1d568d1b
SP
90 ln -sf dump .%{_sbindir}/rdump
91 ln -sf dump.static .%{_sbindir}/rdump.static
92 ln -sf restore .%{_sbindir}/rrestore
93 ln -sf restore.static .%{_sbindir}/rrestore.static
94 chmod ug-s .%{_sbindir}/rmt
95 mkdir -p .%{_sysconfdir}
96 > .%{_sysconfdir}/dumpdates
97 ln -sf ..%{_sbindir}/rmt .%{_sysconfdir}/rmt
caea5c76
SP
98 # quick workaround :)
99 mv sbin/* usr/sbin/
100 mv usr/sbin/*static sbin/
101 mv usr/sbin/rmt sbin/
102 # somehow, rpm didn't strip these...
103 strip usr/sbin/* sbin/* || :
104popd
c154548c
SP
105
106%clean
1d568d1b 107rm -rf %{buildroot}
c154548c
SP
108
109%files
110%defattr(-,root,root)
1d568d1b 111%doc CHANGES COPYRIGHT KNOWNBUGS MAINTAINERS README REPORTING-BUGS THANKS TODO
8b7882a8 112%doc dump.lsm examples
1d568d1b 113%attr(0664,root,disk) %config(noreplace) %{_sysconfdir}/dumpdates
caea5c76
SP
114%attr(0755,root,root) /usr/sbin/dump
115/usr/sbin/rdump
116%attr(0755,root,root) /usr/sbin/restore
117/usr/sbin/rrestore
1d568d1b
SP
118%{_mandir}/man8/dump.*
119%{_mandir}/man8/rdump.*
120%{_mandir}/man8/restore.*
121%{_mandir}/man8/rrestore.*
c154548c
SP
122
123%files -n rmt
124%defattr(-,root,root)
1d568d1b
SP
125%attr(0755,root,root) %{_sbindir}/rmt
126%{_sysconfdir}/rmt
127%{_mandir}/man8/rmt.*
c154548c 128
dc8d1876
SP
129%files -n dump-static
130%defattr(-,root,root)
1d568d1b
SP
131%attr(0755,root,root) %{_sbindir}/dump.static
132%{_sbindir}/rdump.static
133%attr(0755,root,root) %{_sbindir}/restore.static
134%{_sbindir}/rrestore.static
dc8d1876 135
c154548c 136%changelog
11856e77 137* Mon Jan 7 2002 Stelian Pop <stelian@popies.net>
490aeb91
SP
138- dump 0.4b26 released, first packaging.
139
11856e77 140* Sat Nov 17 2001 Stelian Pop <stelian@popies.net>
bf8ee3da
SP
141- dump 0.4b25 released, first packaging.
142
11856e77 143* Wed Sep 12 2001 Stelian Pop <stelian@popies.net>
68da8d85
SP
144- dump 0.4b24 released, first packaging.
145
11856e77 146* Fri Jul 20 2001 Stelian Pop <stelian@popies.net>
3a1a7e1c
SP
147- dump 0.4b23 released, first packaging.
148
11856e77 149* Sat May 12 2001 Stelian Pop <stelian@popies.net>
9081ea90
SP
150- dump 0.4b22 released, first packaging.
151
11856e77 152* Sat Jan 30 2001 Stelian Pop <stelian@popies.net>
35e850a4
SP
153- dump 0.4b21 released, first packaging.
154
11856e77 155* Fri Nov 10 2000 Stelian Pop <stelian@popies.net>
e93e901d
SP
156- dump 0.4b20 released, first packaging.
157
11856e77 158* Sun Aug 20 2000 Stelian Pop <stelian@popies.net>
d56b7aa4
SP
159- dump 0.4b19 released, first packaging.
160
11856e77 161* Thu Jun 30 2000 Stelian Pop <stelian@popies.net>
8cca05cc
SP
162- dump 0.4b18 released, first packaging.
163
11856e77 164* Thu Jun 1 2000 Stelian Pop <stelian@popies.net>
ac443b63
SP
165- dump 0.4b17 released, first packaging.
166
11856e77 167* Sat Mar 11 2000 Stelian Pop <stelian@popies.net>
107a347c
SP
168- dump 0.4b16 released, first packaging.
169
11856e77 170* Thu Mar 2 2000 Stelian Pop <stelian@popies.net>
2f7e72ce
SP
171- dump 0.4b15 released, first packaging.
172
11856e77 173* Thu Feb 10 2000 Stelian Pop <stelian@popies.net>
688653ea
SP
174- dump 0.4b14 released, first packaging.
175
11856e77 176* Fri Jan 21 2000 Stelian Pop <stelian@popies.net>
d4b74b5c
SP
177- dump 0.4b13 released, first packaging.
178
11856e77 179* Fri Jan 8 2000 Stelian Pop <stelian@popies.net>
df172bbb
SP
180- dump 0.4b12 released, first packaging.
181
11856e77 182* Sun Dec 5 1999 Stelian Pop <stelian@popies.net>
cf9aab8e
SP
183- dump 0.4b11 released, first packaging.
184
11856e77 185* Sun Nov 21 1999 Stelian Pop <stelian@popies.net>
c930abff
SP
186- dump 0.4b10 released, first packaging.
187
11856e77 188* Thu Nov 11 1999 Stelian Pop <stelian@popies.net>
dc8d1876
SP
189- make static versions also for rescue purposes.
190
11856e77 191* Wed Nov 5 1999 Stelian Pop <stelian@popies.net>
08ebf8d7
SP
192- dump 0.4b9 released, first packaging.
193
11856e77 194* Wed Nov 3 1999 Stelian Pop <stelian@popies.net>
c154548c
SP
195- dump 0.4b8 released, first packaging.
196
11856e77 197* Thu Oct 8 1999 Stelian Pop <stelian@popies.net>
c154548c
SP
198- dump 0.4b7 released, first packaging.
199
11856e77 200* Thu Sep 30 1999 Stelian Pop <stelian@popies.net>
c154548c
SP
201- dump 0.4b6 released, first packaging.
202
203* Fri Sep 10 1999 Jeff Johnson <jbj@redhat.com>
204- recompile with e2fsprogs = 1.15 (#4962).
205
206* Sat Jul 31 1999 Jeff Johnson <jbj@redhat.com>
207- workaround egcs bug (#4281) that caused dump problems (#2989).
208- use sigjmp_buf, not jmp_buf (#3260).
209- invoke /etc/rmt (instead of rmt) like other unices. (#3272).
210- use glibc21 err/glob rather than the internal compatibility routines.
211- wire $(OPT) throughout Makefile's.
212- fix many printf problems, mostly lint clean.
213- merge SuSE, Debian and many OpenBSD fixes.
214
215* Thu Mar 25 1999 Jeff Johnson <jbj@redhat.com>
216- remove setuid/setgid bits from /sbin/rmt (dump/restore are OK).
217
218* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
219- auto rebuild in the new build environment (release 6)
220
221* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
222- strip binaries.
223
224* Thu Mar 18 1999 Jeff Johnson <jbj@redhat.com>
225- Fix dangling symlinks (#1551).
226
227* Wed Mar 17 1999 Michael Maher <mike@redhat.com>
228- Top O' the morning, build root's fixed for man pages.
229
230* Fri Feb 19 1999 Preston Brown <pbrown@redhat.com>
231- upgraded to dump 0.4b4, massaged patches.
232
233* Tue Feb 02 1999 Ian A Cameron <I.A.Cameron@open.ac.uk>
234- added patch from Derrick J Brashear for traverse.c to stop bread errors
235
236* Wed Jan 20 1999 Jeff Johnson <jbj@redhat.com>
237- restore original 6755 root.tty to dump/restore, defattr did tty->root (#684).
238- mark /etc/dumpdates as noreplace.
239
240* Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
241- add build root.
242
243* Tue May 05 1998 Prospector System <bugs@redhat.com>
244- translations modified for de, fr, tr
245
246* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
247- added a patch for resolving linux/types.h and sys/types.h conflicts
248
249* Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
250- added prototype of llseek() so dump would work on large partitions
251
252* Thu Oct 30 1997 Donnie Barnes <djb@redhat.com>
253- made all symlinks relative instead of absolute
254
255* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
256- built against glibc
257
258* Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
259- Moved rmt to its own package.
260
261* Tue Feb 11 1997 Michael Fulbright <msf@redhat.com>
262- Added endian cleanups for SPARC
263
264* Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
265- Made /etc/dumpdates writeable by group disk.