]> git.wh0rd.org - dump.git/blame - dump.spec
Modifications from the RedHat RPM.
[dump.git] / dump.spec
CommitLineData
1d568d1b
SP
1%define _sbindir /sbin
2# XXX --enable-kerberos needs krcmd
86fab47e 3%define myoptions --with-binmode=6755 --with-manowner=root --with-mangrp=root --with-manmode=0644 --with-dumpdates="%{_sysconfdir}/dumpdates" --enable-readline --enable-largefile --enable-qfa
1d568d1b 4
2fa54f1c 5Summary: Programs for backing up and restoring ext2/ext3 filesystems.
c154548c 6Name: dump
3a1a7e1c 7Version: 0.4b23
c154548c 8Release: 1
aa73f847 9License: BSD
c154548c 10Group: Applications/Archiving
aa73f847 11Source: http://download.sourceforge.net/dump/dump-%{version}.tar.gz
2fa54f1c 12BuildPrereq: e2fsprogs-devel, libtermcap-devel, readline-devel
caea5c76 13Requires: rmt
1d568d1b 14BuildRoot: %{_tmppath}/%{name}-root
c154548c
SP
15
16%description
caea5c76
SP
17The dump package contains both dump and restore. Dump examines files
18in a filesystem, determines which ones need to be backed up, and
19copies those files to a specified disk, tape, or other storage medium.
20The restore command performs the inverse function of dump; it can
21restore a full backup of a filesystem. Subsequent incremental backups
22can then be layered on top of the full backup. Single files and
23directory subtrees may also be restored from full or partial backups.
c154548c
SP
24
25Install dump if you need a system for both backing up filesystems and
26restoring filesystems after backups.
27
28%package -n rmt
29Summary: Provides certain programs with access to remote tape devices.
30Group: Applications/Archiving
31
32%description -n rmt
33The rmt utility provides remote access to tape devices for programs
34like dump (a filesystem backup program), restore (a program for
caea5c76 35restoring files from a backup), and tar (an archiving program).
c154548c 36
dc8d1876 37%package -n dump-static
8954518f 38Summary: Statically linked versions of dump and restore.
dc8d1876
SP
39Group: Applications/Archiving
40
41%description -n dump-static
caea5c76 42The dump package contains both dump and restore. Dump examines files in
dc8d1876 43a filesystem, determines which ones need to be backed up, and copies
caea5c76 44those files to a specified disk, tape, or other storage medium. The
dc8d1876 45restore command performs the inverse function of dump; it can restore a
caea5c76
SP
46full backup of a filesystem. Subsequent incremental backups can then be
47layered on top of the full backup. Single files and directory subtrees
dc8d1876
SP
48may also be restored from full or partial backups.
49
50Install dump if you need a system for both backing up filesystems and
51restoring filesystems after backups.
52
caea5c76 53This package contains statically linked versions of dump and restore.
dc8d1876 54
c154548c
SP
55%prep
56%setup -q
57
58%build
1d568d1b 59%configure %{myoptions} --enable-static
dc8d1876 60
2fa54f1c
SP
61%ifarch alpha
62RPM_OPT_FLAGS=""
63%endif
64make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes \
65 -Wmissing-prototypes -Wno-char-subscripts"
dc8d1876
SP
66
67mv dump/dump dump/dump.static
68mv restore/restore restore/restore.static
69
70make distclean
71
1d568d1b 72%configure %{myoptions} --enable-rmt
c154548c 73
2fa54f1c
SP
74make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes \
75 -Wmissing-prototypes -Wno-char-subscripts"
c154548c
SP
76
77%install
1d568d1b
SP
78rm -rf %{buildroot}
79mkdir -p %{buildroot}%{_sbindir}
80mkdir -p %{buildroot}%{_mandir}/man8
81
60d46c35 82%makeinstall SBINDIR=%{buildroot}%{_sbindir} MANDIR=%{buildroot}%{_mandir}/man8 BINOWNER=$(id -un) BINGRP=$(id -gn) MANOWNER=$(id -un) MANGRP=$(id -gn)
caea5c76 83mkdir -p $RPM_BUILD_ROOT/usr/sbin
1d568d1b
SP
84
85cp dump/dump.static %{buildroot}%{_sbindir}
86cp restore/restore.static %{buildroot}%{_sbindir}
87
caea5c76 88pushd $RPM_BUILD_ROOT
1d568d1b
SP
89 ln -sf dump .%{_sbindir}/rdump
90 ln -sf dump.static .%{_sbindir}/rdump.static
91 ln -sf restore .%{_sbindir}/rrestore
92 ln -sf restore.static .%{_sbindir}/rrestore.static
93 chmod ug-s .%{_sbindir}/rmt
94 mkdir -p .%{_sysconfdir}
95 > .%{_sysconfdir}/dumpdates
96 ln -sf ..%{_sbindir}/rmt .%{_sysconfdir}/rmt
caea5c76
SP
97 # quick workaround :)
98 mv sbin/* usr/sbin/
99 mv usr/sbin/*static sbin/
100 mv usr/sbin/rmt sbin/
101 # somehow, rpm didn't strip these...
102 strip usr/sbin/* sbin/* || :
103popd
c154548c
SP
104
105%clean
1d568d1b 106rm -rf %{buildroot}
c154548c
SP
107
108%files
109%defattr(-,root,root)
1d568d1b
SP
110%doc CHANGES COPYRIGHT KNOWNBUGS MAINTAINERS README REPORTING-BUGS THANKS TODO
111%doc dump.lsm
112%attr(0664,root,disk) %config(noreplace) %{_sysconfdir}/dumpdates
caea5c76
SP
113%attr(0755,root,root) /usr/sbin/dump
114/usr/sbin/rdump
115%attr(0755,root,root) /usr/sbin/restore
116/usr/sbin/rrestore
1d568d1b
SP
117%{_mandir}/man8/dump.*
118%{_mandir}/man8/rdump.*
119%{_mandir}/man8/restore.*
120%{_mandir}/man8/rrestore.*
c154548c
SP
121
122%files -n rmt
123%defattr(-,root,root)
1d568d1b
SP
124%attr(0755,root,root) %{_sbindir}/rmt
125%{_sysconfdir}/rmt
126%{_mandir}/man8/rmt.*
c154548c 127
dc8d1876
SP
128%files -n dump-static
129%defattr(-,root,root)
1d568d1b
SP
130%attr(0755,root,root) %{_sbindir}/dump.static
131%{_sbindir}/rdump.static
132%attr(0755,root,root) %{_sbindir}/restore.static
133%{_sbindir}/rrestore.static
dc8d1876 134
c154548c 135%changelog
3a1a7e1c
SP
136* Fri Jul 20 2001 Stelian Pop <pop@noos.fr>
137- dump 0.4b23 released, first packaging.
138
9081ea90
SP
139* Sat May 12 2001 Stelian Pop <pop@noos.fr>
140- dump 0.4b22 released, first packaging.
141
35e850a4
SP
142* Sat Jan 30 2001 Stelian Pop <pop@noos.fr>
143- dump 0.4b21 released, first packaging.
144
109e9e1d 145* Fri Nov 10 2000 Stelian Pop <pop@noos.fr>
e93e901d
SP
146- dump 0.4b20 released, first packaging.
147
109e9e1d 148* Sun Aug 20 2000 Stelian Pop <pop@noos.fr>
d56b7aa4
SP
149- dump 0.4b19 released, first packaging.
150
109e9e1d 151* Thu Jun 30 2000 Stelian Pop <pop@noos.fr>
8cca05cc
SP
152- dump 0.4b18 released, first packaging.
153
109e9e1d 154* Thu Jun 1 2000 Stelian Pop <pop@noos.fr>
ac443b63
SP
155- dump 0.4b17 released, first packaging.
156
109e9e1d 157* Sat Mar 11 2000 Stelian Pop <pop@noos.fr>
107a347c
SP
158- dump 0.4b16 released, first packaging.
159
109e9e1d 160* Thu Mar 2 2000 Stelian Pop <pop@noos.fr>
2f7e72ce
SP
161- dump 0.4b15 released, first packaging.
162
109e9e1d 163* Thu Feb 10 2000 Stelian Pop <pop@noos.fr>
688653ea
SP
164- dump 0.4b14 released, first packaging.
165
109e9e1d 166* Fri Jan 21 2000 Stelian Pop <pop@noos.fr>
d4b74b5c
SP
167- dump 0.4b13 released, first packaging.
168
109e9e1d 169* Fri Jan 8 2000 Stelian Pop <pop@noos.fr>
df172bbb
SP
170- dump 0.4b12 released, first packaging.
171
109e9e1d 172* Sun Dec 5 1999 Stelian Pop <pop@noos.fr>
cf9aab8e
SP
173- dump 0.4b11 released, first packaging.
174
109e9e1d 175* Sun Nov 21 1999 Stelian Pop <pop@noos.fr>
c930abff
SP
176- dump 0.4b10 released, first packaging.
177
109e9e1d 178* Thu Nov 11 1999 Stelian Pop <pop@noos.fr>
dc8d1876
SP
179- make static versions also for rescue purposes.
180
109e9e1d 181* Wed Nov 5 1999 Stelian Pop <pop@noos.fr>
08ebf8d7
SP
182- dump 0.4b9 released, first packaging.
183
109e9e1d 184* Wed Nov 3 1999 Stelian Pop <pop@noos.fr>
c154548c
SP
185- dump 0.4b8 released, first packaging.
186
109e9e1d 187* Thu Oct 8 1999 Stelian Pop <pop@noos.fr>
c154548c
SP
188- dump 0.4b7 released, first packaging.
189
109e9e1d 190* Thu Sep 30 1999 Stelian Pop <pop@noos.fr>
c154548c
SP
191- dump 0.4b6 released, first packaging.
192
193* Fri Sep 10 1999 Jeff Johnson <jbj@redhat.com>
194- recompile with e2fsprogs = 1.15 (#4962).
195
196* Sat Jul 31 1999 Jeff Johnson <jbj@redhat.com>
197- workaround egcs bug (#4281) that caused dump problems (#2989).
198- use sigjmp_buf, not jmp_buf (#3260).
199- invoke /etc/rmt (instead of rmt) like other unices. (#3272).
200- use glibc21 err/glob rather than the internal compatibility routines.
201- wire $(OPT) throughout Makefile's.
202- fix many printf problems, mostly lint clean.
203- merge SuSE, Debian and many OpenBSD fixes.
204
205* Thu Mar 25 1999 Jeff Johnson <jbj@redhat.com>
206- remove setuid/setgid bits from /sbin/rmt (dump/restore are OK).
207
208* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
209- auto rebuild in the new build environment (release 6)
210
211* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
212- strip binaries.
213
214* Thu Mar 18 1999 Jeff Johnson <jbj@redhat.com>
215- Fix dangling symlinks (#1551).
216
217* Wed Mar 17 1999 Michael Maher <mike@redhat.com>
218- Top O' the morning, build root's fixed for man pages.
219
220* Fri Feb 19 1999 Preston Brown <pbrown@redhat.com>
221- upgraded to dump 0.4b4, massaged patches.
222
223* Tue Feb 02 1999 Ian A Cameron <I.A.Cameron@open.ac.uk>
224- added patch from Derrick J Brashear for traverse.c to stop bread errors
225
226* Wed Jan 20 1999 Jeff Johnson <jbj@redhat.com>
227- restore original 6755 root.tty to dump/restore, defattr did tty->root (#684).
228- mark /etc/dumpdates as noreplace.
229
230* Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
231- add build root.
232
233* Tue May 05 1998 Prospector System <bugs@redhat.com>
234- translations modified for de, fr, tr
235
236* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
237- added a patch for resolving linux/types.h and sys/types.h conflicts
238
239* Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
240- added prototype of llseek() so dump would work on large partitions
241
242* Thu Oct 30 1997 Donnie Barnes <djb@redhat.com>
243- made all symlinks relative instead of absolute
244
245* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
246- built against glibc
247
248* Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
249- Moved rmt to its own package.
250
251* Tue Feb 11 1997 Michael Fulbright <msf@redhat.com>
252- Added endian cleanups for SPARC
253
254* Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
255- Made /etc/dumpdates writeable by group disk.