]> git.wh0rd.org - dump.git/blame - dump.spec
Fix restore when inode maps are not entirely contained on the first volume.
[dump.git] / dump.spec
CommitLineData
1d568d1b
SP
1%define _sbindir /sbin
2# XXX --enable-kerberos needs krcmd
86fab47e 3%define myoptions --with-binmode=6755 --with-manowner=root --with-mangrp=root --with-manmode=0644 --with-dumpdates="%{_sysconfdir}/dumpdates" --enable-readline --enable-largefile --enable-qfa
1d568d1b 4
2fa54f1c 5Summary: Programs for backing up and restoring ext2/ext3 filesystems.
c154548c 6Name: dump
d1f2790b 7Version: 0.4b28
c154548c 8Release: 1
aa73f847 9License: BSD
132daf88 10URL: http://dump.sourceforge.net
c154548c 11Group: Applications/Archiving
aa73f847 12Source: http://download.sourceforge.net/dump/dump-%{version}.tar.gz
c64bce40
SP
13BuildPrereq: e2fsprogs-devel >= 1.18
14BuildPrereq: libtermcap-devel, readline-devel
15BuildPrereq: zlib-devel, bzip2-devel
caea5c76 16Requires: rmt
1d568d1b 17BuildRoot: %{_tmppath}/%{name}-root
c154548c
SP
18
19%description
caea5c76
SP
20The dump package contains both dump and restore. Dump examines files
21in a filesystem, determines which ones need to be backed up, and
22copies those files to a specified disk, tape, or other storage medium.
23The restore command performs the inverse function of dump; it can
24restore a full backup of a filesystem. Subsequent incremental backups
25can then be layered on top of the full backup. Single files and
26directory subtrees may also be restored from full or partial backups.
c154548c
SP
27
28Install dump if you need a system for both backing up filesystems and
29restoring filesystems after backups.
30
31%package -n rmt
32Summary: Provides certain programs with access to remote tape devices.
33Group: Applications/Archiving
34
35%description -n rmt
36The rmt utility provides remote access to tape devices for programs
37like dump (a filesystem backup program), restore (a program for
caea5c76 38restoring files from a backup), and tar (an archiving program).
c154548c 39
dc8d1876 40%package -n dump-static
8954518f 41Summary: Statically linked versions of dump and restore.
dc8d1876
SP
42Group: Applications/Archiving
43
44%description -n dump-static
caea5c76 45The dump package contains both dump and restore. Dump examines files in
dc8d1876 46a filesystem, determines which ones need to be backed up, and copies
caea5c76 47those files to a specified disk, tape, or other storage medium. The
dc8d1876 48restore command performs the inverse function of dump; it can restore a
caea5c76
SP
49full backup of a filesystem. Subsequent incremental backups can then be
50layered on top of the full backup. Single files and directory subtrees
dc8d1876
SP
51may also be restored from full or partial backups.
52
53Install dump if you need a system for both backing up filesystems and
54restoring filesystems after backups.
55
caea5c76 56This package contains statically linked versions of dump and restore.
dc8d1876 57
c154548c
SP
58%prep
59%setup -q
60
61%build
1d568d1b 62%configure %{myoptions} --enable-static
dc8d1876 63
2fa54f1c
SP
64%ifarch alpha
65RPM_OPT_FLAGS=""
66%endif
67make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes \
68 -Wmissing-prototypes -Wno-char-subscripts"
dc8d1876
SP
69
70mv dump/dump dump/dump.static
71mv restore/restore restore/restore.static
72
73make distclean
74
1d568d1b 75%configure %{myoptions} --enable-rmt
c154548c 76
2fa54f1c
SP
77make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes \
78 -Wmissing-prototypes -Wno-char-subscripts"
c154548c
SP
79
80%install
1d568d1b
SP
81rm -rf %{buildroot}
82mkdir -p %{buildroot}%{_sbindir}
83mkdir -p %{buildroot}%{_mandir}/man8
84
60d46c35 85%makeinstall SBINDIR=%{buildroot}%{_sbindir} MANDIR=%{buildroot}%{_mandir}/man8 BINOWNER=$(id -un) BINGRP=$(id -gn) MANOWNER=$(id -un) MANGRP=$(id -gn)
caea5c76 86mkdir -p $RPM_BUILD_ROOT/usr/sbin
1d568d1b
SP
87
88cp dump/dump.static %{buildroot}%{_sbindir}
89cp restore/restore.static %{buildroot}%{_sbindir}
90
caea5c76 91pushd $RPM_BUILD_ROOT
1d568d1b
SP
92 ln -sf dump .%{_sbindir}/rdump
93 ln -sf dump.static .%{_sbindir}/rdump.static
94 ln -sf restore .%{_sbindir}/rrestore
95 ln -sf restore.static .%{_sbindir}/rrestore.static
96 chmod ug-s .%{_sbindir}/rmt
97 mkdir -p .%{_sysconfdir}
98 > .%{_sysconfdir}/dumpdates
99 ln -sf ..%{_sbindir}/rmt .%{_sysconfdir}/rmt
caea5c76
SP
100 # quick workaround :)
101 mv sbin/* usr/sbin/
102 mv usr/sbin/*static sbin/
103 mv usr/sbin/rmt sbin/
104 # somehow, rpm didn't strip these...
105 strip usr/sbin/* sbin/* || :
106popd
c154548c
SP
107
108%clean
1d568d1b 109rm -rf %{buildroot}
c154548c
SP
110
111%files
112%defattr(-,root,root)
1d568d1b 113%doc CHANGES COPYRIGHT KNOWNBUGS MAINTAINERS README REPORTING-BUGS THANKS TODO
8b7882a8 114%doc dump.lsm examples
1d568d1b 115%attr(0664,root,disk) %config(noreplace) %{_sysconfdir}/dumpdates
caea5c76
SP
116%attr(0755,root,root) /usr/sbin/dump
117/usr/sbin/rdump
118%attr(0755,root,root) /usr/sbin/restore
119/usr/sbin/rrestore
1d568d1b
SP
120%{_mandir}/man8/dump.*
121%{_mandir}/man8/rdump.*
122%{_mandir}/man8/restore.*
123%{_mandir}/man8/rrestore.*
c154548c
SP
124
125%files -n rmt
126%defattr(-,root,root)
1d568d1b
SP
127%attr(0755,root,root) %{_sbindir}/rmt
128%{_sysconfdir}/rmt
129%{_mandir}/man8/rmt.*
c154548c 130
dc8d1876
SP
131%files -n dump-static
132%defattr(-,root,root)
1d568d1b
SP
133%attr(0755,root,root) %{_sbindir}/dump.static
134%{_sbindir}/rdump.static
135%attr(0755,root,root) %{_sbindir}/restore.static
136%{_sbindir}/rrestore.static
dc8d1876 137
c154548c 138%changelog
d1f2790b
SP
139* Fri Apr 12 2002 Stelian Pop <stelian@popies.net
140- dump 0.4b28 released, first packaging.
141
f06477da
SP
142* Fri Feb 15 2002 Stelian Pop <stelian@popies.net
143- dump 0.4b27 released, first packaging.
144
11856e77 145* Mon Jan 7 2002 Stelian Pop <stelian@popies.net>
490aeb91
SP
146- dump 0.4b26 released, first packaging.
147
11856e77 148* Sat Nov 17 2001 Stelian Pop <stelian@popies.net>
bf8ee3da
SP
149- dump 0.4b25 released, first packaging.
150
11856e77 151* Wed Sep 12 2001 Stelian Pop <stelian@popies.net>
68da8d85
SP
152- dump 0.4b24 released, first packaging.
153
11856e77 154* Fri Jul 20 2001 Stelian Pop <stelian@popies.net>
3a1a7e1c
SP
155- dump 0.4b23 released, first packaging.
156
11856e77 157* Sat May 12 2001 Stelian Pop <stelian@popies.net>
9081ea90
SP
158- dump 0.4b22 released, first packaging.
159
11856e77 160* Sat Jan 30 2001 Stelian Pop <stelian@popies.net>
35e850a4
SP
161- dump 0.4b21 released, first packaging.
162
11856e77 163* Fri Nov 10 2000 Stelian Pop <stelian@popies.net>
e93e901d
SP
164- dump 0.4b20 released, first packaging.
165
11856e77 166* Sun Aug 20 2000 Stelian Pop <stelian@popies.net>
d56b7aa4
SP
167- dump 0.4b19 released, first packaging.
168
11856e77 169* Thu Jun 30 2000 Stelian Pop <stelian@popies.net>
8cca05cc
SP
170- dump 0.4b18 released, first packaging.
171
11856e77 172* Thu Jun 1 2000 Stelian Pop <stelian@popies.net>
ac443b63
SP
173- dump 0.4b17 released, first packaging.
174
11856e77 175* Sat Mar 11 2000 Stelian Pop <stelian@popies.net>
107a347c
SP
176- dump 0.4b16 released, first packaging.
177
11856e77 178* Thu Mar 2 2000 Stelian Pop <stelian@popies.net>
2f7e72ce
SP
179- dump 0.4b15 released, first packaging.
180
11856e77 181* Thu Feb 10 2000 Stelian Pop <stelian@popies.net>
688653ea
SP
182- dump 0.4b14 released, first packaging.
183
11856e77 184* Fri Jan 21 2000 Stelian Pop <stelian@popies.net>
d4b74b5c
SP
185- dump 0.4b13 released, first packaging.
186
11856e77 187* Fri Jan 8 2000 Stelian Pop <stelian@popies.net>
df172bbb
SP
188- dump 0.4b12 released, first packaging.
189
11856e77 190* Sun Dec 5 1999 Stelian Pop <stelian@popies.net>
cf9aab8e
SP
191- dump 0.4b11 released, first packaging.
192
11856e77 193* Sun Nov 21 1999 Stelian Pop <stelian@popies.net>
c930abff
SP
194- dump 0.4b10 released, first packaging.
195
11856e77 196* Thu Nov 11 1999 Stelian Pop <stelian@popies.net>
dc8d1876
SP
197- make static versions also for rescue purposes.
198
11856e77 199* Wed Nov 5 1999 Stelian Pop <stelian@popies.net>
08ebf8d7
SP
200- dump 0.4b9 released, first packaging.
201
11856e77 202* Wed Nov 3 1999 Stelian Pop <stelian@popies.net>
c154548c
SP
203- dump 0.4b8 released, first packaging.
204
11856e77 205* Thu Oct 8 1999 Stelian Pop <stelian@popies.net>
c154548c
SP
206- dump 0.4b7 released, first packaging.
207
11856e77 208* Thu Sep 30 1999 Stelian Pop <stelian@popies.net>
c154548c
SP
209- dump 0.4b6 released, first packaging.
210
211* Fri Sep 10 1999 Jeff Johnson <jbj@redhat.com>
212- recompile with e2fsprogs = 1.15 (#4962).
213
214* Sat Jul 31 1999 Jeff Johnson <jbj@redhat.com>
215- workaround egcs bug (#4281) that caused dump problems (#2989).
216- use sigjmp_buf, not jmp_buf (#3260).
217- invoke /etc/rmt (instead of rmt) like other unices. (#3272).
218- use glibc21 err/glob rather than the internal compatibility routines.
219- wire $(OPT) throughout Makefile's.
220- fix many printf problems, mostly lint clean.
221- merge SuSE, Debian and many OpenBSD fixes.
222
223* Thu Mar 25 1999 Jeff Johnson <jbj@redhat.com>
224- remove setuid/setgid bits from /sbin/rmt (dump/restore are OK).
225
226* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
227- auto rebuild in the new build environment (release 6)
228
229* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
230- strip binaries.
231
232* Thu Mar 18 1999 Jeff Johnson <jbj@redhat.com>
233- Fix dangling symlinks (#1551).
234
235* Wed Mar 17 1999 Michael Maher <mike@redhat.com>
236- Top O' the morning, build root's fixed for man pages.
237
238* Fri Feb 19 1999 Preston Brown <pbrown@redhat.com>
239- upgraded to dump 0.4b4, massaged patches.
240
241* Tue Feb 02 1999 Ian A Cameron <I.A.Cameron@open.ac.uk>
242- added patch from Derrick J Brashear for traverse.c to stop bread errors
243
244* Wed Jan 20 1999 Jeff Johnson <jbj@redhat.com>
245- restore original 6755 root.tty to dump/restore, defattr did tty->root (#684).
246- mark /etc/dumpdates as noreplace.
247
248* Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
249- add build root.
250
251* Tue May 05 1998 Prospector System <bugs@redhat.com>
252- translations modified for de, fr, tr
253
254* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
255- added a patch for resolving linux/types.h and sys/types.h conflicts
256
257* Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
258- added prototype of llseek() so dump would work on large partitions
259
260* Thu Oct 30 1997 Donnie Barnes <djb@redhat.com>
261- made all symlinks relative instead of absolute
262
263* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
264- built against glibc
265
266* Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
267- Moved rmt to its own package.
268
269* Tue Feb 11 1997 Michael Fulbright <msf@redhat.com>
270- Added endian cleanups for SPARC
271
272* Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
273- Made /etc/dumpdates writeable by group disk.