]> git.wh0rd.org - dump.git/blame - dump.spec
Copyright notice for AlcĂ´ve, for paying me to work on dump...
[dump.git] / dump.spec
CommitLineData
1d568d1b
SP
1%define _sbindir /sbin
2# XXX --enable-kerberos needs krcmd
3%define myoptions --with-binmode=6755 --with-manowner=root --with-mangrp=root --with-manmode=0644 --with-dumpdates="%{_sysconfdir}/dumpdates" --enable-readline
4
c154548c
SP
5Summary: Programs for backing up and restoring filesystems.
6Name: dump
d56b7aa4 7Version: 0.4b19
c154548c
SP
8Release: 1
9Copyright: UCB
10Group: Applications/Archiving
ebcbe7f6 11Source: http://sourceforge.net/download.php/dump/dump-%{version}.tar.gz
c154548c 12Requires: rmt
1d568d1b 13BuildRoot: %{_tmppath}/%{name}-root
c154548c
SP
14
15%description
16The dump package contains both dump and restore. Dump examines files in
17a filesystem, determines which ones need to be backed up, and copies
18those files to a specified disk, tape or other storage medium. The
19restore command performs the inverse function of dump; it can restore a
20full backup of a filesystem. Subsequent incremental backups can then be
21layered on top of the full backup. Single files and directory subtrees
22may also be restored from full or partial backups.
23
24Install dump if you need a system for both backing up filesystems and
25restoring filesystems after backups.
26
27%package -n rmt
28Summary: Provides certain programs with access to remote tape devices.
29Group: Applications/Archiving
30
31%description -n rmt
32The rmt utility provides remote access to tape devices for programs
33like dump (a filesystem backup program), restore (a program for
34restoring files from a backup) and tar (an archiving program).
35
dc8d1876 36%package -n dump-static
8954518f 37Summary: Statically linked versions of dump and restore.
dc8d1876
SP
38Group: Applications/Archiving
39
40%description -n dump-static
41The dump package contains both dump and restore. Dump examines files in
42a filesystem, determines which ones need to be backed up, and copies
43those files to a specified disk, tape or other storage medium. The
44restore command performs the inverse function of dump; it can restore a
45full backup of a filesystem. Subsequent incremental backups can then be
46layered on top of the full backup. Single files and directory subtrees
47may also be restored from full or partial backups.
48
49Install dump if you need a system for both backing up filesystems and
50restoring filesystems after backups.
51
52This packages contains statically linked versions of dump and restore.
53
c154548c
SP
54%prep
55%setup -q
56
57%build
1d568d1b 58%configure %{myoptions} --enable-static
dc8d1876
SP
59
60make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts"
61
62mv dump/dump dump/dump.static
63mv restore/restore restore/restore.static
64
65make distclean
66
1d568d1b 67%configure %{myoptions} --enable-rmt
c154548c
SP
68
69make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts"
70
71%install
1d568d1b
SP
72rm -rf %{buildroot}
73mkdir -p %{buildroot}%{_sbindir}
74mkdir -p %{buildroot}%{_mandir}/man8
75
76%makeinstall BINDIR=%{buildroot}%{_sbindir} MANDIR=%{buildroot}%{_mandir}/man8 BINOWNER=$(id -un) BINGRP=$(id -gn) MANOWNER=$(id -un) MANGRP=$(id -gn)
77
78cp dump/dump.static %{buildroot}%{_sbindir}
79cp restore/restore.static %{buildroot}%{_sbindir}
80
81{ cd %{buildroot}
82 strip .%{_sbindir}/* || :
83 ln -sf dump .%{_sbindir}/rdump
84 ln -sf dump.static .%{_sbindir}/rdump.static
85 ln -sf restore .%{_sbindir}/rrestore
86 ln -sf restore.static .%{_sbindir}/rrestore.static
87 chmod ug-s .%{_sbindir}/rmt
88 mkdir -p .%{_sysconfdir}
89 > .%{_sysconfdir}/dumpdates
90 ln -sf ..%{_sbindir}/rmt .%{_sysconfdir}/rmt
c154548c
SP
91}
92
93%clean
1d568d1b 94rm -rf %{buildroot}
c154548c
SP
95
96%files
97%defattr(-,root,root)
1d568d1b
SP
98%doc CHANGES COPYRIGHT KNOWNBUGS MAINTAINERS README REPORTING-BUGS THANKS TODO
99%doc dump.lsm
100%attr(0664,root,disk) %config(noreplace) %{_sysconfdir}/dumpdates
101%attr(0755,root,root) %{_sbindir}/dump
102%{_sbindir}/rdump
103%attr(0755,root,root) %{_sbindir}/restore
104%{_sbindir}/rrestore
105%{_mandir}/man8/dump.*
106%{_mandir}/man8/rdump.*
107%{_mandir}/man8/restore.*
108%{_mandir}/man8/rrestore.*
c154548c
SP
109
110%files -n rmt
111%defattr(-,root,root)
1d568d1b
SP
112%attr(0755,root,root) %{_sbindir}/rmt
113%{_sysconfdir}/rmt
114%{_mandir}/man8/rmt.*
c154548c 115
dc8d1876
SP
116%files -n dump-static
117%defattr(-,root,root)
1d568d1b
SP
118%attr(0755,root,root) %{_sbindir}/dump.static
119%{_sbindir}/rdump.static
120%attr(0755,root,root) %{_sbindir}/restore.static
121%{_sbindir}/rrestore.static
dc8d1876 122
c154548c 123%changelog
d56b7aa4
SP
124* Sun Aug 20 2000 Stelian Pop <pop@cybercable.fr>
125- dump 0.4b19 released, first packaging.
126
8cca05cc
SP
127* Thu Jun 30 2000 Stelian Pop <pop@cybercable.fr>
128- dump 0.4b18 released, first packaging.
129
ac443b63
SP
130* Thu Jun 1 2000 Stelian Pop <pop@cybercable.fr>
131- dump 0.4b17 released, first packaging.
132
133* Sat Mar 11 2000 Stelian Pop <pop@cybercable.fr>
107a347c
SP
134- dump 0.4b16 released, first packaging.
135
2f7e72ce
SP
136* Thu Mar 2 2000 Stelian Pop <pop@cybercable.fr>
137- dump 0.4b15 released, first packaging.
138
688653ea
SP
139* Thu Feb 10 2000 Stelian Pop <pop@cybercable.fr>
140- dump 0.4b14 released, first packaging.
141
d4b74b5c
SP
142* Fri Jan 21 2000 Stelian Pop <pop@cybercable.fr>
143- dump 0.4b13 released, first packaging.
144
0d0bc326 145* Fri Jan 8 2000 Stelian Pop <pop@cybercable.fr>
df172bbb
SP
146- dump 0.4b12 released, first packaging.
147
cf9aab8e
SP
148* Sun Dec 5 1999 Stelian Pop <pop@cybercable.fr>
149- dump 0.4b11 released, first packaging.
150
c930abff
SP
151* Sun Nov 21 1999 Stelian Pop <pop@cybercable.fr>
152- dump 0.4b10 released, first packaging.
153
dc8d1876
SP
154* Thu Nov 11 1999 Stelian Pop <pop@cybercable.fr>
155- make static versions also for rescue purposes.
156
08ebf8d7
SP
157* Wed Nov 5 1999 Stelian Pop <pop@cybercable.fr>
158- dump 0.4b9 released, first packaging.
159
c154548c
SP
160* Wed Nov 3 1999 Stelian Pop <pop@cybercable.fr>
161- dump 0.4b8 released, first packaging.
162
163* Thu Oct 8 1999 Stelian Pop <pop@cybercable.fr>
164- dump 0.4b7 released, first packaging.
165
166* Thu Sep 30 1999 Stelian Pop <pop@cybercable.fr>
167- dump 0.4b6 released, first packaging.
168
169* Fri Sep 10 1999 Jeff Johnson <jbj@redhat.com>
170- recompile with e2fsprogs = 1.15 (#4962).
171
172* Sat Jul 31 1999 Jeff Johnson <jbj@redhat.com>
173- workaround egcs bug (#4281) that caused dump problems (#2989).
174- use sigjmp_buf, not jmp_buf (#3260).
175- invoke /etc/rmt (instead of rmt) like other unices. (#3272).
176- use glibc21 err/glob rather than the internal compatibility routines.
177- wire $(OPT) throughout Makefile's.
178- fix many printf problems, mostly lint clean.
179- merge SuSE, Debian and many OpenBSD fixes.
180
181* Thu Mar 25 1999 Jeff Johnson <jbj@redhat.com>
182- remove setuid/setgid bits from /sbin/rmt (dump/restore are OK).
183
184* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
185- auto rebuild in the new build environment (release 6)
186
187* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
188- strip binaries.
189
190* Thu Mar 18 1999 Jeff Johnson <jbj@redhat.com>
191- Fix dangling symlinks (#1551).
192
193* Wed Mar 17 1999 Michael Maher <mike@redhat.com>
194- Top O' the morning, build root's fixed for man pages.
195
196* Fri Feb 19 1999 Preston Brown <pbrown@redhat.com>
197- upgraded to dump 0.4b4, massaged patches.
198
199* Tue Feb 02 1999 Ian A Cameron <I.A.Cameron@open.ac.uk>
200- added patch from Derrick J Brashear for traverse.c to stop bread errors
201
202* Wed Jan 20 1999 Jeff Johnson <jbj@redhat.com>
203- restore original 6755 root.tty to dump/restore, defattr did tty->root (#684).
204- mark /etc/dumpdates as noreplace.
205
206* Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
207- add build root.
208
209* Tue May 05 1998 Prospector System <bugs@redhat.com>
210- translations modified for de, fr, tr
211
212* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
213- added a patch for resolving linux/types.h and sys/types.h conflicts
214
215* Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
216- added prototype of llseek() so dump would work on large partitions
217
218* Thu Oct 30 1997 Donnie Barnes <djb@redhat.com>
219- made all symlinks relative instead of absolute
220
221* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
222- built against glibc
223
224* Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
225- Moved rmt to its own package.
226
227* Tue Feb 11 1997 Michael Fulbright <msf@redhat.com>
228- Added endian cleanups for SPARC
229
230* Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
231- Made /etc/dumpdates writeable by group disk.