]> git.wh0rd.org - dump.git/blame - dump.spec
Made the nodump flag work on a directory.
[dump.git] / dump.spec
CommitLineData
c154548c
SP
1Summary: Programs for backing up and restoring filesystems.
2Name: dump
08ebf8d7 3Version: 0.4b9
c154548c
SP
4Release: 1
5Copyright: UCB
6Group: Applications/Archiving
7Source: http://perso.cybercable.fr/pop/dump/dump-%{version}.tar.gz
8Requires: rmt
9BuildRoot: /var/tmp/%{name}-root
10
11%description
12The dump package contains both dump and restore. Dump examines files in
13a filesystem, determines which ones need to be backed up, and copies
14those files to a specified disk, tape or other storage medium. The
15restore command performs the inverse function of dump; it can restore a
16full backup of a filesystem. Subsequent incremental backups can then be
17layered on top of the full backup. Single files and directory subtrees
18may also be restored from full or partial backups.
19
20Install dump if you need a system for both backing up filesystems and
21restoring filesystems after backups.
22
23%package -n rmt
24Summary: Provides certain programs with access to remote tape devices.
25Group: Applications/Archiving
26
27%description -n rmt
28The rmt utility provides remote access to tape devices for programs
29like dump (a filesystem backup program), restore (a program for
30restoring files from a backup) and tar (an archiving program).
31
dc8d1876
SP
32%package -n dump-static
33Summary: Programs for backing up and restoring filesystems.
34Group: Applications/Archiving
35
36%description -n dump-static
37The dump package contains both dump and restore. Dump examines files in
38a filesystem, determines which ones need to be backed up, and copies
39those files to a specified disk, tape or other storage medium. The
40restore command performs the inverse function of dump; it can restore a
41full backup of a filesystem. Subsequent incremental backups can then be
42layered on top of the full backup. Single files and directory subtrees
43may also be restored from full or partial backups.
44
45Install dump if you need a system for both backing up filesystems and
46restoring filesystems after backups.
47
48This packages contains statically linked versions of dump and restore.
49
c154548c
SP
50%prep
51%setup -q
52
53%build
54
dc8d1876
SP
55%configure --with-binmode=6755 --with-manowner=root --with-mangrp=root --with-manmode=0644 --enable-static
56
57make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts"
58
59mv dump/dump dump/dump.static
60mv restore/restore restore/restore.static
61
62make distclean
63
64configure --with-binmode=6755 --with-manowner=root --with-mangrp=root --with-manmode=0644 --enable-rmt
c154548c
SP
65
66make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts"
67
68%install
69rm -rf $RPM_BUILD_ROOT
70mkdir -p $RPM_BUILD_ROOT/sbin
71mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/man/man8
72
73make install BINDIR=$RPM_BUILD_ROOT/sbin MANDIR=${RPM_BUILD_ROOT}%{_prefix}/man/man8
74
dc8d1876
SP
75cp dump/dump.static $RPM_BUILD_ROOT/sbin
76cp restore/restore.static $RPM_BUILD_ROOT/sbin
77
c154548c
SP
78{ cd $RPM_BUILD_ROOT
79 strip ./sbin/* || :
80 ln -sf dump ./sbin/rdump
dc8d1876 81 ln -sf dump.static ./sbin/rdump.static
c154548c 82 ln -sf restore ./sbin/rrestore
dc8d1876 83 ln -sf restore.static ./sbin/rrestore.static
c154548c
SP
84 chmod ug-s ./sbin/rmt
85 mkdir -p ./etc
86 > ./etc/dumpdates
87 ln -sf ../sbin/rmt ./etc/rmt
88}
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%files
94%defattr(-,root,root)
95%doc CHANGES COPYRIGHT KNOWNBUGS MAINTAINERS README THANKS TODO dump.lsm
96%attr(0664,root,disk) %config(noreplace) /etc/dumpdates
97%attr(6755,root,tty) /sbin/dump
98/sbin/rdump
99%attr(6755,root,tty) /sbin/restore
100/sbin/rrestore
101%{_prefix}/man/man8/dump.8
102%{_prefix}/man/man8/rdump.8
103%{_prefix}/man/man8/restore.8
104%{_prefix}/man/man8/rrestore.8
105
106%files -n rmt
107%defattr(-,root,root)
108%attr(0755,root,root) /sbin/rmt
109/etc/rmt
110%{_prefix}/man/man8/rmt.8
111
dc8d1876
SP
112%files -n dump-static
113%defattr(-,root,root)
114%attr(6755,root,tty) /sbin/dump.static
115/sbin/rdump.static
116%attr(6755,root,tty) /sbin/restore.static
117/sbin/rrestore.static
118
c154548c 119%changelog
dc8d1876
SP
120* Thu Nov 11 1999 Stelian Pop <pop@cybercable.fr>
121- make static versions also for rescue purposes.
122
08ebf8d7
SP
123* Wed Nov 5 1999 Stelian Pop <pop@cybercable.fr>
124- dump 0.4b9 released, first packaging.
125
c154548c
SP
126* Wed Nov 3 1999 Stelian Pop <pop@cybercable.fr>
127- dump 0.4b8 released, first packaging.
128
129* Thu Oct 8 1999 Stelian Pop <pop@cybercable.fr>
130- dump 0.4b7 released, first packaging.
131
132* Thu Sep 30 1999 Stelian Pop <pop@cybercable.fr>
133- dump 0.4b6 released, first packaging.
134
135* Fri Sep 10 1999 Jeff Johnson <jbj@redhat.com>
136- recompile with e2fsprogs = 1.15 (#4962).
137
138* Sat Jul 31 1999 Jeff Johnson <jbj@redhat.com>
139- workaround egcs bug (#4281) that caused dump problems (#2989).
140- use sigjmp_buf, not jmp_buf (#3260).
141- invoke /etc/rmt (instead of rmt) like other unices. (#3272).
142- use glibc21 err/glob rather than the internal compatibility routines.
143- wire $(OPT) throughout Makefile's.
144- fix many printf problems, mostly lint clean.
145- merge SuSE, Debian and many OpenBSD fixes.
146
147* Thu Mar 25 1999 Jeff Johnson <jbj@redhat.com>
148- remove setuid/setgid bits from /sbin/rmt (dump/restore are OK).
149
150* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
151- auto rebuild in the new build environment (release 6)
152
153* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
154- strip binaries.
155
156* Thu Mar 18 1999 Jeff Johnson <jbj@redhat.com>
157- Fix dangling symlinks (#1551).
158
159* Wed Mar 17 1999 Michael Maher <mike@redhat.com>
160- Top O' the morning, build root's fixed for man pages.
161
162* Fri Feb 19 1999 Preston Brown <pbrown@redhat.com>
163- upgraded to dump 0.4b4, massaged patches.
164
165* Tue Feb 02 1999 Ian A Cameron <I.A.Cameron@open.ac.uk>
166- added patch from Derrick J Brashear for traverse.c to stop bread errors
167
168* Wed Jan 20 1999 Jeff Johnson <jbj@redhat.com>
169- restore original 6755 root.tty to dump/restore, defattr did tty->root (#684).
170- mark /etc/dumpdates as noreplace.
171
172* Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
173- add build root.
174
175* Tue May 05 1998 Prospector System <bugs@redhat.com>
176- translations modified for de, fr, tr
177
178* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
179- added a patch for resolving linux/types.h and sys/types.h conflicts
180
181* Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
182- added prototype of llseek() so dump would work on large partitions
183
184* Thu Oct 30 1997 Donnie Barnes <djb@redhat.com>
185- made all symlinks relative instead of absolute
186
187* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
188- built against glibc
189
190* Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
191- Moved rmt to its own package.
192
193* Tue Feb 11 1997 Michael Fulbright <msf@redhat.com>
194- Added endian cleanups for SPARC
195
196* Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
197- Made /etc/dumpdates writeable by group disk.