]> git.wh0rd.org - dump.git/blob - dump.spec
Fix -B manpage entry.
[dump.git] / dump.spec
1 %define _sbindir /sbin
2 # XXX --enable-kerberos needs krcmd
3 %define myoptions --with-binmode=6755 --with-manowner=root --with-mangrp=root --with-manmode=0644 --with-dumpdates="%{_sysconfdir}/dumpdates" --enable-readline --enable-largefile --enable-qfa
4
5 Summary: Programs for backing up and restoring ext2/ext3 filesystems.
6 Name: dump
7 Version: 0.4b27
8 Release: 1
9 License: BSD
10 URL: http://dump.sourceforge.net
11 Group: Applications/Archiving
12 Source: http://download.sourceforge.net/dump/dump-%{version}.tar.gz
13 BuildPrereq: e2fsprogs-devel >= 1.18, libtermcap-devel, readline-devel
14 Requires: rmt
15 BuildRoot: %{_tmppath}/%{name}-root
16
17 %description
18 The dump package contains both dump and restore. Dump examines files
19 in a filesystem, determines which ones need to be backed up, and
20 copies those files to a specified disk, tape, or other storage medium.
21 The restore command performs the inverse function of dump; it can
22 restore a full backup of a filesystem. Subsequent incremental backups
23 can then be layered on top of the full backup. Single files and
24 directory subtrees may also be restored from full or partial backups.
25
26 Install dump if you need a system for both backing up filesystems and
27 restoring filesystems after backups.
28
29 %package -n rmt
30 Summary: Provides certain programs with access to remote tape devices.
31 Group: Applications/Archiving
32
33 %description -n rmt
34 The rmt utility provides remote access to tape devices for programs
35 like dump (a filesystem backup program), restore (a program for
36 restoring files from a backup), and tar (an archiving program).
37
38 %package -n dump-static
39 Summary: Statically linked versions of dump and restore.
40 Group: Applications/Archiving
41
42 %description -n dump-static
43 The dump package contains both dump and restore. Dump examines files in
44 a filesystem, determines which ones need to be backed up, and copies
45 those files to a specified disk, tape, or other storage medium. The
46 restore command performs the inverse function of dump; it can restore a
47 full backup of a filesystem. Subsequent incremental backups can then be
48 layered on top of the full backup. Single files and directory subtrees
49 may also be restored from full or partial backups.
50
51 Install dump if you need a system for both backing up filesystems and
52 restoring filesystems after backups.
53
54 This package contains statically linked versions of dump and restore.
55
56 %prep
57 %setup -q
58
59 %build
60 %configure %{myoptions} --enable-static
61
62 %ifarch alpha
63 RPM_OPT_FLAGS=""
64 %endif
65 make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes \
66 -Wmissing-prototypes -Wno-char-subscripts"
67
68 mv dump/dump dump/dump.static
69 mv restore/restore restore/restore.static
70
71 make distclean
72
73 %configure %{myoptions} --enable-rmt
74
75 make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes \
76 -Wmissing-prototypes -Wno-char-subscripts"
77
78 %install
79 rm -rf %{buildroot}
80 mkdir -p %{buildroot}%{_sbindir}
81 mkdir -p %{buildroot}%{_mandir}/man8
82
83 %makeinstall SBINDIR=%{buildroot}%{_sbindir} MANDIR=%{buildroot}%{_mandir}/man8 BINOWNER=$(id -un) BINGRP=$(id -gn) MANOWNER=$(id -un) MANGRP=$(id -gn)
84 mkdir -p $RPM_BUILD_ROOT/usr/sbin
85
86 cp dump/dump.static %{buildroot}%{_sbindir}
87 cp restore/restore.static %{buildroot}%{_sbindir}
88
89 pushd $RPM_BUILD_ROOT
90 ln -sf dump .%{_sbindir}/rdump
91 ln -sf dump.static .%{_sbindir}/rdump.static
92 ln -sf restore .%{_sbindir}/rrestore
93 ln -sf restore.static .%{_sbindir}/rrestore.static
94 chmod ug-s .%{_sbindir}/rmt
95 mkdir -p .%{_sysconfdir}
96 > .%{_sysconfdir}/dumpdates
97 ln -sf ..%{_sbindir}/rmt .%{_sysconfdir}/rmt
98 # quick workaround :)
99 mv sbin/* usr/sbin/
100 mv usr/sbin/*static sbin/
101 mv usr/sbin/rmt sbin/
102 # somehow, rpm didn't strip these...
103 strip usr/sbin/* sbin/* || :
104 popd
105
106 %clean
107 rm -rf %{buildroot}
108
109 %files
110 %defattr(-,root,root)
111 %doc CHANGES COPYRIGHT KNOWNBUGS MAINTAINERS README REPORTING-BUGS THANKS TODO
112 %doc dump.lsm examples
113 %attr(0664,root,disk) %config(noreplace) %{_sysconfdir}/dumpdates
114 %attr(0755,root,root) /usr/sbin/dump
115 /usr/sbin/rdump
116 %attr(0755,root,root) /usr/sbin/restore
117 /usr/sbin/rrestore
118 %{_mandir}/man8/dump.*
119 %{_mandir}/man8/rdump.*
120 %{_mandir}/man8/restore.*
121 %{_mandir}/man8/rrestore.*
122
123 %files -n rmt
124 %defattr(-,root,root)
125 %attr(0755,root,root) %{_sbindir}/rmt
126 %{_sysconfdir}/rmt
127 %{_mandir}/man8/rmt.*
128
129 %files -n dump-static
130 %defattr(-,root,root)
131 %attr(0755,root,root) %{_sbindir}/dump.static
132 %{_sbindir}/rdump.static
133 %attr(0755,root,root) %{_sbindir}/restore.static
134 %{_sbindir}/rrestore.static
135
136 %changelog
137 * Fri Feb 15 2002 Stelian Pop <stelian@popies.net
138 - dump 0.4b27 released, first packaging.
139
140 * Mon Jan 7 2002 Stelian Pop <stelian@popies.net>
141 - dump 0.4b26 released, first packaging.
142
143 * Sat Nov 17 2001 Stelian Pop <stelian@popies.net>
144 - dump 0.4b25 released, first packaging.
145
146 * Wed Sep 12 2001 Stelian Pop <stelian@popies.net>
147 - dump 0.4b24 released, first packaging.
148
149 * Fri Jul 20 2001 Stelian Pop <stelian@popies.net>
150 - dump 0.4b23 released, first packaging.
151
152 * Sat May 12 2001 Stelian Pop <stelian@popies.net>
153 - dump 0.4b22 released, first packaging.
154
155 * Sat Jan 30 2001 Stelian Pop <stelian@popies.net>
156 - dump 0.4b21 released, first packaging.
157
158 * Fri Nov 10 2000 Stelian Pop <stelian@popies.net>
159 - dump 0.4b20 released, first packaging.
160
161 * Sun Aug 20 2000 Stelian Pop <stelian@popies.net>
162 - dump 0.4b19 released, first packaging.
163
164 * Thu Jun 30 2000 Stelian Pop <stelian@popies.net>
165 - dump 0.4b18 released, first packaging.
166
167 * Thu Jun 1 2000 Stelian Pop <stelian@popies.net>
168 - dump 0.4b17 released, first packaging.
169
170 * Sat Mar 11 2000 Stelian Pop <stelian@popies.net>
171 - dump 0.4b16 released, first packaging.
172
173 * Thu Mar 2 2000 Stelian Pop <stelian@popies.net>
174 - dump 0.4b15 released, first packaging.
175
176 * Thu Feb 10 2000 Stelian Pop <stelian@popies.net>
177 - dump 0.4b14 released, first packaging.
178
179 * Fri Jan 21 2000 Stelian Pop <stelian@popies.net>
180 - dump 0.4b13 released, first packaging.
181
182 * Fri Jan 8 2000 Stelian Pop <stelian@popies.net>
183 - dump 0.4b12 released, first packaging.
184
185 * Sun Dec 5 1999 Stelian Pop <stelian@popies.net>
186 - dump 0.4b11 released, first packaging.
187
188 * Sun Nov 21 1999 Stelian Pop <stelian@popies.net>
189 - dump 0.4b10 released, first packaging.
190
191 * Thu Nov 11 1999 Stelian Pop <stelian@popies.net>
192 - make static versions also for rescue purposes.
193
194 * Wed Nov 5 1999 Stelian Pop <stelian@popies.net>
195 - dump 0.4b9 released, first packaging.
196
197 * Wed Nov 3 1999 Stelian Pop <stelian@popies.net>
198 - dump 0.4b8 released, first packaging.
199
200 * Thu Oct 8 1999 Stelian Pop <stelian@popies.net>
201 - dump 0.4b7 released, first packaging.
202
203 * Thu Sep 30 1999 Stelian Pop <stelian@popies.net>
204 - dump 0.4b6 released, first packaging.
205
206 * Fri Sep 10 1999 Jeff Johnson <jbj@redhat.com>
207 - recompile with e2fsprogs = 1.15 (#4962).
208
209 * Sat Jul 31 1999 Jeff Johnson <jbj@redhat.com>
210 - workaround egcs bug (#4281) that caused dump problems (#2989).
211 - use sigjmp_buf, not jmp_buf (#3260).
212 - invoke /etc/rmt (instead of rmt) like other unices. (#3272).
213 - use glibc21 err/glob rather than the internal compatibility routines.
214 - wire $(OPT) throughout Makefile's.
215 - fix many printf problems, mostly lint clean.
216 - merge SuSE, Debian and many OpenBSD fixes.
217
218 * Thu Mar 25 1999 Jeff Johnson <jbj@redhat.com>
219 - remove setuid/setgid bits from /sbin/rmt (dump/restore are OK).
220
221 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
222 - auto rebuild in the new build environment (release 6)
223
224 * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
225 - strip binaries.
226
227 * Thu Mar 18 1999 Jeff Johnson <jbj@redhat.com>
228 - Fix dangling symlinks (#1551).
229
230 * Wed Mar 17 1999 Michael Maher <mike@redhat.com>
231 - Top O' the morning, build root's fixed for man pages.
232
233 * Fri Feb 19 1999 Preston Brown <pbrown@redhat.com>
234 - upgraded to dump 0.4b4, massaged patches.
235
236 * Tue Feb 02 1999 Ian A Cameron <I.A.Cameron@open.ac.uk>
237 - added patch from Derrick J Brashear for traverse.c to stop bread errors
238
239 * Wed Jan 20 1999 Jeff Johnson <jbj@redhat.com>
240 - restore original 6755 root.tty to dump/restore, defattr did tty->root (#684).
241 - mark /etc/dumpdates as noreplace.
242
243 * Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
244 - add build root.
245
246 * Tue May 05 1998 Prospector System <bugs@redhat.com>
247 - translations modified for de, fr, tr
248
249 * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
250 - added a patch for resolving linux/types.h and sys/types.h conflicts
251
252 * Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
253 - added prototype of llseek() so dump would work on large partitions
254
255 * Thu Oct 30 1997 Donnie Barnes <djb@redhat.com>
256 - made all symlinks relative instead of absolute
257
258 * Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
259 - built against glibc
260
261 * Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
262 - Moved rmt to its own package.
263
264 * Tue Feb 11 1997 Michael Fulbright <msf@redhat.com>
265 - Added endian cleanups for SPARC
266
267 * Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
268 - Made /etc/dumpdates writeable by group disk.