]> git.wh0rd.org - dump.git/blob - dump.spec
Improve level 1 mapdirs speed.
[dump.git] / dump.spec
1 %define _sbindir /sbin
2 # XXX --enable-kerberos needs krcmd
3 %define myoptions --with-binmode=6755 --with-manowner=root --with-mangrp=root --with-manmode=0644 --with-dumpdates="%{_sysconfdir}/dumpdates"
4
5 Summary: Programs for backing up and restoring ext2/ext3 filesystems.
6 Name: dump
7 Version: 0.4b42
8 Release: 1
9 License: BSD
10 URL: http://dump.sourceforge.net
11 Group: Applications/Archiving
12 Source: dump-%{version}.tar.gz
13 BuildPrereq: e2fsprogs-devel >= 1.18
14 BuildPrereq: libtermcap-devel, readline-devel, ncurses-devel
15 BuildPrereq: zlib-devel, bzip2-devel
16 Requires: rmt
17 BuildRoot: %{_tmppath}/%{name}-root
18
19 %description
20 The dump package contains both dump and restore. Dump examines files
21 in a filesystem, determines which ones need to be backed up, and
22 copies those files to a specified disk, tape, or other storage medium.
23 The restore command performs the inverse function of dump; it can
24 restore a full backup of a filesystem. Subsequent incremental backups
25 can then be layered on top of the full backup. Single files and
26 directory subtrees may also be restored from full or partial backups.
27
28 Install dump if you need a system for both backing up filesystems and
29 restoring filesystems after backups.
30
31 %package -n rmt
32 Summary: Provides certain programs with access to remote tape devices.
33 Group: Applications/Archiving
34
35 %description -n rmt
36 The rmt utility provides remote access to tape devices for programs
37 like dump (a filesystem backup program), restore (a program for
38 restoring files from a backup), and tar (an archiving program).
39
40 %package -n dump-static
41 Summary: Statically linked versions of dump and restore.
42 Group: Applications/Archiving
43
44 %description -n dump-static
45 The dump package contains both dump and restore. Dump examines files in
46 a filesystem, determines which ones need to be backed up, and copies
47 those files to a specified disk, tape, or other storage medium. The
48 restore command performs the inverse function of dump; it can restore a
49 full backup of a filesystem. Subsequent incremental backups can then be
50 layered on top of the full backup. Single files and directory subtrees
51 may also be restored from full or partial backups.
52
53 Install dump if you need a system for both backing up filesystems and
54 restoring filesystems after backups.
55
56 This package contains statically linked versions of dump and restore.
57
58 %prep
59 %setup -q
60
61 %build
62 %configure %{myoptions} --enable-static -disable-rmt
63
64 %ifarch alpha
65 RPM_OPT_FLAGS=""
66 %endif
67 make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes \
68 -Wmissing-prototypes -Wno-char-subscripts"
69
70 mv dump/dump dump/dump.static
71 mv restore/restore restore/restore.static
72
73 make distclean
74
75 %configure %{myoptions}
76
77 make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes \
78 -Wmissing-prototypes -Wno-char-subscripts"
79
80 %install
81 rm -rf %{buildroot}
82 mkdir -p %{buildroot}%{_sbindir}
83 mkdir -p %{buildroot}%{_mandir}/man8
84
85 %makeinstall SBINDIR=%{buildroot}%{_sbindir} MANDIR=%{buildroot}%{_mandir}/man8 BINOWNER=$(id -un) BINGRP=$(id -gn) MANOWNER=$(id -un) MANGRP=$(id -gn)
86 mkdir -p $RPM_BUILD_ROOT/usr/sbin
87
88 cp dump/dump.static %{buildroot}%{_sbindir}
89 cp restore/restore.static %{buildroot}%{_sbindir}
90
91 pushd $RPM_BUILD_ROOT
92 ln -sf dump .%{_sbindir}/rdump
93 ln -sf dump.static .%{_sbindir}/rdump.static
94 ln -sf restore .%{_sbindir}/rrestore
95 ln -sf restore.static .%{_sbindir}/rrestore.static
96 chmod ug-s .%{_sbindir}/rmt
97 mkdir -p .%{_sysconfdir}
98 > .%{_sysconfdir}/dumpdates
99 ln -sf ..%{_sbindir}/rmt .%{_sysconfdir}/rmt
100 # quick workaround :)
101 mv sbin/* usr/sbin/
102 mv usr/sbin/*static sbin/
103 mv usr/sbin/rmt sbin/
104 # somehow, rpm didn't strip these...
105 strip usr/sbin/* sbin/* || :
106 popd
107
108 %clean
109 rm -rf %{buildroot}
110
111 %files
112 %defattr(-,root,root)
113 %doc CHANGES COPYRIGHT KNOWNBUGS MAINTAINERS README REPORTING-BUGS THANKS TODO
114 %doc dump.lsm examples
115 %attr(0664,root,disk) %config(noreplace) %{_sysconfdir}/dumpdates
116 %attr(0755,root,root) /usr/sbin/dump
117 /usr/sbin/rdump
118 %attr(0755,root,root) /usr/sbin/restore
119 /usr/sbin/rrestore
120 %{_mandir}/man8/dump.*
121 %{_mandir}/man8/rdump.*
122 %{_mandir}/man8/restore.*
123 %{_mandir}/man8/rrestore.*
124
125 %files -n rmt
126 %defattr(-,root,root)
127 %attr(0755,root,root) %{_sbindir}/rmt
128 %{_sysconfdir}/rmt
129 %{_mandir}/man8/rmt.*
130
131 %files -n dump-static
132 %defattr(-,root,root)
133 %attr(0755,root,root) %{_sbindir}/dump.static
134 %{_sbindir}/rdump.static
135 %attr(0755,root,root) %{_sbindir}/restore.static
136 %{_sbindir}/rrestore.static
137
138 %changelog
139 * Mon Jun 18 2009 Stelian Pop <stelian@popies.net>
140 - dump 0.4b42 released, first packaging.
141
142 * Mon Jan 2 2006 Stelian Pop <stelian@popies.net>
143 - dump 0.4b41 released, first packaging.
144
145 * Fri Jan 21 2005 Stelian Pop <stelian@popies.net>
146 - dump 0.4b39 released, first packaging.
147
148 * Fri Jan 7 2005 Stelian Pop <stelian@popies.net>
149 - dump 0.4b38 released, first packaging.
150
151 * Wed Jul 7 2004 Stelian Pop <stelian@popies.net>
152 - dump 0.4b37 released, first packaging.
153
154 * Wed Apr 21 2004 Stelian Pop <stelian@popies.net>
155 - dump 0.4b36 released, first packaging.
156
157 * Sun Dec 21 2003 Stelian Pop <stelian@popies.net>
158 - dump 0.4b35 released, first packaging.
159
160 * Fri Apr 18 2003 Stelian Pop <stelian@popies.net>
161 - dump 0.4b34 released, first packaging.
162
163 * Mon Feb 10 2003 Stelian Pop <stelian@popies.net>
164 - dump 0.4b33 released, first packaging.
165
166 * Fri Nov 15 2002 Stelian Pop <stelian@popies.net>
167 - dump 0.4b32 released, first packaging.
168
169 * Tue Jul 30 2002 Stelian Pop <stelian@popies.net>
170 - dump 0.4b31 released, first packaging.
171
172 * Thu Jul 25 2002 Stelian Pop <stelian@popies.net>
173 - dump 0.4b30 released, first packaging.
174
175 * Sat Jun 8 2002 Stelian Pop <stelian@popies.net>
176 - dump 0.4b29 released, first packaging.
177
178 * Fri Apr 12 2002 Stelian Pop <stelian@popies.net>
179 - dump 0.4b28 released, first packaging.
180
181 * Fri Feb 15 2002 Stelian Pop <stelian@popies.net>
182 - dump 0.4b27 released, first packaging.
183
184 * Mon Jan 7 2002 Stelian Pop <stelian@popies.net>
185 - dump 0.4b26 released, first packaging.
186
187 * Sat Nov 17 2001 Stelian Pop <stelian@popies.net>
188 - dump 0.4b25 released, first packaging.
189
190 * Wed Sep 12 2001 Stelian Pop <stelian@popies.net>
191 - dump 0.4b24 released, first packaging.
192
193 * Fri Jul 20 2001 Stelian Pop <stelian@popies.net>
194 - dump 0.4b23 released, first packaging.
195
196 * Sat May 12 2001 Stelian Pop <stelian@popies.net>
197 - dump 0.4b22 released, first packaging.
198
199 * Sat Jan 30 2001 Stelian Pop <stelian@popies.net>
200 - dump 0.4b21 released, first packaging.
201
202 * Fri Nov 10 2000 Stelian Pop <stelian@popies.net>
203 - dump 0.4b20 released, first packaging.
204
205 * Sun Aug 20 2000 Stelian Pop <stelian@popies.net>
206 - dump 0.4b19 released, first packaging.
207
208 * Thu Jun 30 2000 Stelian Pop <stelian@popies.net>
209 - dump 0.4b18 released, first packaging.
210
211 * Thu Jun 1 2000 Stelian Pop <stelian@popies.net>
212 - dump 0.4b17 released, first packaging.
213
214 * Sat Mar 11 2000 Stelian Pop <stelian@popies.net>
215 - dump 0.4b16 released, first packaging.
216
217 * Thu Mar 2 2000 Stelian Pop <stelian@popies.net>
218 - dump 0.4b15 released, first packaging.
219
220 * Thu Feb 10 2000 Stelian Pop <stelian@popies.net>
221 - dump 0.4b14 released, first packaging.
222
223 * Fri Jan 21 2000 Stelian Pop <stelian@popies.net>
224 - dump 0.4b13 released, first packaging.
225
226 * Fri Jan 8 2000 Stelian Pop <stelian@popies.net>
227 - dump 0.4b12 released, first packaging.
228
229 * Sun Dec 5 1999 Stelian Pop <stelian@popies.net>
230 - dump 0.4b11 released, first packaging.
231
232 * Sun Nov 21 1999 Stelian Pop <stelian@popies.net>
233 - dump 0.4b10 released, first packaging.
234
235 * Thu Nov 11 1999 Stelian Pop <stelian@popies.net>
236 - make static versions also for rescue purposes.
237
238 * Wed Nov 5 1999 Stelian Pop <stelian@popies.net>
239 - dump 0.4b9 released, first packaging.
240
241 * Wed Nov 3 1999 Stelian Pop <stelian@popies.net>
242 - dump 0.4b8 released, first packaging.
243
244 * Thu Oct 8 1999 Stelian Pop <stelian@popies.net>
245 - dump 0.4b7 released, first packaging.
246
247 * Thu Sep 30 1999 Stelian Pop <stelian@popies.net>
248 - dump 0.4b6 released, first packaging.
249
250 * Fri Sep 10 1999 Jeff Johnson <jbj@redhat.com>
251 - recompile with e2fsprogs = 1.15 (#4962).
252
253 * Sat Jul 31 1999 Jeff Johnson <jbj@redhat.com>
254 - workaround egcs bug (#4281) that caused dump problems (#2989).
255 - use sigjmp_buf, not jmp_buf (#3260).
256 - invoke /etc/rmt (instead of rmt) like other unices. (#3272).
257 - use glibc21 err/glob rather than the internal compatibility routines.
258 - wire $(OPT) throughout Makefile's.
259 - fix many printf problems, mostly lint clean.
260 - merge SuSE, Debian and many OpenBSD fixes.
261
262 * Thu Mar 25 1999 Jeff Johnson <jbj@redhat.com>
263 - remove setuid/setgid bits from /sbin/rmt (dump/restore are OK).
264
265 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
266 - auto rebuild in the new build environment (release 6)
267
268 * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
269 - strip binaries.
270
271 * Thu Mar 18 1999 Jeff Johnson <jbj@redhat.com>
272 - Fix dangling symlinks (#1551).
273
274 * Wed Mar 17 1999 Michael Maher <mike@redhat.com>
275 - Top O' the morning, build root's fixed for man pages.
276
277 * Fri Feb 19 1999 Preston Brown <pbrown@redhat.com>
278 - upgraded to dump 0.4b4, massaged patches.
279
280 * Tue Feb 02 1999 Ian A Cameron <I.A.Cameron@open.ac.uk>
281 - added patch from Derrick J Brashear for traverse.c to stop bread errors
282
283 * Wed Jan 20 1999 Jeff Johnson <jbj@redhat.com>
284 - restore original 6755 root.tty to dump/restore, defattr did tty->root (#684).
285 - mark /etc/dumpdates as noreplace.
286
287 * Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
288 - add build root.
289
290 * Tue May 05 1998 Prospector System <bugs@redhat.com>
291 - translations modified for de, fr, tr
292
293 * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
294 - added a patch for resolving linux/types.h and sys/types.h conflicts
295
296 * Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
297 - added prototype of llseek() so dump would work on large partitions
298
299 * Thu Oct 30 1997 Donnie Barnes <djb@redhat.com>
300 - made all symlinks relative instead of absolute
301
302 * Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
303 - built against glibc
304
305 * Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
306 - Moved rmt to its own package.
307
308 * Tue Feb 11 1997 Michael Fulbright <msf@redhat.com>
309 - Added endian cleanups for SPARC
310
311 * Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
312 - Made /etc/dumpdates writeable by group disk.