]> git.wh0rd.org - dump.git/blob - dump.spec
Fixed restore to use the full volume path when doing a compare.
[dump.git] / dump.spec
1 %define _sbindir /sbin
2 # XXX --enable-kerberos needs krcmd
3 %define myoptions --with-binmode=6755 --with-manowner=root --with-mangrp=root --with-manmode=0644 --with-dumpdates="%{_sysconfdir}/dumpdates" --enable-readline --enable-largefile --enable-qfa
4
5 Summary: Programs for backing up and restoring ext2/ext3 filesystems.
6 Name: dump
7 Version: 0.4b23
8 Release: 1
9 License: BSD
10 Group: Applications/Archiving
11 Source: http://download.sourceforge.net/dump/dump-%{version}.tar.gz
12 Requires: rmt
13 BuildPrereq: e2fsprogs-devel, libtermcap-devel, readline-devel
14 BuildRoot: %{_tmppath}/%{name}-root
15
16 %description
17 The dump package contains both dump and restore. Dump examines files in
18 a filesystem, determines which ones need to be backed up, and copies
19 those files to a specified disk, tape or other storage medium. The
20 restore command performs the inverse function of dump; it can restore a
21 full backup of a filesystem. Subsequent incremental backups can then be
22 layered on top of the full backup. Single files and directory subtrees
23 may also be restored from full or partial backups.
24
25 Install dump if you need a system for both backing up filesystems and
26 restoring filesystems after backups.
27
28 %package -n rmt
29 Summary: Provides certain programs with access to remote tape devices.
30 Group: Applications/Archiving
31
32 %description -n rmt
33 The rmt utility provides remote access to tape devices for programs
34 like dump (a filesystem backup program), restore (a program for
35 restoring files from a backup) and tar (an archiving program).
36
37 %package -n dump-static
38 Summary: Statically linked versions of dump and restore.
39 Group: Applications/Archiving
40
41 %description -n dump-static
42 The dump package contains both dump and restore. Dump examines files in
43 a filesystem, determines which ones need to be backed up, and copies
44 those files to a specified disk, tape or other storage medium. The
45 restore command performs the inverse function of dump; it can restore a
46 full backup of a filesystem. Subsequent incremental backups can then be
47 layered on top of the full backup. Single files and directory subtrees
48 may also be restored from full or partial backups.
49
50 Install dump if you need a system for both backing up filesystems and
51 restoring filesystems after backups.
52
53 This packages contains statically linked versions of dump and restore.
54
55 %prep
56 %setup -q
57
58 %build
59 %configure %{myoptions} --enable-static
60
61 %ifarch alpha
62 RPM_OPT_FLAGS=""
63 %endif
64 make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes \
65 -Wmissing-prototypes -Wno-char-subscripts"
66
67 mv dump/dump dump/dump.static
68 mv restore/restore restore/restore.static
69
70 make distclean
71
72 %configure %{myoptions} --enable-rmt
73
74 make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes \
75 -Wmissing-prototypes -Wno-char-subscripts"
76
77 %install
78 rm -rf %{buildroot}
79 mkdir -p %{buildroot}%{_sbindir}
80 mkdir -p %{buildroot}%{_mandir}/man8
81
82 %makeinstall SBINDIR=%{buildroot}%{_sbindir} MANDIR=%{buildroot}%{_mandir}/man8 BINOWNER=$(id -un) BINGRP=$(id -gn) MANOWNER=$(id -un) MANGRP=$(id -gn)
83
84 cp dump/dump.static %{buildroot}%{_sbindir}
85 cp restore/restore.static %{buildroot}%{_sbindir}
86
87 { cd %{buildroot}
88 strip .%{_sbindir}/* || :
89 ln -sf dump .%{_sbindir}/rdump
90 ln -sf dump.static .%{_sbindir}/rdump.static
91 ln -sf restore .%{_sbindir}/rrestore
92 ln -sf restore.static .%{_sbindir}/rrestore.static
93 chmod ug-s .%{_sbindir}/rmt
94 mkdir -p .%{_sysconfdir}
95 > .%{_sysconfdir}/dumpdates
96 ln -sf ..%{_sbindir}/rmt .%{_sysconfdir}/rmt
97 }
98
99 %clean
100 rm -rf %{buildroot}
101
102 %files
103 %defattr(-,root,root)
104 %doc CHANGES COPYRIGHT KNOWNBUGS MAINTAINERS README REPORTING-BUGS THANKS TODO
105 %doc dump.lsm
106 %attr(0664,root,disk) %config(noreplace) %{_sysconfdir}/dumpdates
107 %attr(0755,root,root) %{_sbindir}/dump
108 %{_sbindir}/rdump
109 %attr(0755,root,root) %{_sbindir}/restore
110 %{_sbindir}/rrestore
111 %{_mandir}/man8/dump.*
112 %{_mandir}/man8/rdump.*
113 %{_mandir}/man8/restore.*
114 %{_mandir}/man8/rrestore.*
115
116 %files -n rmt
117 %defattr(-,root,root)
118 %attr(0755,root,root) %{_sbindir}/rmt
119 %{_sysconfdir}/rmt
120 %{_mandir}/man8/rmt.*
121
122 %files -n dump-static
123 %defattr(-,root,root)
124 %attr(0755,root,root) %{_sbindir}/dump.static
125 %{_sbindir}/rdump.static
126 %attr(0755,root,root) %{_sbindir}/restore.static
127 %{_sbindir}/rrestore.static
128
129 %changelog
130 * Fri Jul 20 2001 Stelian Pop <pop@noos.fr>
131 - dump 0.4b23 released, first packaging.
132
133 * Sat May 12 2001 Stelian Pop <pop@noos.fr>
134 - dump 0.4b22 released, first packaging.
135
136 * Sat Jan 30 2001 Stelian Pop <pop@noos.fr>
137 - dump 0.4b21 released, first packaging.
138
139 * Fri Nov 10 2000 Stelian Pop <pop@noos.fr>
140 - dump 0.4b20 released, first packaging.
141
142 * Sun Aug 20 2000 Stelian Pop <pop@noos.fr>
143 - dump 0.4b19 released, first packaging.
144
145 * Thu Jun 30 2000 Stelian Pop <pop@noos.fr>
146 - dump 0.4b18 released, first packaging.
147
148 * Thu Jun 1 2000 Stelian Pop <pop@noos.fr>
149 - dump 0.4b17 released, first packaging.
150
151 * Sat Mar 11 2000 Stelian Pop <pop@noos.fr>
152 - dump 0.4b16 released, first packaging.
153
154 * Thu Mar 2 2000 Stelian Pop <pop@noos.fr>
155 - dump 0.4b15 released, first packaging.
156
157 * Thu Feb 10 2000 Stelian Pop <pop@noos.fr>
158 - dump 0.4b14 released, first packaging.
159
160 * Fri Jan 21 2000 Stelian Pop <pop@noos.fr>
161 - dump 0.4b13 released, first packaging.
162
163 * Fri Jan 8 2000 Stelian Pop <pop@noos.fr>
164 - dump 0.4b12 released, first packaging.
165
166 * Sun Dec 5 1999 Stelian Pop <pop@noos.fr>
167 - dump 0.4b11 released, first packaging.
168
169 * Sun Nov 21 1999 Stelian Pop <pop@noos.fr>
170 - dump 0.4b10 released, first packaging.
171
172 * Thu Nov 11 1999 Stelian Pop <pop@noos.fr>
173 - make static versions also for rescue purposes.
174
175 * Wed Nov 5 1999 Stelian Pop <pop@noos.fr>
176 - dump 0.4b9 released, first packaging.
177
178 * Wed Nov 3 1999 Stelian Pop <pop@noos.fr>
179 - dump 0.4b8 released, first packaging.
180
181 * Thu Oct 8 1999 Stelian Pop <pop@noos.fr>
182 - dump 0.4b7 released, first packaging.
183
184 * Thu Sep 30 1999 Stelian Pop <pop@noos.fr>
185 - dump 0.4b6 released, first packaging.
186
187 * Fri Sep 10 1999 Jeff Johnson <jbj@redhat.com>
188 - recompile with e2fsprogs = 1.15 (#4962).
189
190 * Sat Jul 31 1999 Jeff Johnson <jbj@redhat.com>
191 - workaround egcs bug (#4281) that caused dump problems (#2989).
192 - use sigjmp_buf, not jmp_buf (#3260).
193 - invoke /etc/rmt (instead of rmt) like other unices. (#3272).
194 - use glibc21 err/glob rather than the internal compatibility routines.
195 - wire $(OPT) throughout Makefile's.
196 - fix many printf problems, mostly lint clean.
197 - merge SuSE, Debian and many OpenBSD fixes.
198
199 * Thu Mar 25 1999 Jeff Johnson <jbj@redhat.com>
200 - remove setuid/setgid bits from /sbin/rmt (dump/restore are OK).
201
202 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
203 - auto rebuild in the new build environment (release 6)
204
205 * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
206 - strip binaries.
207
208 * Thu Mar 18 1999 Jeff Johnson <jbj@redhat.com>
209 - Fix dangling symlinks (#1551).
210
211 * Wed Mar 17 1999 Michael Maher <mike@redhat.com>
212 - Top O' the morning, build root's fixed for man pages.
213
214 * Fri Feb 19 1999 Preston Brown <pbrown@redhat.com>
215 - upgraded to dump 0.4b4, massaged patches.
216
217 * Tue Feb 02 1999 Ian A Cameron <I.A.Cameron@open.ac.uk>
218 - added patch from Derrick J Brashear for traverse.c to stop bread errors
219
220 * Wed Jan 20 1999 Jeff Johnson <jbj@redhat.com>
221 - restore original 6755 root.tty to dump/restore, defattr did tty->root (#684).
222 - mark /etc/dumpdates as noreplace.
223
224 * Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
225 - add build root.
226
227 * Tue May 05 1998 Prospector System <bugs@redhat.com>
228 - translations modified for de, fr, tr
229
230 * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
231 - added a patch for resolving linux/types.h and sys/types.h conflicts
232
233 * Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
234 - added prototype of llseek() so dump would work on large partitions
235
236 * Thu Oct 30 1997 Donnie Barnes <djb@redhat.com>
237 - made all symlinks relative instead of absolute
238
239 * Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
240 - built against glibc
241
242 * Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
243 - Moved rmt to its own package.
244
245 * Tue Feb 11 1997 Michael Fulbright <msf@redhat.com>
246 - Added endian cleanups for SPARC
247
248 * Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
249 - Made /etc/dumpdates writeable by group disk.