]> git.wh0rd.org - dump.git/blob - dump.spec
LFS fixes (explicit use of open64/etc)
[dump.git] / dump.spec
1 %define _sbindir /sbin
2 # XXX --enable-kerberos needs krcmd
3 %define myoptions --with-binmode=6755 --with-manowner=root --with-mangrp=root --with-manmode=0644 --with-dumpdates="%{_sysconfdir}/dumpdates" --enable-readline --enable-largefile
4
5 Summary: Programs for backing up and restoring filesystems.
6 Name: dump
7 Version: 0.4b21
8 Release: 1
9 License: BSD
10 Group: Applications/Archiving
11 Source: http://download.sourceforge.net/dump/dump-%{version}.tar.gz
12 Requires: rmt
13 BuildRequires: e2fsprogs-devel
14 BuildRoot: %{_tmppath}/%{name}-root
15
16 %description
17 The dump package contains both dump and restore. Dump examines files in
18 a filesystem, determines which ones need to be backed up, and copies
19 those files to a specified disk, tape or other storage medium. The
20 restore command performs the inverse function of dump; it can restore a
21 full backup of a filesystem. Subsequent incremental backups can then be
22 layered on top of the full backup. Single files and directory subtrees
23 may also be restored from full or partial backups.
24
25 Install dump if you need a system for both backing up filesystems and
26 restoring filesystems after backups.
27
28 %package -n rmt
29 Summary: Provides certain programs with access to remote tape devices.
30 Group: Applications/Archiving
31
32 %description -n rmt
33 The rmt utility provides remote access to tape devices for programs
34 like dump (a filesystem backup program), restore (a program for
35 restoring files from a backup) and tar (an archiving program).
36
37 %package -n dump-static
38 Summary: Statically linked versions of dump and restore.
39 Group: Applications/Archiving
40
41 %description -n dump-static
42 The dump package contains both dump and restore. Dump examines files in
43 a filesystem, determines which ones need to be backed up, and copies
44 those files to a specified disk, tape or other storage medium. The
45 restore command performs the inverse function of dump; it can restore a
46 full backup of a filesystem. Subsequent incremental backups can then be
47 layered on top of the full backup. Single files and directory subtrees
48 may also be restored from full or partial backups.
49
50 Install dump if you need a system for both backing up filesystems and
51 restoring filesystems after backups.
52
53 This packages contains statically linked versions of dump and restore.
54
55 %prep
56 %setup -q
57
58 %build
59 %configure %{myoptions} --enable-static
60
61 make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts"
62
63 mv dump/dump dump/dump.static
64 mv restore/restore restore/restore.static
65
66 make distclean
67
68 %configure %{myoptions} --enable-rmt
69
70 make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts"
71
72 %install
73 rm -rf %{buildroot}
74 mkdir -p %{buildroot}%{_sbindir}
75 mkdir -p %{buildroot}%{_mandir}/man8
76
77 %makeinstall SBINDIR=%{buildroot}%{_sbindir} MANDIR=%{buildroot}%{_mandir}/man8 BINOWNER=$(id -un) BINGRP=$(id -gn) MANOWNER=$(id -un) MANGRP=$(id -gn)
78
79 cp dump/dump.static %{buildroot}%{_sbindir}
80 cp restore/restore.static %{buildroot}%{_sbindir}
81
82 { cd %{buildroot}
83 strip .%{_sbindir}/* || :
84 ln -sf dump .%{_sbindir}/rdump
85 ln -sf dump.static .%{_sbindir}/rdump.static
86 ln -sf restore .%{_sbindir}/rrestore
87 ln -sf restore.static .%{_sbindir}/rrestore.static
88 chmod ug-s .%{_sbindir}/rmt
89 mkdir -p .%{_sysconfdir}
90 > .%{_sysconfdir}/dumpdates
91 ln -sf ..%{_sbindir}/rmt .%{_sysconfdir}/rmt
92 }
93
94 %clean
95 rm -rf %{buildroot}
96
97 %files
98 %defattr(-,root,root)
99 %doc CHANGES COPYRIGHT KNOWNBUGS MAINTAINERS README REPORTING-BUGS THANKS TODO
100 %doc dump.lsm
101 %attr(0664,root,disk) %config(noreplace) %{_sysconfdir}/dumpdates
102 %attr(0755,root,root) %{_sbindir}/dump
103 %{_sbindir}/rdump
104 %attr(0755,root,root) %{_sbindir}/restore
105 %{_sbindir}/rrestore
106 %{_mandir}/man8/dump.*
107 %{_mandir}/man8/rdump.*
108 %{_mandir}/man8/restore.*
109 %{_mandir}/man8/rrestore.*
110
111 %files -n rmt
112 %defattr(-,root,root)
113 %attr(0755,root,root) %{_sbindir}/rmt
114 %{_sysconfdir}/rmt
115 %{_mandir}/man8/rmt.*
116
117 %files -n dump-static
118 %defattr(-,root,root)
119 %attr(0755,root,root) %{_sbindir}/dump.static
120 %{_sbindir}/rdump.static
121 %attr(0755,root,root) %{_sbindir}/restore.static
122 %{_sbindir}/rrestore.static
123
124 %changelog
125 * Sat Jan 30 2001 Stelian Pop <pop@noos.fr>
126 - dump 0.4b21 released, first packaging.
127
128 * Fri Nov 10 2000 Stelian Pop <pop@noos.fr>
129 - dump 0.4b20 released, first packaging.
130
131 * Sun Aug 20 2000 Stelian Pop <pop@noos.fr>
132 - dump 0.4b19 released, first packaging.
133
134 * Thu Jun 30 2000 Stelian Pop <pop@noos.fr>
135 - dump 0.4b18 released, first packaging.
136
137 * Thu Jun 1 2000 Stelian Pop <pop@noos.fr>
138 - dump 0.4b17 released, first packaging.
139
140 * Sat Mar 11 2000 Stelian Pop <pop@noos.fr>
141 - dump 0.4b16 released, first packaging.
142
143 * Thu Mar 2 2000 Stelian Pop <pop@noos.fr>
144 - dump 0.4b15 released, first packaging.
145
146 * Thu Feb 10 2000 Stelian Pop <pop@noos.fr>
147 - dump 0.4b14 released, first packaging.
148
149 * Fri Jan 21 2000 Stelian Pop <pop@noos.fr>
150 - dump 0.4b13 released, first packaging.
151
152 * Fri Jan 8 2000 Stelian Pop <pop@noos.fr>
153 - dump 0.4b12 released, first packaging.
154
155 * Sun Dec 5 1999 Stelian Pop <pop@noos.fr>
156 - dump 0.4b11 released, first packaging.
157
158 * Sun Nov 21 1999 Stelian Pop <pop@noos.fr>
159 - dump 0.4b10 released, first packaging.
160
161 * Thu Nov 11 1999 Stelian Pop <pop@noos.fr>
162 - make static versions also for rescue purposes.
163
164 * Wed Nov 5 1999 Stelian Pop <pop@noos.fr>
165 - dump 0.4b9 released, first packaging.
166
167 * Wed Nov 3 1999 Stelian Pop <pop@noos.fr>
168 - dump 0.4b8 released, first packaging.
169
170 * Thu Oct 8 1999 Stelian Pop <pop@noos.fr>
171 - dump 0.4b7 released, first packaging.
172
173 * Thu Sep 30 1999 Stelian Pop <pop@noos.fr>
174 - dump 0.4b6 released, first packaging.
175
176 * Fri Sep 10 1999 Jeff Johnson <jbj@redhat.com>
177 - recompile with e2fsprogs = 1.15 (#4962).
178
179 * Sat Jul 31 1999 Jeff Johnson <jbj@redhat.com>
180 - workaround egcs bug (#4281) that caused dump problems (#2989).
181 - use sigjmp_buf, not jmp_buf (#3260).
182 - invoke /etc/rmt (instead of rmt) like other unices. (#3272).
183 - use glibc21 err/glob rather than the internal compatibility routines.
184 - wire $(OPT) throughout Makefile's.
185 - fix many printf problems, mostly lint clean.
186 - merge SuSE, Debian and many OpenBSD fixes.
187
188 * Thu Mar 25 1999 Jeff Johnson <jbj@redhat.com>
189 - remove setuid/setgid bits from /sbin/rmt (dump/restore are OK).
190
191 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
192 - auto rebuild in the new build environment (release 6)
193
194 * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
195 - strip binaries.
196
197 * Thu Mar 18 1999 Jeff Johnson <jbj@redhat.com>
198 - Fix dangling symlinks (#1551).
199
200 * Wed Mar 17 1999 Michael Maher <mike@redhat.com>
201 - Top O' the morning, build root's fixed for man pages.
202
203 * Fri Feb 19 1999 Preston Brown <pbrown@redhat.com>
204 - upgraded to dump 0.4b4, massaged patches.
205
206 * Tue Feb 02 1999 Ian A Cameron <I.A.Cameron@open.ac.uk>
207 - added patch from Derrick J Brashear for traverse.c to stop bread errors
208
209 * Wed Jan 20 1999 Jeff Johnson <jbj@redhat.com>
210 - restore original 6755 root.tty to dump/restore, defattr did tty->root (#684).
211 - mark /etc/dumpdates as noreplace.
212
213 * Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
214 - add build root.
215
216 * Tue May 05 1998 Prospector System <bugs@redhat.com>
217 - translations modified for de, fr, tr
218
219 * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
220 - added a patch for resolving linux/types.h and sys/types.h conflicts
221
222 * Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
223 - added prototype of llseek() so dump would work on large partitions
224
225 * Thu Oct 30 1997 Donnie Barnes <djb@redhat.com>
226 - made all symlinks relative instead of absolute
227
228 * Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
229 - built against glibc
230
231 * Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
232 - Moved rmt to its own package.
233
234 * Tue Feb 11 1997 Michael Fulbright <msf@redhat.com>
235 - Added endian cleanups for SPARC
236
237 * Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
238 - Made /etc/dumpdates writeable by group disk.