]> git.wh0rd.org - dump.git/blob - dump.spec
Update the spec file from RedHat.
[dump.git] / dump.spec
1 %define _sbindir /sbin
2 # XXX --enable-kerberos needs krcmd
3 %define myoptions --with-binmode=6755 --with-manowner=root --with-mangrp=root --with-manmode=0644 --with-dumpdates="%{_sysconfdir}/dumpdates" --enable-readline
4
5 Summary: Programs for backing up and restoring filesystems.
6 Name: dump
7 Version: 0.4b21
8 Release: 1
9 License: BSD
10 Group: Applications/Archiving
11 Source: http://download.sourceforge.net/dump/dump-%{version}.tar.gz
12 Requires: rmt
13 BuildRoot: %{_tmppath}/%{name}-root
14
15 %description
16 The dump package contains both dump and restore. Dump examines files in
17 a filesystem, determines which ones need to be backed up, and copies
18 those files to a specified disk, tape or other storage medium. The
19 restore command performs the inverse function of dump; it can restore a
20 full backup of a filesystem. Subsequent incremental backups can then be
21 layered on top of the full backup. Single files and directory subtrees
22 may also be restored from full or partial backups.
23
24 Install dump if you need a system for both backing up filesystems and
25 restoring filesystems after backups.
26
27 %package -n rmt
28 Summary: Provides certain programs with access to remote tape devices.
29 Group: Applications/Archiving
30
31 %description -n rmt
32 The rmt utility provides remote access to tape devices for programs
33 like dump (a filesystem backup program), restore (a program for
34 restoring files from a backup) and tar (an archiving program).
35
36 %package -n dump-static
37 Summary: Statically linked versions of dump and restore.
38 Group: Applications/Archiving
39
40 %description -n dump-static
41 The dump package contains both dump and restore. Dump examines files in
42 a filesystem, determines which ones need to be backed up, and copies
43 those files to a specified disk, tape or other storage medium. The
44 restore command performs the inverse function of dump; it can restore a
45 full backup of a filesystem. Subsequent incremental backups can then be
46 layered on top of the full backup. Single files and directory subtrees
47 may also be restored from full or partial backups.
48
49 Install dump if you need a system for both backing up filesystems and
50 restoring filesystems after backups.
51
52 This packages contains statically linked versions of dump and restore.
53
54 %prep
55 %setup -q
56
57 %build
58 %configure %{myoptions} --enable-static
59
60 make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts"
61
62 mv dump/dump dump/dump.static
63 mv restore/restore restore/restore.static
64
65 make distclean
66
67 %configure %{myoptions} --enable-rmt
68
69 make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts"
70
71 %install
72 rm -rf %{buildroot}
73 mkdir -p %{buildroot}%{_sbindir}
74 mkdir -p %{buildroot}%{_mandir}/man8
75
76 %makeinstall SBINDIR=%{buildroot}%{_sbindir} MANDIR=%{buildroot}%{_mandir}/man8 BINOWNER=$(id -un) BINGRP=$(id -gn) MANOWNER=$(id -un) MANGRP=$(id -gn)
77
78 cp dump/dump.static %{buildroot}%{_sbindir}
79 cp restore/restore.static %{buildroot}%{_sbindir}
80
81 { cd %{buildroot}
82 strip .%{_sbindir}/* || :
83 ln -sf dump .%{_sbindir}/rdump
84 ln -sf dump.static .%{_sbindir}/rdump.static
85 ln -sf restore .%{_sbindir}/rrestore
86 ln -sf restore.static .%{_sbindir}/rrestore.static
87 chmod ug-s .%{_sbindir}/rmt
88 mkdir -p .%{_sysconfdir}
89 > .%{_sysconfdir}/dumpdates
90 ln -sf ..%{_sbindir}/rmt .%{_sysconfdir}/rmt
91 }
92
93 %clean
94 rm -rf %{buildroot}
95
96 %files
97 %defattr(-,root,root)
98 %doc CHANGES COPYRIGHT KNOWNBUGS MAINTAINERS README REPORTING-BUGS THANKS TODO
99 %doc dump.lsm
100 %attr(0664,root,disk) %config(noreplace) %{_sysconfdir}/dumpdates
101 %attr(0755,root,root) %{_sbindir}/dump
102 %{_sbindir}/rdump
103 %attr(0755,root,root) %{_sbindir}/restore
104 %{_sbindir}/rrestore
105 %{_mandir}/man8/dump.*
106 %{_mandir}/man8/rdump.*
107 %{_mandir}/man8/restore.*
108 %{_mandir}/man8/rrestore.*
109
110 %files -n rmt
111 %defattr(-,root,root)
112 %attr(0755,root,root) %{_sbindir}/rmt
113 %{_sysconfdir}/rmt
114 %{_mandir}/man8/rmt.*
115
116 %files -n dump-static
117 %defattr(-,root,root)
118 %attr(0755,root,root) %{_sbindir}/dump.static
119 %{_sbindir}/rdump.static
120 %attr(0755,root,root) %{_sbindir}/restore.static
121 %{_sbindir}/rrestore.static
122
123 %changelog
124 * Sat Jan 30 2001 Stelian Pop <pop@noos.fr>
125 - dump 0.4b21 released, first packaging.
126
127 * Fri Nov 10 2000 Stelian Pop <pop@noos.fr>
128 - dump 0.4b20 released, first packaging.
129
130 * Sun Aug 20 2000 Stelian Pop <pop@noos.fr>
131 - dump 0.4b19 released, first packaging.
132
133 * Thu Jun 30 2000 Stelian Pop <pop@noos.fr>
134 - dump 0.4b18 released, first packaging.
135
136 * Thu Jun 1 2000 Stelian Pop <pop@noos.fr>
137 - dump 0.4b17 released, first packaging.
138
139 * Sat Mar 11 2000 Stelian Pop <pop@noos.fr>
140 - dump 0.4b16 released, first packaging.
141
142 * Thu Mar 2 2000 Stelian Pop <pop@noos.fr>
143 - dump 0.4b15 released, first packaging.
144
145 * Thu Feb 10 2000 Stelian Pop <pop@noos.fr>
146 - dump 0.4b14 released, first packaging.
147
148 * Fri Jan 21 2000 Stelian Pop <pop@noos.fr>
149 - dump 0.4b13 released, first packaging.
150
151 * Fri Jan 8 2000 Stelian Pop <pop@noos.fr>
152 - dump 0.4b12 released, first packaging.
153
154 * Sun Dec 5 1999 Stelian Pop <pop@noos.fr>
155 - dump 0.4b11 released, first packaging.
156
157 * Sun Nov 21 1999 Stelian Pop <pop@noos.fr>
158 - dump 0.4b10 released, first packaging.
159
160 * Thu Nov 11 1999 Stelian Pop <pop@noos.fr>
161 - make static versions also for rescue purposes.
162
163 * Wed Nov 5 1999 Stelian Pop <pop@noos.fr>
164 - dump 0.4b9 released, first packaging.
165
166 * Wed Nov 3 1999 Stelian Pop <pop@noos.fr>
167 - dump 0.4b8 released, first packaging.
168
169 * Thu Oct 8 1999 Stelian Pop <pop@noos.fr>
170 - dump 0.4b7 released, first packaging.
171
172 * Thu Sep 30 1999 Stelian Pop <pop@noos.fr>
173 - dump 0.4b6 released, first packaging.
174
175 * Fri Sep 10 1999 Jeff Johnson <jbj@redhat.com>
176 - recompile with e2fsprogs = 1.15 (#4962).
177
178 * Sat Jul 31 1999 Jeff Johnson <jbj@redhat.com>
179 - workaround egcs bug (#4281) that caused dump problems (#2989).
180 - use sigjmp_buf, not jmp_buf (#3260).
181 - invoke /etc/rmt (instead of rmt) like other unices. (#3272).
182 - use glibc21 err/glob rather than the internal compatibility routines.
183 - wire $(OPT) throughout Makefile's.
184 - fix many printf problems, mostly lint clean.
185 - merge SuSE, Debian and many OpenBSD fixes.
186
187 * Thu Mar 25 1999 Jeff Johnson <jbj@redhat.com>
188 - remove setuid/setgid bits from /sbin/rmt (dump/restore are OK).
189
190 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
191 - auto rebuild in the new build environment (release 6)
192
193 * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
194 - strip binaries.
195
196 * Thu Mar 18 1999 Jeff Johnson <jbj@redhat.com>
197 - Fix dangling symlinks (#1551).
198
199 * Wed Mar 17 1999 Michael Maher <mike@redhat.com>
200 - Top O' the morning, build root's fixed for man pages.
201
202 * Fri Feb 19 1999 Preston Brown <pbrown@redhat.com>
203 - upgraded to dump 0.4b4, massaged patches.
204
205 * Tue Feb 02 1999 Ian A Cameron <I.A.Cameron@open.ac.uk>
206 - added patch from Derrick J Brashear for traverse.c to stop bread errors
207
208 * Wed Jan 20 1999 Jeff Johnson <jbj@redhat.com>
209 - restore original 6755 root.tty to dump/restore, defattr did tty->root (#684).
210 - mark /etc/dumpdates as noreplace.
211
212 * Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
213 - add build root.
214
215 * Tue May 05 1998 Prospector System <bugs@redhat.com>
216 - translations modified for de, fr, tr
217
218 * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
219 - added a patch for resolving linux/types.h and sys/types.h conflicts
220
221 * Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
222 - added prototype of llseek() so dump would work on large partitions
223
224 * Thu Oct 30 1997 Donnie Barnes <djb@redhat.com>
225 - made all symlinks relative instead of absolute
226
227 * Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
228 - built against glibc
229
230 * Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
231 - Moved rmt to its own package.
232
233 * Tue Feb 11 1997 Michael Fulbright <msf@redhat.com>
234 - Added endian cleanups for SPARC
235
236 * Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
237 - Made /etc/dumpdates writeable by group disk.