]> git.wh0rd.org - dump.git/blob - dump.spec
Update the location of dump home page (to the sourceforge one).
[dump.git] / dump.spec
1 Summary: Programs for backing up and restoring filesystems.
2 Name: dump
3 Version: 0.4b12
4 Release: 1
5 Copyright: UCB
6 Group: Applications/Archiving
7 Source: http://sourceforge.net/download.php/dump/dump-%{version}.tar.gz
8 Requires: rmt
9 BuildRoot: /var/tmp/%{name}-root
10
11 %description
12 The dump package contains both dump and restore. Dump examines files in
13 a filesystem, determines which ones need to be backed up, and copies
14 those files to a specified disk, tape or other storage medium. The
15 restore command performs the inverse function of dump; it can restore a
16 full backup of a filesystem. Subsequent incremental backups can then be
17 layered on top of the full backup. Single files and directory subtrees
18 may also be restored from full or partial backups.
19
20 Install dump if you need a system for both backing up filesystems and
21 restoring filesystems after backups.
22
23 %package -n rmt
24 Summary: Provides certain programs with access to remote tape devices.
25 Group: Applications/Archiving
26
27 %description -n rmt
28 The rmt utility provides remote access to tape devices for programs
29 like dump (a filesystem backup program), restore (a program for
30 restoring files from a backup) and tar (an archiving program).
31
32 %package -n dump-static
33 Summary: Programs for backing up and restoring filesystems.
34 Group: Applications/Archiving
35
36 %description -n dump-static
37 The dump package contains both dump and restore. Dump examines files in
38 a filesystem, determines which ones need to be backed up, and copies
39 those files to a specified disk, tape or other storage medium. The
40 restore command performs the inverse function of dump; it can restore a
41 full backup of a filesystem. Subsequent incremental backups can then be
42 layered on top of the full backup. Single files and directory subtrees
43 may also be restored from full or partial backups.
44
45 Install dump if you need a system for both backing up filesystems and
46 restoring filesystems after backups.
47
48 This packages contains statically linked versions of dump and restore.
49
50 %prep
51 %setup -q
52
53 %build
54
55 %configure --with-binmode=6755 --with-manowner=root --with-mangrp=root --with-manmode=0644 --enable-static
56
57 make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts"
58
59 mv dump/dump dump/dump.static
60 mv restore/restore restore/restore.static
61
62 make distclean
63
64 %configure --with-binmode=6755 --with-manowner=root --with-mangrp=root --with-manmode=0644 --enable-rmt
65
66 make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts"
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 mkdir -p $RPM_BUILD_ROOT/sbin
71 mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/man/man8
72
73 make install BINDIR=$RPM_BUILD_ROOT/sbin MANDIR=${RPM_BUILD_ROOT}%{_prefix}/man/man8 BINOWNER=$(id -un) BINGRP=$(id -gn) MANOWNER=$(id -un) MANGRP=$(id -gn)
74
75 cp dump/dump.static $RPM_BUILD_ROOT/sbin
76 cp restore/restore.static $RPM_BUILD_ROOT/sbin
77
78 { cd $RPM_BUILD_ROOT
79 strip ./sbin/* || :
80 ln -sf dump ./sbin/rdump
81 ln -sf dump.static ./sbin/rdump.static
82 ln -sf restore ./sbin/rrestore
83 ln -sf restore.static ./sbin/rrestore.static
84 chmod ug-s ./sbin/rmt
85 mkdir -p ./etc
86 > ./etc/dumpdates
87 ln -sf ../sbin/rmt ./etc/rmt
88 }
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files
94 %defattr(-,root,root)
95 %doc CHANGES COPYRIGHT KNOWNBUGS MAINTAINERS README THANKS TODO dump.lsm
96 %attr(0664,root,disk) %config(noreplace) /etc/dumpdates
97 %attr(6755,root,tty) /sbin/dump
98 /sbin/rdump
99 %attr(6755,root,tty) /sbin/restore
100 /sbin/rrestore
101 %{_prefix}/man/man8/dump.8
102 %{_prefix}/man/man8/rdump.8
103 %{_prefix}/man/man8/restore.8
104 %{_prefix}/man/man8/rrestore.8
105
106 %files -n rmt
107 %defattr(-,root,root)
108 %attr(0755,root,root) /sbin/rmt
109 /etc/rmt
110 %{_prefix}/man/man8/rmt.8
111
112 %files -n dump-static
113 %defattr(-,root,root)
114 %attr(6755,root,tty) /sbin/dump.static
115 /sbin/rdump.static
116 %attr(6755,root,tty) /sbin/restore.static
117 /sbin/rrestore.static
118
119 %changelog
120 * Fri Jan 8 2000 Stelian Pop <pop@cybercable.fr>
121 - dump 0.4b12 released, first packaging.
122
123 * Sun Dec 5 1999 Stelian Pop <pop@cybercable.fr>
124 - dump 0.4b11 released, first packaging.
125
126 * Sun Nov 21 1999 Stelian Pop <pop@cybercable.fr>
127 - dump 0.4b10 released, first packaging.
128
129 * Thu Nov 11 1999 Stelian Pop <pop@cybercable.fr>
130 - make static versions also for rescue purposes.
131
132 * Wed Nov 5 1999 Stelian Pop <pop@cybercable.fr>
133 - dump 0.4b9 released, first packaging.
134
135 * Wed Nov 3 1999 Stelian Pop <pop@cybercable.fr>
136 - dump 0.4b8 released, first packaging.
137
138 * Thu Oct 8 1999 Stelian Pop <pop@cybercable.fr>
139 - dump 0.4b7 released, first packaging.
140
141 * Thu Sep 30 1999 Stelian Pop <pop@cybercable.fr>
142 - dump 0.4b6 released, first packaging.
143
144 * Fri Sep 10 1999 Jeff Johnson <jbj@redhat.com>
145 - recompile with e2fsprogs = 1.15 (#4962).
146
147 * Sat Jul 31 1999 Jeff Johnson <jbj@redhat.com>
148 - workaround egcs bug (#4281) that caused dump problems (#2989).
149 - use sigjmp_buf, not jmp_buf (#3260).
150 - invoke /etc/rmt (instead of rmt) like other unices. (#3272).
151 - use glibc21 err/glob rather than the internal compatibility routines.
152 - wire $(OPT) throughout Makefile's.
153 - fix many printf problems, mostly lint clean.
154 - merge SuSE, Debian and many OpenBSD fixes.
155
156 * Thu Mar 25 1999 Jeff Johnson <jbj@redhat.com>
157 - remove setuid/setgid bits from /sbin/rmt (dump/restore are OK).
158
159 * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
160 - auto rebuild in the new build environment (release 6)
161
162 * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
163 - strip binaries.
164
165 * Thu Mar 18 1999 Jeff Johnson <jbj@redhat.com>
166 - Fix dangling symlinks (#1551).
167
168 * Wed Mar 17 1999 Michael Maher <mike@redhat.com>
169 - Top O' the morning, build root's fixed for man pages.
170
171 * Fri Feb 19 1999 Preston Brown <pbrown@redhat.com>
172 - upgraded to dump 0.4b4, massaged patches.
173
174 * Tue Feb 02 1999 Ian A Cameron <I.A.Cameron@open.ac.uk>
175 - added patch from Derrick J Brashear for traverse.c to stop bread errors
176
177 * Wed Jan 20 1999 Jeff Johnson <jbj@redhat.com>
178 - restore original 6755 root.tty to dump/restore, defattr did tty->root (#684).
179 - mark /etc/dumpdates as noreplace.
180
181 * Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
182 - add build root.
183
184 * Tue May 05 1998 Prospector System <bugs@redhat.com>
185 - translations modified for de, fr, tr
186
187 * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
188 - added a patch for resolving linux/types.h and sys/types.h conflicts
189
190 * Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
191 - added prototype of llseek() so dump would work on large partitions
192
193 * Thu Oct 30 1997 Donnie Barnes <djb@redhat.com>
194 - made all symlinks relative instead of absolute
195
196 * Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
197 - built against glibc
198
199 * Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
200 - Moved rmt to its own package.
201
202 * Tue Feb 11 1997 Michael Fulbright <msf@redhat.com>
203 - Added endian cleanups for SPARC
204
205 * Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
206 - Made /etc/dumpdates writeable by group disk.