]> git.wh0rd.org - dump.git/blobdiff - dump.spec
Improvements to cron_dump_to_disk
[dump.git] / dump.spec
index fbfaaabb6a6840ed980c23198fc56867dcb40e27..8276ecd1109953b5b039204f0a3e5f421d20d2f4 100644 (file)
--- a/dump.spec
+++ b/dump.spec
@@ -1,21 +1,29 @@
-Summary: Programs for backing up and restoring filesystems.
+%define        _sbindir /sbin
+# XXX --enable-kerberos                needs krcmd
+%define        myoptions --with-binmode=6755 --with-manowner=root --with-mangrp=root --with-manmode=0644 --with-dumpdates="%{_sysconfdir}/dumpdates"
+
+Summary: Programs for backing up and restoring ext2/ext3 filesystems.
 Name: dump
-Version: 0.4b13
+Version: 0.4b41
 Release: 1
-Copyright: UCB
+License: BSD
+URL: http://dump.sourceforge.net
 Group: Applications/Archiving
-Source: http://sourceforge.net/download.php/dump/dump-%{version}.tar.gz
+Source: dump-%{version}.tar.gz
+BuildPrereq: e2fsprogs-devel >= 1.18
+BuildPrereq: libtermcap-devel, readline-devel, ncurses-devel
+BuildPrereq: zlib-devel, bzip2-devel
 Requires: rmt
-BuildRoot: /var/tmp/%{name}-root
+BuildRoot: %{_tmppath}/%{name}-root
 
 %description
-The dump package contains both dump and restore.  Dump examines files in
-a filesystem, determines which ones need to be backed up, and copies
-those files to a specified disk, tape or other storage medium.  The
-restore command performs the inverse function of dump; it can restore a
-full backup of a filesystem.  Subsequent incremental backups can then be
-layered on top of the full backup.  Single files and directory subtrees
-may also be restored from full or partial backups.
+The dump package contains both dump and restore. Dump examines files
+in a filesystem, determines which ones need to be backed up, and
+copies those files to a specified disk, tape, or other storage medium.
+The restore command performs the inverse function of dump; it can
+restore a full backup of a filesystem. Subsequent incremental backups
+can then be layered on top of the full backup. Single files and
+directory subtrees may also be restored from full or partial backups.
 
 Install dump if you need a system for both backing up filesystems and
 restoring filesystems after backups.
@@ -27,121 +35,213 @@ Group: Applications/Archiving
 %description -n rmt
 The rmt utility provides remote access to tape devices for programs
 like dump (a filesystem backup program), restore (a program for
-restoring files from a backup) and tar (an archiving program).
+restoring files from a backup), and tar (an archiving program).
 
 %package -n dump-static
-Summary: Programs for backing up and restoring filesystems.
+Summary: Statically linked versions of dump and restore.
 Group: Applications/Archiving
 
 %description -n dump-static
-The dump package contains both dump and restore.  Dump examines files in
+The dump package contains both dump and restore. Dump examines files in
 a filesystem, determines which ones need to be backed up, and copies
-those files to a specified disk, tape or other storage medium.  The
+those files to a specified disk, tape, or other storage medium. The
 restore command performs the inverse function of dump; it can restore a
-full backup of a filesystem.  Subsequent incremental backups can then be
-layered on top of the full backup.  Single files and directory subtrees
+full backup of a filesystem. Subsequent incremental backups can then be
+layered on top of the full backup. Single files and directory subtrees
 may also be restored from full or partial backups.
 
 Install dump if you need a system for both backing up filesystems and
 restoring filesystems after backups.
 
-This packages contains statically linked versions of dump and restore.
+This package contains statically linked versions of dump and restore.
 
 %prep
 %setup -q
 
 %build
+%configure %{myoptions} --enable-static -disable-rmt
 
-%configure --with-binmode=6755 --with-manowner=root --with-mangrp=root --with-manmode=0644 --enable-static
-
-make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts"
+%ifarch alpha
+RPM_OPT_FLAGS=""
+%endif
+make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes \
+                         -Wmissing-prototypes -Wno-char-subscripts"
 
 mv dump/dump dump/dump.static
 mv restore/restore restore/restore.static
 
 make distclean
 
-%configure --with-binmode=6755 --with-manowner=root --with-mangrp=root --with-manmode=0644 --enable-rmt
+%configure %{myoptions}
 
-make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts"
+make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes \
+                         -Wmissing-prototypes -Wno-char-subscripts"
 
 %install
-rm -rf $RPM_BUILD_ROOT
-mkdir -p $RPM_BUILD_ROOT/sbin
-mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/man/man8
-
-make install BINDIR=$RPM_BUILD_ROOT/sbin MANDIR=${RPM_BUILD_ROOT}%{_prefix}/man/man8 BINOWNER=$(id -un) BINGRP=$(id -gn) MANOWNER=$(id -un) MANGRP=$(id -gn)
-
-cp dump/dump.static $RPM_BUILD_ROOT/sbin
-cp restore/restore.static $RPM_BUILD_ROOT/sbin
-
-{ cd $RPM_BUILD_ROOT
-  strip ./sbin/* || :
-  ln -sf dump ./sbin/rdump
-  ln -sf dump.static ./sbin/rdump.static
-  ln -sf restore ./sbin/rrestore
-  ln -sf restore.static ./sbin/rrestore.static
-  chmod ug-s ./sbin/rmt
-  mkdir -p ./etc
-  > ./etc/dumpdates
-  ln -sf ../sbin/rmt ./etc/rmt
-}
+rm -rf %{buildroot}
+mkdir -p %{buildroot}%{_sbindir}
+mkdir -p %{buildroot}%{_mandir}/man8
+
+%makeinstall SBINDIR=%{buildroot}%{_sbindir} MANDIR=%{buildroot}%{_mandir}/man8 BINOWNER=$(id -un) BINGRP=$(id -gn) MANOWNER=$(id -un) MANGRP=$(id -gn)
+mkdir -p $RPM_BUILD_ROOT/usr/sbin
+
+cp dump/dump.static %{buildroot}%{_sbindir}
+cp restore/restore.static %{buildroot}%{_sbindir}
+
+pushd $RPM_BUILD_ROOT
+  ln -sf dump .%{_sbindir}/rdump
+  ln -sf dump.static .%{_sbindir}/rdump.static
+  ln -sf restore .%{_sbindir}/rrestore
+  ln -sf restore.static .%{_sbindir}/rrestore.static
+  chmod ug-s .%{_sbindir}/rmt
+  mkdir -p .%{_sysconfdir}
+  > .%{_sysconfdir}/dumpdates
+  ln -sf ..%{_sbindir}/rmt .%{_sysconfdir}/rmt
+  # quick workaround :)
+  mv sbin/* usr/sbin/
+  mv usr/sbin/*static sbin/
+  mv usr/sbin/rmt sbin/
+  # somehow, rpm didn't strip these...
+  strip usr/sbin/* sbin/* || :  
+popd
 
 %clean
-rm -rf $RPM_BUILD_ROOT
+rm -rf %{buildroot}
 
 %files
 %defattr(-,root,root)
-%doc CHANGES COPYRIGHT KNOWNBUGS MAINTAINERS README THANKS TODO dump.lsm
-%attr(0664,root,disk)  %config(noreplace) /etc/dumpdates
-%attr(6755,root,tty)   /sbin/dump
-/sbin/rdump
-%attr(6755,root,tty)   /sbin/restore
-/sbin/rrestore
-%{_prefix}/man/man8/dump.8
-%{_prefix}/man/man8/rdump.8
-%{_prefix}/man/man8/restore.8
-%{_prefix}/man/man8/rrestore.8
+%doc CHANGES COPYRIGHT KNOWNBUGS MAINTAINERS README REPORTING-BUGS THANKS TODO
+%doc dump.lsm examples
+%attr(0664,root,disk)  %config(noreplace) %{_sysconfdir}/dumpdates
+%attr(0755,root,root)  /usr/sbin/dump
+/usr/sbin/rdump
+%attr(0755,root,root)  /usr/sbin/restore
+/usr/sbin/rrestore
+%{_mandir}/man8/dump.*
+%{_mandir}/man8/rdump.*
+%{_mandir}/man8/restore.*
+%{_mandir}/man8/rrestore.*
 
 %files -n rmt
 %defattr(-,root,root)
-%attr(0755,root,root)  /sbin/rmt
-/etc/rmt
-%{_prefix}/man/man8/rmt.8 
+%attr(0755,root,root)  %{_sbindir}/rmt
+%{_sysconfdir}/rmt
+%{_mandir}/man8/rmt.*
 
 %files -n dump-static
 %defattr(-,root,root)
-%attr(6755,root,tty)   /sbin/dump.static
-/sbin/rdump.static
-%attr(6755,root,tty)   /sbin/restore.static
-/sbin/rrestore.static
+%attr(0755,root,root)  %{_sbindir}/dump.static
+%{_sbindir}/rdump.static
+%attr(0755,root,root)  %{_sbindir}/restore.static
+%{_sbindir}/rrestore.static
 
 %changelog
-* Fri Jan 21 2000 Stelian Pop <pop@cybercable.fr>
+* Mon Jan  2 2006 Stelian Pop <stelian@popies.net>
+- dump 0.4b41 released, first packaging.
+
+* Fri Jan 21 2005 Stelian Pop <stelian@popies.net>
+- dump 0.4b39 released, first packaging.
+
+* Fri Jan  7 2005 Stelian Pop <stelian@popies.net>
+- dump 0.4b38 released, first packaging.
+
+* Wed Jul  7 2004 Stelian Pop <stelian@popies.net>
+- dump 0.4b37 released, first packaging.
+
+* Wed Apr 21 2004 Stelian Pop <stelian@popies.net>
+- dump 0.4b36 released, first packaging.
+
+* Sun Dec 21 2003 Stelian Pop <stelian@popies.net>
+- dump 0.4b35 released, first packaging.
+
+* Fri Apr 18 2003 Stelian Pop <stelian@popies.net>
+- dump 0.4b34 released, first packaging.
+
+* Mon Feb 10 2003 Stelian Pop <stelian@popies.net>
+- dump 0.4b33 released, first packaging.
+
+* Fri Nov 15 2002 Stelian Pop <stelian@popies.net>
+- dump 0.4b32 released, first packaging.
+
+* Tue Jul 30 2002 Stelian Pop <stelian@popies.net>
+- dump 0.4b31 released, first packaging.
+
+* Thu Jul 25 2002 Stelian Pop <stelian@popies.net>
+- dump 0.4b30 released, first packaging.
+
+* Sat Jun  8 2002 Stelian Pop <stelian@popies.net>
+- dump 0.4b29 released, first packaging.
+
+* Fri Apr 12 2002 Stelian Pop <stelian@popies.net>
+- dump 0.4b28 released, first packaging.
+
+* Fri Feb 15 2002 Stelian Pop <stelian@popies.net>
+- dump 0.4b27 released, first packaging.
+
+* Mon Jan  7 2002 Stelian Pop <stelian@popies.net>
+- dump 0.4b26 released, first packaging.
+
+* Sat Nov 17 2001 Stelian Pop <stelian@popies.net>
+- dump 0.4b25 released, first packaging.
+
+* Wed Sep 12 2001 Stelian Pop <stelian@popies.net>
+- dump 0.4b24 released, first packaging.
+
+* Fri Jul 20 2001 Stelian Pop <stelian@popies.net>
+- dump 0.4b23 released, first packaging.
+
+* Sat May 12 2001 Stelian Pop <stelian@popies.net>
+- dump 0.4b22 released, first packaging.
+
+* Sat Jan 30 2001 Stelian Pop <stelian@popies.net>
+- dump 0.4b21 released, first packaging.
+
+* Fri Nov 10 2000 Stelian Pop <stelian@popies.net>
+- dump 0.4b20 released, first packaging.
+
+* Sun Aug 20 2000 Stelian Pop <stelian@popies.net>
+- dump 0.4b19 released, first packaging.
+
+* Thu Jun 30 2000 Stelian Pop <stelian@popies.net>
+- dump 0.4b18 released, first packaging.
+
+* Thu Jun  1 2000 Stelian Pop <stelian@popies.net>
+- dump 0.4b17 released, first packaging.
+
+* Sat Mar 11 2000 Stelian Pop <stelian@popies.net>
+- dump 0.4b16 released, first packaging.
+
+* Thu Mar  2 2000 Stelian Pop <stelian@popies.net>
+- dump 0.4b15 released, first packaging.
+
+* Thu Feb 10 2000 Stelian Pop <stelian@popies.net>
+- dump 0.4b14 released, first packaging.
+
+* Fri Jan 21 2000 Stelian Pop <stelian@popies.net>
 - dump 0.4b13 released, first packaging.
 
-* Fri Jan 8 2000 Stelian Pop <pop@cybercable.fr>
+* Fri Jan 8 2000 Stelian Pop <stelian@popies.net>
 - dump 0.4b12 released, first packaging.
 
-* Sun Dec 5 1999 Stelian Pop <pop@cybercable.fr>
+* Sun Dec 5 1999 Stelian Pop <stelian@popies.net>
 - dump 0.4b11 released, first packaging.
 
-* Sun Nov 21 1999 Stelian Pop <pop@cybercable.fr>
+* Sun Nov 21 1999 Stelian Pop <stelian@popies.net>
 - dump 0.4b10 released, first packaging.
 
-* Thu Nov 11 1999 Stelian Pop <pop@cybercable.fr>
+* Thu Nov 11 1999 Stelian Pop <stelian@popies.net>
 - make static versions also for rescue purposes.
 
-* Wed Nov 5 1999 Stelian Pop <pop@cybercable.fr>
+* Wed Nov 5 1999 Stelian Pop <stelian@popies.net>
 - dump 0.4b9 released, first packaging.
 
-* Wed Nov 3 1999 Stelian Pop <pop@cybercable.fr>
+* Wed Nov 3 1999 Stelian Pop <stelian@popies.net>
 - dump 0.4b8 released, first packaging.
 
-* Thu Oct 8 1999 Stelian Pop <pop@cybercable.fr>
+* Thu Oct 8 1999 Stelian Pop <stelian@popies.net>
 - dump 0.4b7 released, first packaging.
 
-* Thu Sep 30 1999 Stelian Pop <pop@cybercable.fr>
+* Thu Sep 30 1999 Stelian Pop <stelian@popies.net>
 - dump 0.4b6 released, first packaging.
 
 * Fri Sep 10 1999 Jeff Johnson <jbj@redhat.com>