initial import
[patches.git] / gcc-libtool-generic-linux.patch
1 2006-04-10 Mike Frysinger <vapier@gentoo.org>
2
3 * libtool.m4: Accept linux* instead of just linux-gnu*.
4 * ltconfig: Likewise. Also accept linux-uclibc* as well as linux-gnu*.
5
6 --- libtool.m4
7 +++ libtool.m4
8 @@ -739,7 +739,7 @@
9 ;;
10
11 # This must be Linux ELF.
12 -linux-gnu*)
13 +linux*)
14 lt_cv_deplibs_check_method=pass_all
15 ;;
16
17 --- ltconfig
18 +++ ltconfig
19 @@ -603,7 +603,7 @@
20
21 # Transform linux* to *-*-linux-gnu*, to support old configure scripts.
22 case $host_os in
23 -linux-gnu*) ;;
24 +linux-gnu*|linux-uclibc*) ;;
25 linux*) host=`echo $host | sed 's/^\(.*-.*-linux\)\(.*\)$/\1-gnu\2/'`
26 esac
27
28 @@ -1251,7 +1251,7 @@
29 ;;
30
31 # This must be Linux ELF.
32 -linux-gnu*)
33 +linux*)
34 version_type=linux
35 need_lib_prefix=no
36 need_version=no