]> git.wh0rd.org - fontconfig.git/blobdiff - conf.d/Makefile.am
Bug 43321 - Required corrections in urdu.orth file
[fontconfig.git] / conf.d / Makefile.am
index 7aca24642c1ba5bdf9b6ad9f3464ce637fd7dc54..3f5255fadb30fb3c51c161ef783e0156eb7624f4 100644 (file)
@@ -1,5 +1,5 @@
 # 
-#  $Id$
+#  fontconfig/conf.d/Makefile.am
 # 
 #  Copyright © 2005 Keith Packard
 # 
@@ -7,22 +7,24 @@
 #  documentation for any purpose is hereby granted without fee, provided that
 #  the above copyright notice appear in all copies and that both that
 #  copyright notice and this permission notice appear in supporting
-#  documentation, and that the name of Keith Packard not be used in
+#  documentation, and that the name of the author(s) not be used in
 #  advertising or publicity pertaining to distribution of the software without
-#  specific, written prior permission.  Keith Packard makes no
+#  specific, written prior permission.  The authors make no
 #  representations about the suitability of this software for any purpose.  It
 #  is provided "as is" without express or implied warranty.
 # 
-#  KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+#  THE AUTHOR(S) DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
 #  INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
-#  EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+#  EVENT SHALL THE AUTHOR(S) BE LIABLE FOR ANY SPECIAL, INDIRECT OR
 #  CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
 #  DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
 #  TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
 #  PERFORMANCE OF THIS SOFTWARE.
 
+DOC_FILES= \
+       README
+
 CONF_FILES = \
-       README \
        10-autohint.conf \
        10-no-sub-pixel.conf \
        10-sub-pixel-bgr.conf \
@@ -42,6 +44,7 @@ CONF_FILES = \
        51-local.conf \
        60-latin.conf \
        65-fonts-persian.conf \
+       65-khmer.conf \
        65-nonlatin.conf \
        69-unifont.conf \
        70-no-bitmaps.conf \
@@ -66,13 +69,14 @@ CONF_LINKS = \
        80-delicious.conf \
        90-synthetic.conf
 
-EXTRA_DIST = $(CONF_FILES)
+EXTRA_DIST = $(CONF_FILES) $(DOC_FILES)
 
 configdir=$(CONFDIR)
 confavaildir=$(configdir)/conf.avail
 confddir=$(configdir)/conf.d
 
 confavail_DATA=$(CONF_FILES)
+confd_DATA=$(DOC_FILES)
 
 install-data-local:
        mkdir -p ${DESTDIR}${confddir}
@@ -83,3 +87,10 @@ install-data-local:
                echo rm -f $$i";" ln -s ../conf.avail/$$i .; \
                ln -s ../conf.avail/$$i .; \
         done)
+uninstall-local:
+       @(echo cd ${DESTDIR}${confddir}; \
+        cd ${DESTDIR}${confddir}; \
+        for i in ${CONF_LINKS}; do \
+               echo rm -f $$i; \
+               rm -f $$i; \
+        done)