]> git.wh0rd.org - fontconfig.git/blobdiff - doc/Makefile.am
Replace 'KEITH PACKARD' with 'THE AUTHOR(S)' in license text in all files
[fontconfig.git] / doc / Makefile.am
index 622de9b21ca1b7b2fc549eb707ae630b2aa289a2..8bf1ba13e43c4b35ed1725c428babfe2a02cc92b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# $Id$
+# fontconfig/doc/Makefile.am
 #
 # Copyright © 2003 Keith Packard
 #
@@ -13,9 +13,9 @@
 # representations about the suitability of this software for any purpose.  It
 # is provided "as is" without express or implied warranty.
 #
-# KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# THE AUTHOR(S) DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
 # INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
-# EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# EVENT SHALL THE AUTHOR(S) BE LIABLE FOR ANY SPECIAL, INDIRECT OR
 # CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
 # DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
 # TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
@@ -42,13 +42,16 @@ FNCS_TMPL = ${DOC_SRC}/func.sgml
 DOC_FUNCS_FNCS=\
        fcatomic.fncs \
        fcblanks.fncs \
+       fccache.fncs \
        fccharset.fncs \
        fcconfig.fncs \
        fcconstant.fncs \
+       fcdircache.fncs \
        fcfile.fncs \
        fcfontset.fncs \
        fcfreetype.fncs \
        fcinit.fncs \
+       fclangset.fncs \
        fcmatrix.fncs \
        fcobjectset.fncs \
        fcobjecttype.fncs \
@@ -60,13 +63,16 @@ DOC_FUNCS_FNCS=\
 DOC_FUNCS_SGML=\
        fcatomic.sgml \
        fcblanks.sgml \
+       fccache.sgml \
        fccharset.sgml \
        fcconfig.sgml \
        fcconstant.sgml \
+       fcdircache.sgml \
        fcfile.sgml \
        fcfontset.sgml \
        fcfreetype.sgml \
        fcinit.sgml \
+       fclangset.sgml \
        fcmatrix.sgml \
        fcobjectset.sgml \
        fcobjecttype.sgml \
@@ -75,7 +81,8 @@ DOC_FUNCS_SGML=\
        fcstrset.sgml \
        fcvalue.sgml
 
-man_MANS=fonts-conf.5 @DOCMAN3@
+man5_MANS=fonts-conf.5 
+man3_MANS=$(DOCMAN3)
 
 noinst_PROGRAMS=edit-sgml
 edit_sgml_SOURCES=edit-sgml.c
@@ -83,9 +90,13 @@ edit_sgml_SOURCES=edit-sgml.c
 docdir=@DOCDIR@
 
 DOC_FILES=$(TXT) $(PDF) $(HTML_FILES)
-LOCAL_DOCS=$(man_MANS) $(DOC_FILES) $(HTML_DIR)/*
+LOCAL_DOCS=$(man3_MANS) $(man5_MANS) $(DOC_FILES) $(HTML_DIR)/*
 
-EXTRA_DIST=$(LOCAL_DOCS) $(SGML) $(DOC_FUNCS_FNCS) $(FNCS_TMPL) confdir.sgml.in
+check_SCRIPTS=check-missing-doc
+TESTS_ENVIRONMENT=top_srcdir=${top_srcdir} sh
+TESTS=check-missing-doc
+
+EXTRA_DIST=$(LOCAL_DOCS) $(SGML) $(DOC_FUNCS_FNCS) $(check_SCRIPTS) func.sgml confdir.sgml.in
 
 SUFFIXES=.fncs .sgml .txt .html
 
@@ -103,13 +114,15 @@ if USEDOCBOOK
        $(RM) $@
        $(DOC2PDF) $<
 
-$(man_MANS): func.refs
+$(man3_MANS): func.refs
 
 func.refs: local-fontconfig-devel.sgml $(DOC_FUNCS_SGML) version.sgml confdir.sgml
        $(RM) func.refs
-       $(DOC2MAN) local-fontconfig-devel.sgml
-       mv manpage.refs func.refs
-       $(RM) manpage.links
+       $(DOC2MAN) -o devel-man local-fontconfig-devel.sgml && \
+       mv devel-man/manpage.refs func.refs && \
+       mv devel-man/*.3 . && \
+       $(RM) devel-man/manpage.* && \
+       rmdir devel-man
 
 local-fontconfig-devel.sgml: fontconfig-devel.sgml
        $(LN_S) $< $@
@@ -118,8 +131,8 @@ $(DOC_FUNCS_SGML): edit-sgml$(EXEEXT) $(FNCS_TMPL)
 
 fonts-conf.5: local-fontconfig-user.sgml version.sgml confdir.sgml
        $(RM) $@
-       $(DOC2MAN) local-fontconfig-user.sgml
-       $(RM) manpage.refs manpage.links
+       $(DOC2MAN) local-fontconfig-user.sgml && \
+       $(RM) manpage.*
        
 local-fontconfig-user.sgml: fontconfig-user.sgml
        $(LN_S) $< $@
@@ -127,22 +140,23 @@ local-fontconfig-user.sgml: fontconfig-user.sgml
 all-local: $(LOCAL_DOCS)
 
 clean-local:
-       $(RM) $(man_MANS) $(DOC_FILES) $(DOC_FUNCS_SGML) func.refs
+       $(RM) $(man3_MANS) $(man5_MANS) $(DOC_FILES) $(DOC_FUNCS_SGML) func.refs
        $(RM) -r $(HTML_DIR)
 
 $(HTML_DIR): local-fontconfig-devel.sgml $(DOC_FUNCS_SGML) version.sgml confdir.sgml
        $(RM) -r $(HTML_DIR)
-       $(DOC2HTML) -o $(HTML_DIR) local-fontconfig-devel.sgml
+       $(DOC2HTML) -V '%use-id-as-filename%' -o $(HTML_DIR) local-fontconfig-devel.sgml
 
-fontconfig-devel.txt: local-fontconfig-devel.sgml version.sgml confdir.sgml
+fontconfig-devel.txt: local-fontconfig-devel.sgml $(DOC_FUNCS_SGML) version.sgml confdir.sgml
        $(RM) $@
        $(DOC2TXT) local-fontconfig-devel.sgml
        mv local-fontconfig-devel.txt $@
 
-fontconfig-devel.pdf: local-fontconfig-devel.sgml version.sgml confdir.sgml
+fontconfig-devel.pdf: local-fontconfig-devel.sgml $(DOC_FUNCS_SGML) version.sgml confdir.sgml
        $(RM) $@
-       $(DOC2PDF) local-fontconfig-devel.sgml
-       mv local-fontconfig-devel.pdf $@
+       $(top_srcdir)/missing --run $(DOC2PDF) $< && mv local-$@ $@ \
+       || echo Failed to generate $@ >&2; \
+       (test -f $@ || echo $(DOC2PDF) is required to generate this file >> $@)
 
 fontconfig-user.html: local-fontconfig-user.sgml version.sgml confdir.sgml
        $(RM) $@ local-$@ $@.tmp
@@ -158,8 +172,9 @@ fontconfig-user.txt: local-fontconfig-user.sgml version.sgml confdir.sgml
 
 fontconfig-user.pdf: local-fontconfig-user.sgml version.sgml confdir.sgml
        $(RM) $@
-       $(DOC2PDF) local-fontconfig-user.sgml
-       mv local-fontconfig-user.pdf $@
+       $(top_srcdir)/missing --run $(DOC2PDF) $< && mv local-$@ $@ \
+       || echo Failed to generate $@ >&2; \
+       (test -f $@ || echo $(DOC2PDF) is required to generate this file >> $@)
 
 STRIPNL=awk '{ if (NR > 1) printf ("\n"); printf ("%s", $$0); }'
 confdir.sgml: ${DOC_SRC}/confdir.sgml.in
@@ -167,7 +182,14 @@ confdir.sgml: ${DOC_SRC}/confdir.sgml.in
 
 CLEANFILES=confdir.sgml local-fontconfig-user.sgml local-fontconfig-devel.sgml
 
+htmldoc_DATA = $(HTML_DIR)/*
+
+$(HTML_DIR)/*: $(HTML_DIR)
+
 else
+
+htmldoc_DATA = $(srcdir)/$(HTML_DIR)/*
+
 all-local:
 clean-local:
 endif
@@ -176,6 +198,3 @@ htmldocdir=$(docdir)/$(HTML_DIR)
 
 doc_DATA = $(DOC_FILES)
 
-htmldoc_DATA = $(HTML_DIR)/*
-
-$(HTML_DIR)/*: $(HTML_DIR)