]> git.wh0rd.org - fontconfig.git/blobdiff - doc/Makefile.am
Document FcPatternFormat() format
[fontconfig.git] / doc / Makefile.am
index b7c28123888b4c69e56af7af4dbbfea8f07d33a7..9ffd54fcf3398556d8ece0a99d9b65a26a0f5360 100644 (file)
@@ -1,5 +1,5 @@
 #
-# $Id$
+# fontconfig/doc/Makefile.am
 #
 # Copyright © 2003 Keith Packard
 #
@@ -13,9 +13,9 @@
 # representations about the suitability of this software for any purpose.  It
 # is provided "as is" without express or implied warranty.
 #
-# KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# THE AUTHOR(S) DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
 # INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
-# EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# EVENT SHALL THE AUTHOR(S) BE LIABLE FOR ANY SPECIAL, INDIRECT OR
 # CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
 # DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
 # TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
@@ -49,6 +49,7 @@ DOC_FUNCS_FNCS=\
        fcdircache.fncs \
        fcfile.fncs \
        fcfontset.fncs \
+       fcformat.fncs \
        fcfreetype.fncs \
        fcinit.fncs \
        fclangset.fncs \
@@ -70,6 +71,7 @@ DOC_FUNCS_SGML=\
        fcdircache.sgml \
        fcfile.sgml \
        fcfontset.sgml \
+       fcformat.sgml \
        fcfreetype.sgml \
        fcinit.sgml \
        fclangset.sgml \
@@ -121,7 +123,7 @@ func.refs: local-fontconfig-devel.sgml $(DOC_FUNCS_SGML) version.sgml confdir.sg
        $(DOC2MAN) -o devel-man local-fontconfig-devel.sgml && \
        mv devel-man/manpage.refs func.refs && \
        mv devel-man/*.3 . && \
-       $(RM) devel-man/manpage.links && \
+       $(RM) devel-man/manpage.* && \
        rmdir devel-man
 
 local-fontconfig-devel.sgml: fontconfig-devel.sgml
@@ -132,7 +134,7 @@ $(DOC_FUNCS_SGML): edit-sgml$(EXEEXT) $(FNCS_TMPL)
 fonts-conf.5: local-fontconfig-user.sgml version.sgml confdir.sgml
        $(RM) $@
        $(DOC2MAN) local-fontconfig-user.sgml && \
-       $(RM) manpage.refs manpage.links
+       $(RM) manpage.*
        
 local-fontconfig-user.sgml: fontconfig-user.sgml
        $(LN_S) $< $@
@@ -145,7 +147,7 @@ clean-local:
 
 $(HTML_DIR): local-fontconfig-devel.sgml $(DOC_FUNCS_SGML) version.sgml confdir.sgml
        $(RM) -r $(HTML_DIR)
-       $(DOC2HTML) -o $(HTML_DIR) local-fontconfig-devel.sgml
+       $(DOC2HTML) -V '%use-id-as-filename%' -o $(HTML_DIR) local-fontconfig-devel.sgml
 
 fontconfig-devel.txt: local-fontconfig-devel.sgml $(DOC_FUNCS_SGML) version.sgml confdir.sgml
        $(RM) $@