]> git.wh0rd.org - fontconfig.git/blobdiff - doc/Makefile.am
Fix parallel build in doc directory.
[fontconfig.git] / doc / Makefile.am
index 9e9cbeb8aad622e0380b93acb7d53523c96d6e24..b7c28123888b4c69e56af7af4dbbfea8f07d33a7 100644 (file)
 # TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
 # PERFORMANCE OF THIS SOFTWARE.
 
+CC = @CC_FOR_BUILD@
+EXEEXT = @EXEEXT_FOR_BUILD@
+LINK = $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS) -o $@
+
 DOC_SRC = $(srcdir)
 DOC_MODULE = fontconfig
 DOC2HTML = docbook2html
 DOC2TXT = docbook2txt
 DOC2MAN = docbook2man
+DOC2PDF = docbook2pdf
 
 TXT = fontconfig-user.txt fontconfig-devel.txt
+PDF = fontconfig-user.pdf fontconfig-devel.pdf
 HTML_FILES = fontconfig-user.html
 HTML_DIR = fontconfig-devel
 SGML = fontconfig-user.sgml fontconfig-devel.sgml
@@ -36,13 +42,16 @@ FNCS_TMPL = ${DOC_SRC}/func.sgml
 DOC_FUNCS_FNCS=\
        fcatomic.fncs \
        fcblanks.fncs \
+       fccache.fncs \
        fccharset.fncs \
        fcconfig.fncs \
        fcconstant.fncs \
+       fcdircache.fncs \
        fcfile.fncs \
        fcfontset.fncs \
        fcfreetype.fncs \
        fcinit.fncs \
+       fclangset.fncs \
        fcmatrix.fncs \
        fcobjectset.fncs \
        fcobjecttype.fncs \
@@ -54,13 +63,16 @@ DOC_FUNCS_FNCS=\
 DOC_FUNCS_SGML=\
        fcatomic.sgml \
        fcblanks.sgml \
+       fccache.sgml \
        fccharset.sgml \
        fcconfig.sgml \
        fcconstant.sgml \
+       fcdircache.sgml \
        fcfile.sgml \
        fcfontset.sgml \
        fcfreetype.sgml \
        fcinit.sgml \
+       fclangset.sgml \
        fcmatrix.sgml \
        fcobjectset.sgml \
        fcobjecttype.sgml \
@@ -69,17 +81,22 @@ DOC_FUNCS_SGML=\
        fcstrset.sgml \
        fcvalue.sgml
 
-man_MANS=fonts-conf.5 @DOCMAN3@
+man5_MANS=fonts-conf.5 
+man3_MANS=$(DOCMAN3)
 
 noinst_PROGRAMS=edit-sgml
 edit_sgml_SOURCES=edit-sgml.c
 
 docdir=@DOCDIR@
 
-DOC_FILES=$(TXT) $(HTML_FILES)
-LOCAL_DOCS=$(man_MANS) $(DOC_FILES) $(HTML_DIR)/*
+DOC_FILES=$(TXT) $(PDF) $(HTML_FILES)
+LOCAL_DOCS=$(man3_MANS) $(man5_MANS) $(DOC_FILES) $(HTML_DIR)/*
+
+check_SCRIPTS=check-missing-doc
+TESTS_ENVIRONMENT=top_srcdir=${top_srcdir} sh
+TESTS=check-missing-doc
 
-EXTRA_DIST=$(LOCAL_DOCS) $(SGML) $(DOC_FUNCS_FNCS) $(FNCS_TMPL) confdir.sgml.in
+EXTRA_DIST=$(LOCAL_DOCS) $(SGML) $(DOC_FUNCS_FNCS) $(check_SCRIPTS) func.sgml confdir.sgml.in
 
 SUFFIXES=.fncs .sgml .txt .html
 
@@ -87,28 +104,34 @@ if USEDOCBOOK
 
 .fncs.sgml:
        $(RM) $@
-       ./edit-sgml $(FNCS_TMPL) < '$<' > $*.sgml
+       ./edit-sgml$(EXEEXT) $(FNCS_TMPL) < '$<' > $*.sgml
 
 .sgml.txt:
        $(RM) $@
        $(DOC2TXT) $<
 
-$(man_MANS): func.refs
+.sgml.pdf:
+       $(RM) $@
+       $(DOC2PDF) $<
+
+$(man3_MANS): func.refs
 
 func.refs: local-fontconfig-devel.sgml $(DOC_FUNCS_SGML) version.sgml confdir.sgml
        $(RM) func.refs
-       $(DOC2MAN) local-fontconfig-devel.sgml
-       mv manpage.refs func.refs
-       $(RM) manpage.links
+       $(DOC2MAN) -o devel-man local-fontconfig-devel.sgml && \
+       mv devel-man/manpage.refs func.refs && \
+       mv devel-man/*.3 . && \
+       $(RM) devel-man/manpage.links && \
+       rmdir devel-man
 
 local-fontconfig-devel.sgml: fontconfig-devel.sgml
        $(LN_S) $< $@
 
-$(DOC_FUNCS_SGML): edit-sgml $(FNCS_TMPL)
+$(DOC_FUNCS_SGML): edit-sgml$(EXEEXT) $(FNCS_TMPL)
 
 fonts-conf.5: local-fontconfig-user.sgml version.sgml confdir.sgml
        $(RM) $@
-       $(DOC2MAN) local-fontconfig-user.sgml
+       $(DOC2MAN) local-fontconfig-user.sgml && \
        $(RM) manpage.refs manpage.links
        
 local-fontconfig-user.sgml: fontconfig-user.sgml
@@ -117,18 +140,24 @@ local-fontconfig-user.sgml: fontconfig-user.sgml
 all-local: $(LOCAL_DOCS)
 
 clean-local:
-       $(RM) $(man_MANS) $(DOC_FILES) $(DOC_FUNCS_SGML) func.refs
+       $(RM) $(man3_MANS) $(man5_MANS) $(DOC_FILES) $(DOC_FUNCS_SGML) func.refs
        $(RM) -r $(HTML_DIR)
 
 $(HTML_DIR): local-fontconfig-devel.sgml $(DOC_FUNCS_SGML) version.sgml confdir.sgml
        $(RM) -r $(HTML_DIR)
        $(DOC2HTML) -o $(HTML_DIR) local-fontconfig-devel.sgml
 
-fontconfig-devel.txt: local-fontconfig-devel.sgml version.sgml confdir.sgml
+fontconfig-devel.txt: local-fontconfig-devel.sgml $(DOC_FUNCS_SGML) version.sgml confdir.sgml
        $(RM) $@
        $(DOC2TXT) local-fontconfig-devel.sgml
        mv local-fontconfig-devel.txt $@
 
+fontconfig-devel.pdf: local-fontconfig-devel.sgml $(DOC_FUNCS_SGML) version.sgml confdir.sgml
+       $(RM) $@
+       $(top_srcdir)/missing --run $(DOC2PDF) $< && mv local-$@ $@ \
+       || echo Failed to generate $@ >&2; \
+       (test -f $@ || echo $(DOC2PDF) is required to generate this file >> $@)
+
 fontconfig-user.html: local-fontconfig-user.sgml version.sgml confdir.sgml
        $(RM) $@ local-$@ $@.tmp
        $(DOC2HTML) -u local-fontconfig-user.sgml > $@.tmp
@@ -141,13 +170,26 @@ fontconfig-user.txt: local-fontconfig-user.sgml version.sgml confdir.sgml
        $(DOC2TXT) local-fontconfig-user.sgml
        mv local-fontconfig-user.txt $@
 
+fontconfig-user.pdf: local-fontconfig-user.sgml version.sgml confdir.sgml
+       $(RM) $@
+       $(top_srcdir)/missing --run $(DOC2PDF) $< && mv local-$@ $@ \
+       || echo Failed to generate $@ >&2; \
+       (test -f $@ || echo $(DOC2PDF) is required to generate this file >> $@)
+
 STRIPNL=awk '{ if (NR > 1) printf ("\n"); printf ("%s", $$0); }'
 confdir.sgml: ${DOC_SRC}/confdir.sgml.in
        sed "s,@CONFDIR\@,${CONFDIR}," < ${DOC_SRC}/confdir.sgml.in | $(STRIPNL) > confdir.sgml
 
 CLEANFILES=confdir.sgml local-fontconfig-user.sgml local-fontconfig-devel.sgml
 
+htmldoc_DATA = $(HTML_DIR)/*
+
+$(HTML_DIR)/*: $(HTML_DIR)
+
 else
+
+htmldoc_DATA = $(srcdir)/$(HTML_DIR)/*
+
 all-local:
 clean-local:
 endif
@@ -156,6 +198,3 @@ htmldocdir=$(docdir)/$(HTML_DIR)
 
 doc_DATA = $(DOC_FILES)
 
-htmldoc_DATA = $(HTML_DIR)/*
-
-$(HTML_DIR)/*: $(HTML_DIR)