]> git.wh0rd.org - fontconfig.git/blobdiff - fc-cache/Makefile.am
Get rid of $Id$ tags
[fontconfig.git] / fc-cache / Makefile.am
index 3d584bc2c6ea8121ce1a1d87bfcdb73c5bfee4b1..49c59ec0b6a12c0777e6617d4312eea1338ebeaf 100644 (file)
@@ -1,7 +1,7 @@
 # 
-#  $Id$
+#  fontconfig/fc-cache/Makefile.am
 # 
-#  Copyright © 2003 Keith Packard
+#  Copyright Â© 2003 Keith Packard
 # 
 #  Permission to use, copy, modify, distribute, and sell this software and its
 #  documentation for any purpose is hereby granted without fee, provided that
@@ -27,28 +27,41 @@ FC_CACHE_SRC=${top_srcdir}/fc-cache
 
 SGML = ${FC_CACHE_SRC}/fc-cache.sgml
 
-INCLUDES=$(FREETYPE_CFLAGS)
+if OS_WIN32
+else
+install-data-local:
+       -$(mkinstalldirs) "$(DESTDIR)$(fc_cachedir)"
+
+uninstall-local:
+       -$(RM) -rf "$(DESTDIR)$(fc_cachedir)"
+endif
 
-man_MANS=fc-cache.1
+INCLUDES=-I${top_srcdir} -I${top_srcdir}/src $(WARN_CFLAGS)
 
 bin_PROGRAMS=fc-cache
 
-EXTRA_DIST=$(SGML)
+BUILT_MANS=fc-cache.1
+
+if ENABLE_DOCS
+man_MANS=${BUILT_MANS}
+endif
+
+EXTRA_DIST=fc-cache.sgml $(BUILT_MANS)
 
 fc_cache_LDADD = ${top_builddir}/src/libfontconfig.la
 
 if USEDOCBOOK
-                                                                                
-${man_MANS}: ${SGML}                                                                           
+
+${man_MANS}: ${SGML}   
        $(RM) $@
        $(DOC2MAN) ${SGML}
        $(RM) manpage.refs manpage.links
-                                                                                
+
 all-local: $(man_MANS)
-                                                                                
+
 clean-local:
        $(RM) $(man_MANS)
-                                                                                
+
 else
 all-local:
 clean-local: