]> git.wh0rd.org - fontconfig.git/blobdiff - fc-cat/Makefile.am
Bug 44826 - <alias> must contain only a single <family>
[fontconfig.git] / fc-cat / Makefile.am
index 91e5ad720baf69e46a3d7edd83b96b5aa2cfc52c..58745959170e1c9f4a5ac630d6cee18c591b71ef 100644 (file)
@@ -1,5 +1,5 @@
 # 
-#  $Id$
+#  fontconfig/fc-cat/Makefile.am
 # 
 #  Copyright © 2003 Keith Packard
 # 
@@ -7,15 +7,15 @@
 #  documentation for any purpose is hereby granted without fee, provided that
 #  the above copyright notice appear in all copies and that both that
 #  copyright notice and this permission notice appear in supporting
-#  documentation, and that the name of Keith Packard not be used in
+#  documentation, and that the name of the author(s) not be used in
 #  advertising or publicity pertaining to distribution of the software without
-#  specific, written prior permission.  Keith Packard makes no
+#  specific, written prior permission.  The authors make no
 #  representations about the suitability of this software for any purpose.  It
 #  is provided "as is" without express or implied warranty.
 # 
-#  KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+#  THE AUTHOR(S) DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
 #  INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
-#  EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+#  EVENT SHALL THE AUTHOR(S) BE LIABLE FOR ANY SPECIAL, INDIRECT OR
 #  CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
 #  DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
 #  TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
@@ -27,22 +27,26 @@ FC_CAT_SRC=${top_srcdir}/fc-cat
 
 SGML = ${FC_CAT_SRC}/fc-cat.sgml
 
-INCLUDES=-I${top_srcdir} $(FREETYPE_CFLAGS)
+INCLUDES=-I${top_srcdir} $(WARN_CFLAGS)
 
 bin_PROGRAMS=fc-cat
 
-EXTRA_DIST=fc-cat.sgml
+BUILT_MANS=fc-cat.1
 
-fc_cat_LDADD = $(FREETYPE_LIBS) $(LIBXML2_LIBS) $(EXPAT_LIBS) ${top_builddir}/src/libfontconfig.la
+if ENABLE_DOCS
+man_MANS=${BUILT_MANS}
+endif
 
-if USEDOCBOOK
+EXTRA_DIST=fc-cat.sgml ${BUILT_MANS}
 
-man_MANS=fc-cat.1
+fc_cat_LDADD = ${top_builddir}/src/libfontconfig.la
+
+if USEDOCBOOK
 
 ${man_MANS}: ${SGML}   
        $(RM) $@
        $(DOC2MAN) ${SGML}
-       $(RM) manpage.refs manpage.links
+       $(RM) manpage.*
 
 all-local: $(man_MANS)