]> git.wh0rd.org - fontconfig.git/blobdiff - fc-list/Makefile.am
Bug 44826 - <alias> must contain only a single <family>
[fontconfig.git] / fc-list / Makefile.am
index b050a3fe7523a5930adca0887341ca5bb34be946..d40700a4eb1f5688a52a6c3b7526d4f62f255b03 100644 (file)
@@ -1,32 +1,59 @@
 # 
-#  $Id$
+#  fontconfig/fc-list/Makefile.am
 # 
-#  Copyright © 2003 Keith Packard
+#  Copyright Â© 2003 Keith Packard
 # 
 #  Permission to use, copy, modify, distribute, and sell this software and its
 #  documentation for any purpose is hereby granted without fee, provided that
 #  the above copyright notice appear in all copies and that both that
 #  copyright notice and this permission notice appear in supporting
-#  documentation, and that the name of Keith Packard not be used in
+#  documentation, and that the name of the author(s) not be used in
 #  advertising or publicity pertaining to distribution of the software without
-#  specific, written prior permission.  Keith Packard makes no
+#  specific, written prior permission.  The authors make no
 #  representations about the suitability of this software for any purpose.  It
 #  is provided "as is" without express or implied warranty.
 # 
-#  KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+#  THE AUTHOR(S) DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
 #  INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
-#  EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+#  EVENT SHALL THE AUTHOR(S) BE LIABLE FOR ANY SPECIAL, INDIRECT OR
 #  CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
 #  DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
 #  TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
 #  PERFORMANCE OF THIS SOFTWARE.
 
+DOC2MAN = docbook2man
+
+FC_LIST_SRC=${top_srcdir}/fc-list
+
+SGML = ${FC_LIST_SRC}/fc-list.sgml
+
 bin_PROGRAMS=fc-list
 
-man_MANS=fc-list.1
+INCLUDES=-I${top_srcdir} $(WARN_CFLAGS)
+
+BUILT_MANS=fc-list.1
+
+if ENABLE_DOCS
+man_MANS=${BUILT_MANS}
+endif
+
+EXTRA_DIST=fc-list.sgml $(BUILT_MANS)
+
+fc_list_LDADD = ${top_builddir}/src/libfontconfig.la
+
+if USEDOCBOOK
+
+${man_MANS}: ${SGML}
+       $(RM) $@
+       $(DOC2MAN) ${SGML}
+       $(RM) manpage.*
 
-INCLUDES=$(FREETYPE_CFLAGS)
+all-local: $(man_MANS)
 
-EXTRA_DIST=$(man_MANS)
+clean-local:
+       $(RM) $(man_MANS)
 
-fc_list_LDADD = ../src/libfontconfig.la
+else
+all-local:
+clean-local:
+endif