]> git.wh0rd.org - fontconfig.git/blobdiff - fc-match/Makefile.am
Bug 41171 - Invalid use of memset
[fontconfig.git] / fc-match / Makefile.am
index 7a32e348b67b1cefb31ecfa454e5090a7a2001b1..94fc7d906b0b49248020d24538ae39072d7d641f 100644 (file)
@@ -1,21 +1,21 @@
 # 
-#  $Id$
+#  fontconfig/fc-match/Makefile.am
 # 
-#  Copyright © 2003 Keith Packard
+#  Copyright Â© 2003 Keith Packard
 # 
 #  Permission to use, copy, modify, distribute, and sell this software and its
 #  documentation for any purpose is hereby granted without fee, provided that
 #  the above copyright notice appear in all copies and that both that
 #  copyright notice and this permission notice appear in supporting
-#  documentation, and that the name of Keith Packard not be used in
+#  documentation, and that the name of the author(s) not be used in
 #  advertising or publicity pertaining to distribution of the software without
-#  specific, written prior permission.  Keith Packard makes no
+#  specific, written prior permission.  The authors make no
 #  representations about the suitability of this software for any purpose.  It
 #  is provided "as is" without express or implied warranty.
 # 
-#  KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+#  THE AUTHOR(S) DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
 #  INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
-#  EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+#  EVENT SHALL THE AUTHOR(S) BE LIABLE FOR ANY SPECIAL, INDIRECT OR
 #  CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
 #  DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
 #  TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
 
 bin_PROGRAMS=fc-match
 
-man_MANS=fc-match.1
+DOC2MAN = docbook2man
 
-INCLUDES=-I${top_srcdir} $(FREETYPE_CFLAGS) $(WARN_CFLAGS)
+FC_MATCH_SRC=${top_srcdir}/fc-match
 
-EXTRA_DIST=$(man_MANS)
+SGML = ${FC_MATCH_SRC}/fc-match.sgml
+
+INCLUDES=-I${top_srcdir} $(WARN_CFLAGS)
+
+BUILT_MANS=fc-match.1
+
+if ENABLE_DOCS
+man_MANS=${BUILT_MANS}
+endif
+
+EXTRA_DIST=fc-match.sgml $(BUILT_MANS)
 
 fc_match_LDADD = ${top_builddir}/src/libfontconfig.la
+
+if USEDOCBOOK
+
+${man_MANS}: ${SGML}
+       $(RM) $@
+       $(DOC2MAN) ${SGML}
+       $(RM) manpage.*
+
+all-local: $(man_MANS)
+
+clean-local:
+       $(RM) $(man_MANS)
+
+else
+all-local:
+clean-local:
+endif