]> git.wh0rd.org - fontconfig.git/blobdiff - src/Makefile.am
Bug 44826 - <alias> must contain only a single <family>
[fontconfig.git] / src / Makefile.am
index a71ef1dd953fd515027902ee7d171729c070673f..090f9b1abd72695ab6eb423c643e13c6943c8752 100644 (file)
@@ -1,5 +1,5 @@
 #
-# $Id$
+# fontconfig/src/Makefile.am
 #
 # Copyright © 2003 Keith Packard
 #
@@ -7,15 +7,15 @@
 # documentation for any purpose is hereby granted without fee, provided that
 # the above copyright notice appear in all copies and that both that
 # copyright notice and this permission notice appear in supporting
-# documentation, and that the name of Keith Packard not be used in
+# documentation, and that the name of the author(s) not be used in
 # advertising or publicity pertaining to distribution of the software without
-# specific, written prior permission.  Keith Packard makes no
+# specific, written prior permission.  The authors make no
 # representations about the suitability of this software for any purpose.  It
 # is provided "as is" without express or implied warranty.
 #
-# KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# THE AUTHOR(S) DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
 # INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
-# EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# EVENT SHALL THE AUTHOR(S) BE LIABLE FOR ANY SPECIAL, INDIRECT OR
 # CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
 # DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
 # TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
@@ -52,7 +52,7 @@ if MS_LIB_AVAILABLE
 noinst_DATA = fontconfig.lib
 
 fontconfig.lib : libfontconfig.la
-       lib -name:libfontconfig-$(lt_current_minus_age).dll -def:fontconfig.def -out:$@
+       lib -name:libfontconfig-@LIBT_CURRENT_MINUS_AGE@.dll -def:fontconfig.def -out:$@
 
 install-ms-import-lib:
        $(INSTALL) fontconfig.lib $(DESTDIR)$(libdir)
@@ -83,9 +83,22 @@ noinst_HEADERS=fcint.h fcftint.h fcdeprecate.h
 
 ALIAS_FILES = fcalias.h fcaliastail.h fcftalias.h fcftaliastail.h
 
-BUILT_SOURCES = $(ALIAS_FILES)
+BUILT_SOURCES = $(ALIAS_FILES) \
+       ../fc-case/fccase.h \
+       ../fc-glyphname/fcglyphname.h \
+       ../fc-lang/fclang.h
+
+noinst_PROGRAMS = fcarch
+
+../fc-case/fccase.h:
+       cd ../fc-case && $(MAKE) $(AM_MAKEFLAGS) fccase.h
+../fc-glyphname/fcglyphname.h:
+       cd ../fc-glyphname && $(MAKE) $(AM_MAKEFLAGS) fcglyphname.h
+../fc-lang/fclang.h:
+       cd ../fc-lang && $(MAKE) $(AM_MAKEFLAGS) fclang.h
 
 libfontconfig_la_SOURCES = \
+       fcarch.h \
        fcatomic.c \
        fcblanks.c \
        fccache.c \
@@ -94,6 +107,7 @@ libfontconfig_la_SOURCES = \
        fcdbg.c \
        fcdefault.c \
        fcdir.c \
+       fcformat.c \
        fcfreetype.c \
        fcfs.c \
        fcinit.c \
@@ -126,7 +140,7 @@ PUBLIC_FILES = \
        $(top_srcdir)/fontconfig/fontconfig.h \
        $(top_srcdir)/src/fcdeprecate.h \
        $(top_srcdir)/fontconfig/fcprivate.h
-       
+
 PUBLIC_FT_FILES = \
        $(top_srcdir)/fontconfig/fcfreetype.h
 
@@ -146,7 +160,7 @@ fontconfig.def: $(PUBLIC_FILES) $(PUBLIC_FT_FILES)
        echo Generating $@
        (echo EXPORTS; \
        (cat $(PUBLIC_FILES) $(PUBLIC_FT_FILES) || echo 'FcERROR ()' ) | \
-       grep '^Fc[^ ]* *(' | sed -e 's/ *(.*$$//' -e 's/^/      /' | \
+       grep '^Fc[^ ]* *(' | sed -e 's/ *(.*$$//' -e 's/^/      /' | \
        sort; \
        echo LIBRARY libfontconfig-@LIBT_CURRENT_MINUS_AGE@.dll; \
        echo VERSION @LIBT_CURRENT@.@LIBT_REVISION@) >$@