]> git.wh0rd.org - fontconfig.git/blobdiff - src/Makefile.am
Remove fcprivate.h, move the remaining macros to fcint.h.
[fontconfig.git] / src / Makefile.am
index 01c9c5ef0de94eebbe40294dc0455d17145867bc..2ff1f3c013e988b0345dbc8e8a0da2ad3013fc63 100644 (file)
@@ -25,6 +25,8 @@ if OS_WIN32
 
 export_symbols = -export-symbols fontconfig.def
 
+fontconfig_def_dependency = fontconfig.def
+
 # gcc import library install/uninstall
 
 install-libtool-import-lib: 
@@ -39,6 +41,8 @@ else
 install-libtool-import-lib:
 uninstall-libtool-import-lib:
 
+fontconfig_def_dependency = 
+
 endif
 
 if MS_LIB_AVAILABLE
@@ -63,8 +67,6 @@ uninstall-ms-import-lib:
 
 endif
 
-AM_CPPFLAGS = -DPKGCACHEDIR='"${pkgcachedir}"'
-
 INCLUDES =                                             \
        -I$(top_srcdir)                                 \
        -I$(top_srcdir)/src                             \
@@ -72,12 +74,17 @@ INCLUDES =                                          \
        $(LIBXML2_CFLAGS)                               \
        $(EXPAT_CFLAGS)                                 \
        $(WARN_CFLAGS)                                  \
+       -DFC_CACHEDIR='"$(FC_CACHEDIR)"'                \
        -DFONTCONFIG_PATH='"$(CONFDIR)"'
 
-EXTRA_DIST = fontconfig.def.in
+EXTRA_DIST = makealias
 
 noinst_HEADERS=fcint.h
 
+ALIAS_FILES = fcalias.h fcaliastail.h
+
+BUILT_SOURCES = $(ALIAS_FILES)
+
 libfontconfig_la_SOURCES = \
        fcatomic.c \
        fcblanks.c \
@@ -96,6 +103,7 @@ libfontconfig_la_SOURCES = \
        fcmatrix.c \
        fcname.c \
        fcpat.c \
+       fcserialize.c \
        fcstr.c \
        fcxml.c \
        ftglue.h \
@@ -108,7 +116,29 @@ libfontconfig_la_LDFLAGS =                 \
 
 libfontconfig_la_LIBADD = $(ICONV_LIBS) $(FREETYPE_LIBS) $(LIBXML2_LIBS) $(EXPAT_LIBS)
 
+libfontconfig_la_DEPENDENCIES = $(fontconfig_def_dependency)
+
 install-data-local: install-ms-import-lib install-libtool-import-lib
 
 uninstall-local: uninstall-ms-import-lib uninstall-libtool-import-lib
 
+PUBLIC_FILES = \
+       $(top_srcdir)/fontconfig/fontconfig.h \
+       $(top_srcdir)/fontconfig/fcfreetype.h
+       
+fcaliastail.h: fcalias.h
+
+fcalias.h: $(top_srcdir)/src/makealias $(PUBLIC_FILES)
+       sh $(top_srcdir)/src/makealias "$(top_srcdir)/src" $(PUBLIC_FILES)
+
+CLEANFILES := $(ALIAS_FILES)
+
+fontconfig.def: $(PUBLIC_FILES)
+       echo Generating $@
+       (echo EXPORTS; \
+       (cat $(PUBLIC_FILES) || echo 'FcERROR ()' ) | \
+       grep '^Fc[^ ]* *(' | sed -e 's/ *(.*$$//' -e 's/^/      /' | \
+       sort; \
+       echo LIBRARY libfontconfig-@LT_CURRENT_MINUS_AGE@.dll; \
+       echo VERSION @LT_CURRENT@.@LT_REVISION@) >$@
+       @ ! grep -q FcERROR $@ || ($(RM) $@; false)