]> git.wh0rd.org - fontconfig.git/blobdiff - src/Makefile.am
Clean up Makefile's a bit
[fontconfig.git] / src / Makefile.am
index f9e7a66bd3a62f2b173caeab560f5004c04333c2..8b6379dc698900fbd2935b403b881d4a433bcfca 100644 (file)
+#
+# fontconfig/src/Makefile.am
+#
+# Copyright © 2003 Keith Packard
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Keith Packard not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission.  Keith Packard makes no
+# representations about the suitability of this software for any purpose.  It
+# is provided "as is" without express or implied warranty.
+#
+# THE AUTHOR(S) DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL THE AUTHOR(S) BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+if OS_WIN32
+
+export_symbols = -export-symbols fontconfig.def
+
+fontconfig_def_dependency = fontconfig.def
+
+# gcc import library install/uninstall
+
+install-libtool-import-lib: 
+       $(INSTALL) .libs/libfontconfig.dll.a $(DESTDIR)$(libdir)
+       $(INSTALL) fontconfig.def $(DESTDIR)$(libdir)/fontconfig.def
+
+uninstall-libtool-import-lib:
+       -rm $(DESTDIR)$(libdir)/libfontconfig.dll.a $(DESTDIR)$(libdir)/fontconfig.def
+
+else
+
+install-libtool-import-lib:
+uninstall-libtool-import-lib:
+
+fontconfig_def_dependency = 
+
+endif
+
+if MS_LIB_AVAILABLE
+
+# Microsoft import library install/uninstall
+
+noinst_DATA = fontconfig.lib
+
+fontconfig.lib : libfontconfig.la
+       lib -name:libfontconfig-$(lt_current_minus_age).dll -def:fontconfig.def -out:$@
+
+install-ms-import-lib:
+       $(INSTALL) fontconfig.lib $(DESTDIR)$(libdir)
+
+uninstall-ms-import-lib:
+       -rm $(DESTDIR)$(libdir)/fontconfig.lib
+
+else
+
+install-ms-import-lib:
+uninstall-ms-import-lib:
+
+endif
+
 INCLUDES =                                             \
+       -I$(top_srcdir)                                 \
+       -I$(top_srcdir)/src                             \
        $(FREETYPE_CFLAGS)                              \
+       $(LIBXML2_CFLAGS)                               \
        $(EXPAT_CFLAGS)                                 \
-       -I$(top_srcdir)                                 \
-       -I$(top_srcdir)/src
-       
-noinst_HEADERS=fcint.h
+       $(WARN_CFLAGS)                                  \
+       -DFC_CACHEDIR='"$(FC_CACHEDIR)"'                \
+       -DFONTCONFIG_PATH='"$(CONFDIR)"'
+
+EXTRA_DIST = makealias
+
+noinst_HEADERS=fcint.h fcftint.h fcdeprecate.h
+
+ALIAS_FILES = fcalias.h fcaliastail.h fcftalias.h fcftaliastail.h
+
+BUILT_SOURCES = $(ALIAS_FILES) \
+       ../fc-arch/fcarch.h \
+       ../fc-case/fccase.h \
+       ../fc-glyphname/fcglyphname.h \
+       ../fc-lang/fclang.h
+
+../fc-arch/fcarch.h:
+       cd ../fc-arch && $(MAKE) $(AM_MAKEFLAGS) fcarch.h
+../fc-case/fccase.h:
+       cd ../fc-case && $(MAKE) $(AM_MAKEFLAGS) fccase.h
+../fc-glyphname/fcglyphname.h:
+       cd ../fc-glyphname && $(MAKE) $(AM_MAKEFLAGS) fcglyphname.h
+../fc-lang/fclang.h:
+       cd ../fc-lang && $(MAKE) $(AM_MAKEFLAGS) fclang.h
 
 libfontconfig_la_SOURCES = \
        fcatomic.c \
@@ -15,6 +107,7 @@ libfontconfig_la_SOURCES = \
        fcdbg.c \
        fcdefault.c \
        fcdir.c \
+       fcformat.c \
        fcfreetype.c \
        fcfs.c \
        fcinit.c \
@@ -24,13 +117,51 @@ libfontconfig_la_SOURCES = \
        fcmatrix.c \
        fcname.c \
        fcpat.c \
+       fcserialize.c \
        fcstr.c \
-       fcxml.c
-       
+       fcxml.c \
+       ftglue.h \
+       ftglue.c
+
 lib_LTLIBRARIES = libfontconfig.la
 
 libfontconfig_la_LDFLAGS =                     \
-       -version-number @LT_VERSION_NUMBER@
+       -version-info @LIBT_VERSION_INFO@ -no-undefined $(export_symbols)
+
+libfontconfig_la_LIBADD = $(ICONV_LIBS) $(FREETYPE_LIBS) $(LIBXML2_LIBS) $(EXPAT_LIBS)
+
+libfontconfig_la_DEPENDENCIES = $(fontconfig_def_dependency)
+
+install-data-local: install-ms-import-lib install-libtool-import-lib
+
+uninstall-local: uninstall-ms-import-lib uninstall-libtool-import-lib
+
+PUBLIC_FILES = \
+       $(top_srcdir)/fontconfig/fontconfig.h \
+       $(top_srcdir)/src/fcdeprecate.h \
+       $(top_srcdir)/fontconfig/fcprivate.h
+       
+PUBLIC_FT_FILES = \
+       $(top_srcdir)/fontconfig/fcfreetype.h
+
+fcaliastail.h: fcalias.h
+
+fcalias.h: $(top_srcdir)/src/makealias $(PUBLIC_FILES)
+       sh $(top_srcdir)/src/makealias "$(top_srcdir)/src" fcalias.h fcaliastail.h $(PUBLIC_FILES)
+
+fcftaliastail.h: fcftalias.h
+
+fcftalias.h: $(top_srcdir)/src/makealias $(PUBLIC_FT_FILES)
+       sh $(top_srcdir)/src/makealias "$(top_srcdir)/src" fcftalias.h fcftaliastail.h $(PUBLIC_FT_FILES)
 
-libfontconfig_la_LIBADD = $(FREETYPE_LIBS) $(EXPAT_LIBS)
+CLEANFILES = $(ALIAS_FILES)
 
+fontconfig.def: $(PUBLIC_FILES) $(PUBLIC_FT_FILES)
+       echo Generating $@
+       (echo EXPORTS; \
+       (cat $(PUBLIC_FILES) $(PUBLIC_FT_FILES) || echo 'FcERROR ()' ) | \
+       grep '^Fc[^ ]* *(' | sed -e 's/ *(.*$$//' -e 's/^/      /' | \
+       sort; \
+       echo LIBRARY libfontconfig-@LIBT_CURRENT_MINUS_AGE@.dll; \
+       echo VERSION @LIBT_CURRENT@.@LIBT_REVISION@) >$@
+       @ ! grep -q FcERROR $@ || ($(RM) $@; false)