]> git.wh0rd.org - fontconfig.git/blobdiff - src/Makefile.am
Eliminate .so PLT entries for local symbols. (thanks to Arjan van de Ven)
[fontconfig.git] / src / Makefile.am
index a30604e763770a65046d6c259f762a75813f33e3..98e353d58999dcf2ed57573bbd7bbd859499189f 100644 (file)
@@ -1,13 +1,35 @@
+#
+# $Id$
+#
+# Copyright © 2003 Keith Packard
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Keith Packard not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission.  Keith Packard makes no
+# representations about the suitability of this software for any purpose.  It
+# is provided "as is" without express or implied warranty.
+#
+# KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
 if OS_WIN32
 
-no_undefined = -no-undefined
 export_symbols = -export-symbols fontconfig.def
 
 # gcc import library install/uninstall
 
 install-libtool-import-lib: 
        $(INSTALL) .libs/libfontconfig.dll.a $(DESTDIR)$(libdir)
-       $(INSTALL) fontconfig.def $(DESTDIR)$(libdir)/glib-2.0.def
+       $(INSTALL) fontconfig.def $(DESTDIR)$(libdir)/fontconfig.def
 
 uninstall-libtool-import-lib:
        -rm $(DESTDIR)$(libdir)/libfontconfig.dll.a $(DESTDIR)$(libdir)/fontconfig.def
@@ -42,16 +64,23 @@ uninstall-ms-import-lib:
 endif
 
 INCLUDES =                                             \
+       -I$(top_srcdir)                                 \
+       -I$(top_srcdir)/src                             \
        $(FREETYPE_CFLAGS)                              \
+       $(LIBXML2_CFLAGS)                               \
        $(EXPAT_CFLAGS)                                 \
-       -DFONTCONFIG_PATH='"$(CONFDIR)"'                \
-       -I$(top_srcdir)                                 \
-       -I$(top_srcdir)/src
+       $(WARN_CFLAGS)                                  \
+       -DFC_CACHEDIR='"$(FC_CACHEDIR)"'                \
+       -DFONTCONFIG_PATH='"$(CONFDIR)"'
 
-EXTRA_DIST = fontconfig.def.in
+EXTRA_DIST = fontconfig.def.in makealias
 
 noinst_HEADERS=fcint.h
 
+ALIAS_FILES = fcalias.h fcaliastail.h
+
+BUILT_SOURCES = $(ALIAS_FILES)
+
 libfontconfig_la_SOURCES = \
        fcatomic.c \
        fcblanks.c \
@@ -70,17 +99,29 @@ libfontconfig_la_SOURCES = \
        fcmatrix.c \
        fcname.c \
        fcpat.c \
+       fcserialize.c \
        fcstr.c \
-       fcxml.c
+       fcxml.c \
+       ftglue.h \
+       ftglue.c
 
 lib_LTLIBRARIES = libfontconfig.la
 
 libfontconfig_la_LDFLAGS =                     \
-       -version-info @LT_VERSION_INFO@ $(no_undefined) $(export_symbols)
+       -version-info @LT_VERSION_INFO@ -no-undefined $(export_symbols)
 
-libfontconfig_la_LIBADD = $(FREETYPE_LIBS) $(EXPAT_LIBS)
+libfontconfig_la_LIBADD = $(ICONV_LIBS) $(FREETYPE_LIBS) $(LIBXML2_LIBS) $(EXPAT_LIBS)
 
 install-data-local: install-ms-import-lib install-libtool-import-lib
 
 uninstall-local: uninstall-ms-import-lib uninstall-libtool-import-lib
 
+PUBLIC_FILES = \
+       $(top_srcdir)/fontconfig/fontconfig.h \
+       $(top_srcdir)/fontconfig/fcfreetype.h \
+       $(top_srcdir)/fontconfig/fcprivate.h
+       
+$(ALIAS_FILES): $(top_srcdir)/src/makealias $(PUBLIC_FILES)
+       sh $(top_srcdir)/src/makealias "$(top_srcdir)/src" $(PUBLIC_FILES)
+
+CLEANFILES := $(ALIAS_FILES)