]> git.wh0rd.org - fontconfig.git/blobdiff - src/Makefile.am
Get rid of $Id$ tags
[fontconfig.git] / src / Makefile.am
index 750b8d2a5f52d9d9a2ce22409995177ff48dc31c..e18f9376e8e488abf2dc5cb36b671fe0b4b5c928 100644 (file)
@@ -1,5 +1,5 @@
 #
-# $Id$
+# fontconfig/src/Makefile.am
 #
 # Copyright © 2003 Keith Packard
 #
@@ -25,6 +25,8 @@ if OS_WIN32
 
 export_symbols = -export-symbols fontconfig.def
 
+fontconfig_def_dependency = fontconfig.def
+
 # gcc import library install/uninstall
 
 install-libtool-import-lib: 
@@ -39,6 +41,8 @@ else
 install-libtool-import-lib:
 uninstall-libtool-import-lib:
 
+fontconfig_def_dependency = 
+
 endif
 
 if MS_LIB_AVAILABLE
@@ -63,8 +67,6 @@ uninstall-ms-import-lib:
 
 endif
 
-AM_CPPFLAGS = -DPKGCACHEDIR='"${pkgcachedir}"'
-
 INCLUDES =                                             \
        -I$(top_srcdir)                                 \
        -I$(top_srcdir)/src                             \
@@ -72,11 +74,16 @@ INCLUDES =                                          \
        $(LIBXML2_CFLAGS)                               \
        $(EXPAT_CFLAGS)                                 \
        $(WARN_CFLAGS)                                  \
+       -DFC_CACHEDIR='"$(FC_CACHEDIR)"'                \
        -DFONTCONFIG_PATH='"$(CONFDIR)"'
 
-EXTRA_DIST = fontconfig.def.in
+EXTRA_DIST = makealias
 
-noinst_HEADERS=fcint.h
+noinst_HEADERS=fcint.h fcftint.h fcdeprecate.h
+
+ALIAS_FILES = fcalias.h fcaliastail.h fcftalias.h fcftaliastail.h
+
+BUILT_SOURCES = $(ALIAS_FILES)
 
 libfontconfig_la_SOURCES = \
        fcatomic.c \
@@ -96,6 +103,7 @@ libfontconfig_la_SOURCES = \
        fcmatrix.c \
        fcname.c \
        fcpat.c \
+       fcserialize.c \
        fcstr.c \
        fcxml.c \
        ftglue.h \
@@ -104,11 +112,42 @@ libfontconfig_la_SOURCES = \
 lib_LTLIBRARIES = libfontconfig.la
 
 libfontconfig_la_LDFLAGS =                     \
-       -version-info @LT_VERSION_INFO@ -no-undefined $(export_symbols)
+       -version-info @LIBT_VERSION_INFO@ -no-undefined $(export_symbols)
+
+libfontconfig_la_LIBADD = $(ICONV_LIBS) $(FREETYPE_LIBS) $(LIBXML2_LIBS) $(EXPAT_LIBS)
 
-libfontconfig_la_LIBADD = $(FREETYPE_LIBS) $(LIBXML2_LIBS) $(EXPAT_LIBS)
+libfontconfig_la_DEPENDENCIES = $(fontconfig_def_dependency)
 
 install-data-local: install-ms-import-lib install-libtool-import-lib
 
 uninstall-local: uninstall-ms-import-lib uninstall-libtool-import-lib
 
+PUBLIC_FILES = \
+       $(top_srcdir)/fontconfig/fontconfig.h \
+       $(top_srcdir)/src/fcdeprecate.h \
+       $(top_srcdir)/fontconfig/fcprivate.h
+       
+PUBLIC_FT_FILES = \
+       $(top_srcdir)/fontconfig/fcfreetype.h
+
+fcaliastail.h: fcalias.h
+
+fcalias.h: $(top_srcdir)/src/makealias $(PUBLIC_FILES)
+       sh $(top_srcdir)/src/makealias "$(top_srcdir)/src" fcalias.h fcaliastail.h $(PUBLIC_FILES)
+
+fcftaliastail.h: fcftalias.h
+
+fcftalias.h: $(top_srcdir)/src/makealias $(PUBLIC_FT_FILES)
+       sh $(top_srcdir)/src/makealias "$(top_srcdir)/src" fcftalias.h fcftaliastail.h $(PUBLIC_FT_FILES)
+
+CLEANFILES = $(ALIAS_FILES)
+
+fontconfig.def: $(PUBLIC_FILES) $(PUBLIC_FT_FILES)
+       echo Generating $@
+       (echo EXPORTS; \
+       (cat $(PUBLIC_FILES) $(PUBLIC_FT_FILES) || echo 'FcERROR ()' ) | \
+       grep '^Fc[^ ]* *(' | sed -e 's/ *(.*$$//' -e 's/^/      /' | \
+       sort; \
+       echo LIBRARY libfontconfig-@LIBT_CURRENT_MINUS_AGE@.dll; \
+       echo VERSION @LIBT_CURRENT@.@LIBT_REVISION@) >$@
+       @ ! grep -q FcERROR $@ || ($(RM) $@; false)