]> git.wh0rd.org - fontconfig.git/blobdiff - src/Makefile.am
Make fc-arch stuff cross-compiling-safe
[fontconfig.git] / src / Makefile.am
index 2034a8bb7a5efea3d97c6523d5c844d844785a65..e300fe9491b180717ff012fa188dfee9c6a3009c 100644 (file)
@@ -7,9 +7,9 @@
 # documentation for any purpose is hereby granted without fee, provided that
 # the above copyright notice appear in all copies and that both that
 # copyright notice and this permission notice appear in supporting
-# documentation, and that the name of Keith Packard not be used in
+# documentation, and that the name of the author(s) not be used in
 # advertising or publicity pertaining to distribution of the software without
-# specific, written prior permission.  Keith Packard makes no
+# specific, written prior permission.  The authors make no
 # representations about the suitability of this software for any purpose.  It
 # is provided "as is" without express or implied warranty.
 #
@@ -52,7 +52,7 @@ if MS_LIB_AVAILABLE
 noinst_DATA = fontconfig.lib
 
 fontconfig.lib : libfontconfig.la
-       lib -name:libfontconfig-$(lt_current_minus_age).dll -def:fontconfig.def -out:$@
+       lib -name:libfontconfig-@LIBT_CURRENT_MINUS_AGE@.dll -def:fontconfig.def -out:$@
 
 install-ms-import-lib:
        $(INSTALL) fontconfig.lib $(DESTDIR)$(libdir)
@@ -83,16 +83,22 @@ noinst_HEADERS=fcint.h fcftint.h fcdeprecate.h
 
 ALIAS_FILES = fcalias.h fcaliastail.h fcftalias.h fcftaliastail.h
 
-BUILT_SOURCES = $(ALIAS_FILES) ../fc-lang/fclang.h ../fc-arch/fcarch.h ../fc-glyphname/fcglyphname.h
+BUILT_SOURCES = $(ALIAS_FILES) \
+       ../fc-case/fccase.h \
+       ../fc-glyphname/fcglyphname.h \
+       ../fc-lang/fclang.h
 
-../fc-lang/fclang.h:
-       cd ../fc-lang && $(MAKE) $(AM_MAKEFLAGS) fclang.h
-../fc-arch/fcarch.h:
-       cd ../fc-arch && $(MAKE) $(AM_MAKEFLAGS) fcarch.h
+noinst_PROGRAMS = fcarch
+
+../fc-case/fccase.h:
+       cd ../fc-case && $(MAKE) $(AM_MAKEFLAGS) fccase.h
 ../fc-glyphname/fcglyphname.h:
        cd ../fc-glyphname && $(MAKE) $(AM_MAKEFLAGS) fcglyphname.h
+../fc-lang/fclang.h:
+       cd ../fc-lang && $(MAKE) $(AM_MAKEFLAGS) fclang.h
 
 libfontconfig_la_SOURCES = \
+       fcarch.h \
        fcatomic.c \
        fcblanks.c \
        fccache.c \