]> git.wh0rd.org - dump.git/blame_incremental - dump.spec
Made the multi-volume dump work again...
[dump.git] / dump.spec
... / ...
CommitLineData
1Summary: Programs for backing up and restoring filesystems.
2Name: dump
3Version: 0.4b15
4Release: 1
5Copyright: UCB
6Group: Applications/Archiving
7Source: http://sourceforge.net/download.php/dump/dump-%{version}.tar.gz
8Requires: rmt
9BuildRoot: /var/tmp/%{name}-root
10
11%description
12The dump package contains both dump and restore. Dump examines files in
13a filesystem, determines which ones need to be backed up, and copies
14those files to a specified disk, tape or other storage medium. The
15restore command performs the inverse function of dump; it can restore a
16full backup of a filesystem. Subsequent incremental backups can then be
17layered on top of the full backup. Single files and directory subtrees
18may also be restored from full or partial backups.
19
20Install dump if you need a system for both backing up filesystems and
21restoring filesystems after backups.
22
23%package -n rmt
24Summary: Provides certain programs with access to remote tape devices.
25Group: Applications/Archiving
26
27%description -n rmt
28The rmt utility provides remote access to tape devices for programs
29like dump (a filesystem backup program), restore (a program for
30restoring files from a backup) and tar (an archiving program).
31
32%package -n dump-static
33Summary: Programs for backing up and restoring filesystems.
34Group: Applications/Archiving
35
36%description -n dump-static
37The dump package contains both dump and restore. Dump examines files in
38a filesystem, determines which ones need to be backed up, and copies
39those files to a specified disk, tape or other storage medium. The
40restore command performs the inverse function of dump; it can restore a
41full backup of a filesystem. Subsequent incremental backups can then be
42layered on top of the full backup. Single files and directory subtrees
43may also be restored from full or partial backups.
44
45Install dump if you need a system for both backing up filesystems and
46restoring filesystems after backups.
47
48This packages contains statically linked versions of dump and restore.
49
50%prep
51%setup -q
52
53%build
54
55%configure --with-binmode=6755 --with-manowner=root --with-mangrp=root --with-manmode=0644 --enable-static
56
57make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts"
58
59mv dump/dump dump/dump.static
60mv restore/restore restore/restore.static
61
62make distclean
63
64%configure --with-binmode=6755 --with-manowner=root --with-mangrp=root --with-manmode=0644 --enable-rmt
65
66make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts"
67
68%install
69rm -rf $RPM_BUILD_ROOT
70mkdir -p $RPM_BUILD_ROOT/sbin
71mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/man/man8
72
73make install BINDIR=$RPM_BUILD_ROOT/sbin MANDIR=${RPM_BUILD_ROOT}%{_prefix}/man/man8 BINOWNER=$(id -un) BINGRP=$(id -gn) MANOWNER=$(id -un) MANGRP=$(id -gn)
74
75cp dump/dump.static $RPM_BUILD_ROOT/sbin
76cp restore/restore.static $RPM_BUILD_ROOT/sbin
77
78{ cd $RPM_BUILD_ROOT
79 strip ./sbin/* || :
80 ln -sf dump ./sbin/rdump
81 ln -sf dump.static ./sbin/rdump.static
82 ln -sf restore ./sbin/rrestore
83 ln -sf restore.static ./sbin/rrestore.static
84 chmod ug-s ./sbin/rmt
85 mkdir -p ./etc
86 > ./etc/dumpdates
87 ln -sf ../sbin/rmt ./etc/rmt
88}
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%files
94%defattr(-,root,root)
95%doc CHANGES COPYRIGHT KNOWNBUGS MAINTAINERS README REPORTING-BUGS THANKS TODO dump.lsm
96%attr(0664,root,disk) %config(noreplace) /etc/dumpdates
97%attr(6755,root,tty) /sbin/dump
98/sbin/rdump
99%attr(6755,root,tty) /sbin/restore
100/sbin/rrestore
101%{_prefix}/man/man8/dump.8
102%{_prefix}/man/man8/rdump.8
103%{_prefix}/man/man8/restore.8
104%{_prefix}/man/man8/rrestore.8
105
106%files -n rmt
107%defattr(-,root,root)
108%attr(0755,root,root) /sbin/rmt
109/etc/rmt
110%{_prefix}/man/man8/rmt.8
111
112%files -n dump-static
113%defattr(-,root,root)
114%attr(6755,root,tty) /sbin/dump.static
115/sbin/rdump.static
116%attr(6755,root,tty) /sbin/restore.static
117/sbin/rrestore.static
118
119%changelog
120* Thu Mar 2 2000 Stelian Pop <pop@cybercable.fr>
121- dump 0.4b15 released, first packaging.
122
123* Thu Feb 10 2000 Stelian Pop <pop@cybercable.fr>
124- dump 0.4b14 released, first packaging.
125
126* Fri Jan 21 2000 Stelian Pop <pop@cybercable.fr>
127- dump 0.4b13 released, first packaging.
128
129* Fri Jan 8 2000 Stelian Pop <pop@cybercable.fr>
130- dump 0.4b12 released, first packaging.
131
132* Sun Dec 5 1999 Stelian Pop <pop@cybercable.fr>
133- dump 0.4b11 released, first packaging.
134
135* Sun Nov 21 1999 Stelian Pop <pop@cybercable.fr>
136- dump 0.4b10 released, first packaging.
137
138* Thu Nov 11 1999 Stelian Pop <pop@cybercable.fr>
139- make static versions also for rescue purposes.
140
141* Wed Nov 5 1999 Stelian Pop <pop@cybercable.fr>
142- dump 0.4b9 released, first packaging.
143
144* Wed Nov 3 1999 Stelian Pop <pop@cybercable.fr>
145- dump 0.4b8 released, first packaging.
146
147* Thu Oct 8 1999 Stelian Pop <pop@cybercable.fr>
148- dump 0.4b7 released, first packaging.
149
150* Thu Sep 30 1999 Stelian Pop <pop@cybercable.fr>
151- dump 0.4b6 released, first packaging.
152
153* Fri Sep 10 1999 Jeff Johnson <jbj@redhat.com>
154- recompile with e2fsprogs = 1.15 (#4962).
155
156* Sat Jul 31 1999 Jeff Johnson <jbj@redhat.com>
157- workaround egcs bug (#4281) that caused dump problems (#2989).
158- use sigjmp_buf, not jmp_buf (#3260).
159- invoke /etc/rmt (instead of rmt) like other unices. (#3272).
160- use glibc21 err/glob rather than the internal compatibility routines.
161- wire $(OPT) throughout Makefile's.
162- fix many printf problems, mostly lint clean.
163- merge SuSE, Debian and many OpenBSD fixes.
164
165* Thu Mar 25 1999 Jeff Johnson <jbj@redhat.com>
166- remove setuid/setgid bits from /sbin/rmt (dump/restore are OK).
167
168* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
169- auto rebuild in the new build environment (release 6)
170
171* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
172- strip binaries.
173
174* Thu Mar 18 1999 Jeff Johnson <jbj@redhat.com>
175- Fix dangling symlinks (#1551).
176
177* Wed Mar 17 1999 Michael Maher <mike@redhat.com>
178- Top O' the morning, build root's fixed for man pages.
179
180* Fri Feb 19 1999 Preston Brown <pbrown@redhat.com>
181- upgraded to dump 0.4b4, massaged patches.
182
183* Tue Feb 02 1999 Ian A Cameron <I.A.Cameron@open.ac.uk>
184- added patch from Derrick J Brashear for traverse.c to stop bread errors
185
186* Wed Jan 20 1999 Jeff Johnson <jbj@redhat.com>
187- restore original 6755 root.tty to dump/restore, defattr did tty->root (#684).
188- mark /etc/dumpdates as noreplace.
189
190* Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
191- add build root.
192
193* Tue May 05 1998 Prospector System <bugs@redhat.com>
194- translations modified for de, fr, tr
195
196* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
197- added a patch for resolving linux/types.h and sys/types.h conflicts
198
199* Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
200- added prototype of llseek() so dump would work on large partitions
201
202* Thu Oct 30 1997 Donnie Barnes <djb@redhat.com>
203- made all symlinks relative instead of absolute
204
205* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
206- built against glibc
207
208* Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
209- Moved rmt to its own package.
210
211* Tue Feb 11 1997 Michael Fulbright <msf@redhat.com>
212- Added endian cleanups for SPARC
213
214* Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
215- Made /etc/dumpdates writeable by group disk.