]> git.wh0rd.org - dump.git/blobdiff - dump.spec
Remove the requirement to build the RPM as root from the spec file.
[dump.git] / dump.spec
index 8691914ccbfebb08d5fc0df64407fbb2d6c54a8c..9de2f97bfcd82dfb4b73dc347555b3d7124b703b 100644 (file)
--- a/dump.spec
+++ b/dump.spec
@@ -70,7 +70,7 @@ rm -rf $RPM_BUILD_ROOT
 mkdir -p $RPM_BUILD_ROOT/sbin
 mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/man/man8
 
-make install BINDIR=$RPM_BUILD_ROOT/sbin MANDIR=${RPM_BUILD_ROOT}%{_prefix}/man/man8
+make install BINDIR=$RPM_BUILD_ROOT/sbin MANDIR=${RPM_BUILD_ROOT}%{_prefix}/man/man8 BINOWNER=$(id -un) BINGRP=$(id -gn) MANOWNER=$(id -un) MANGRP=$(id -gn)
 
 cp dump/dump.static $RPM_BUILD_ROOT/sbin
 cp restore/restore.static $RPM_BUILD_ROOT/sbin