]> git.wh0rd.org - dump.git/blame - dump.spec
Fixed a socket descriptor leak in dump.
[dump.git] / dump.spec
CommitLineData
1d568d1b
SP
1%define _sbindir /sbin
2# XXX --enable-kerberos needs krcmd
3%define myoptions --with-binmode=6755 --with-manowner=root --with-mangrp=root --with-manmode=0644 --with-dumpdates="%{_sysconfdir}/dumpdates" --enable-readline
4
c154548c
SP
5Summary: Programs for backing up and restoring filesystems.
6Name: dump
35e850a4 7Version: 0.4b21
c154548c
SP
8Release: 1
9Copyright: UCB
10Group: Applications/Archiving
ebcbe7f6 11Source: http://sourceforge.net/download.php/dump/dump-%{version}.tar.gz
c154548c 12Requires: rmt
1d568d1b 13BuildRoot: %{_tmppath}/%{name}-root
c154548c
SP
14
15%description
16The dump package contains both dump and restore. Dump examines files in
17a filesystem, determines which ones need to be backed up, and copies
18those files to a specified disk, tape or other storage medium. The
19restore command performs the inverse function of dump; it can restore a
20full backup of a filesystem. Subsequent incremental backups can then be
21layered on top of the full backup. Single files and directory subtrees
22may also be restored from full or partial backups.
23
24Install dump if you need a system for both backing up filesystems and
25restoring filesystems after backups.
26
27%package -n rmt
28Summary: Provides certain programs with access to remote tape devices.
29Group: Applications/Archiving
30
31%description -n rmt
32The rmt utility provides remote access to tape devices for programs
33like dump (a filesystem backup program), restore (a program for
34restoring files from a backup) and tar (an archiving program).
35
dc8d1876 36%package -n dump-static
8954518f 37Summary: Statically linked versions of dump and restore.
dc8d1876
SP
38Group: Applications/Archiving
39
40%description -n dump-static
41The dump package contains both dump and restore. Dump examines files in
42a filesystem, determines which ones need to be backed up, and copies
43those files to a specified disk, tape or other storage medium. The
44restore command performs the inverse function of dump; it can restore a
45full backup of a filesystem. Subsequent incremental backups can then be
46layered on top of the full backup. Single files and directory subtrees
47may also be restored from full or partial backups.
48
49Install dump if you need a system for both backing up filesystems and
50restoring filesystems after backups.
51
52This packages contains statically linked versions of dump and restore.
53
c154548c
SP
54%prep
55%setup -q
56
57%build
1d568d1b 58%configure %{myoptions} --enable-static
dc8d1876
SP
59
60make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts"
61
62mv dump/dump dump/dump.static
63mv restore/restore restore/restore.static
64
65make distclean
66
1d568d1b 67%configure %{myoptions} --enable-rmt
c154548c
SP
68
69make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wno-char-subscripts"
70
71%install
1d568d1b
SP
72rm -rf %{buildroot}
73mkdir -p %{buildroot}%{_sbindir}
74mkdir -p %{buildroot}%{_mandir}/man8
75
60d46c35 76%makeinstall SBINDIR=%{buildroot}%{_sbindir} MANDIR=%{buildroot}%{_mandir}/man8 BINOWNER=$(id -un) BINGRP=$(id -gn) MANOWNER=$(id -un) MANGRP=$(id -gn)
1d568d1b
SP
77
78cp dump/dump.static %{buildroot}%{_sbindir}
79cp restore/restore.static %{buildroot}%{_sbindir}
80
81{ cd %{buildroot}
82 strip .%{_sbindir}/* || :
83 ln -sf dump .%{_sbindir}/rdump
84 ln -sf dump.static .%{_sbindir}/rdump.static
85 ln -sf restore .%{_sbindir}/rrestore
86 ln -sf restore.static .%{_sbindir}/rrestore.static
87 chmod ug-s .%{_sbindir}/rmt
88 mkdir -p .%{_sysconfdir}
89 > .%{_sysconfdir}/dumpdates
90 ln -sf ..%{_sbindir}/rmt .%{_sysconfdir}/rmt
c154548c
SP
91}
92
93%clean
1d568d1b 94rm -rf %{buildroot}
c154548c
SP
95
96%files
97%defattr(-,root,root)
1d568d1b
SP
98%doc CHANGES COPYRIGHT KNOWNBUGS MAINTAINERS README REPORTING-BUGS THANKS TODO
99%doc dump.lsm
100%attr(0664,root,disk) %config(noreplace) %{_sysconfdir}/dumpdates
101%attr(0755,root,root) %{_sbindir}/dump
102%{_sbindir}/rdump
103%attr(0755,root,root) %{_sbindir}/restore
104%{_sbindir}/rrestore
105%{_mandir}/man8/dump.*
106%{_mandir}/man8/rdump.*
107%{_mandir}/man8/restore.*
108%{_mandir}/man8/rrestore.*
c154548c
SP
109
110%files -n rmt
111%defattr(-,root,root)
1d568d1b
SP
112%attr(0755,root,root) %{_sbindir}/rmt
113%{_sysconfdir}/rmt
114%{_mandir}/man8/rmt.*
c154548c 115
dc8d1876
SP
116%files -n dump-static
117%defattr(-,root,root)
1d568d1b
SP
118%attr(0755,root,root) %{_sbindir}/dump.static
119%{_sbindir}/rdump.static
120%attr(0755,root,root) %{_sbindir}/restore.static
121%{_sbindir}/rrestore.static
dc8d1876 122
c154548c 123%changelog
35e850a4
SP
124* Sat Jan 30 2001 Stelian Pop <pop@noos.fr>
125- dump 0.4b21 released, first packaging.
126
109e9e1d 127* Fri Nov 10 2000 Stelian Pop <pop@noos.fr>
e93e901d
SP
128- dump 0.4b20 released, first packaging.
129
109e9e1d 130* Sun Aug 20 2000 Stelian Pop <pop@noos.fr>
d56b7aa4
SP
131- dump 0.4b19 released, first packaging.
132
109e9e1d 133* Thu Jun 30 2000 Stelian Pop <pop@noos.fr>
8cca05cc
SP
134- dump 0.4b18 released, first packaging.
135
109e9e1d 136* Thu Jun 1 2000 Stelian Pop <pop@noos.fr>
ac443b63
SP
137- dump 0.4b17 released, first packaging.
138
109e9e1d 139* Sat Mar 11 2000 Stelian Pop <pop@noos.fr>
107a347c
SP
140- dump 0.4b16 released, first packaging.
141
109e9e1d 142* Thu Mar 2 2000 Stelian Pop <pop@noos.fr>
2f7e72ce
SP
143- dump 0.4b15 released, first packaging.
144
109e9e1d 145* Thu Feb 10 2000 Stelian Pop <pop@noos.fr>
688653ea
SP
146- dump 0.4b14 released, first packaging.
147
109e9e1d 148* Fri Jan 21 2000 Stelian Pop <pop@noos.fr>
d4b74b5c
SP
149- dump 0.4b13 released, first packaging.
150
109e9e1d 151* Fri Jan 8 2000 Stelian Pop <pop@noos.fr>
df172bbb
SP
152- dump 0.4b12 released, first packaging.
153
109e9e1d 154* Sun Dec 5 1999 Stelian Pop <pop@noos.fr>
cf9aab8e
SP
155- dump 0.4b11 released, first packaging.
156
109e9e1d 157* Sun Nov 21 1999 Stelian Pop <pop@noos.fr>
c930abff
SP
158- dump 0.4b10 released, first packaging.
159
109e9e1d 160* Thu Nov 11 1999 Stelian Pop <pop@noos.fr>
dc8d1876
SP
161- make static versions also for rescue purposes.
162
109e9e1d 163* Wed Nov 5 1999 Stelian Pop <pop@noos.fr>
08ebf8d7
SP
164- dump 0.4b9 released, first packaging.
165
109e9e1d 166* Wed Nov 3 1999 Stelian Pop <pop@noos.fr>
c154548c
SP
167- dump 0.4b8 released, first packaging.
168
109e9e1d 169* Thu Oct 8 1999 Stelian Pop <pop@noos.fr>
c154548c
SP
170- dump 0.4b7 released, first packaging.
171
109e9e1d 172* Thu Sep 30 1999 Stelian Pop <pop@noos.fr>
c154548c
SP
173- dump 0.4b6 released, first packaging.
174
175* Fri Sep 10 1999 Jeff Johnson <jbj@redhat.com>
176- recompile with e2fsprogs = 1.15 (#4962).
177
178* Sat Jul 31 1999 Jeff Johnson <jbj@redhat.com>
179- workaround egcs bug (#4281) that caused dump problems (#2989).
180- use sigjmp_buf, not jmp_buf (#3260).
181- invoke /etc/rmt (instead of rmt) like other unices. (#3272).
182- use glibc21 err/glob rather than the internal compatibility routines.
183- wire $(OPT) throughout Makefile's.
184- fix many printf problems, mostly lint clean.
185- merge SuSE, Debian and many OpenBSD fixes.
186
187* Thu Mar 25 1999 Jeff Johnson <jbj@redhat.com>
188- remove setuid/setgid bits from /sbin/rmt (dump/restore are OK).
189
190* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
191- auto rebuild in the new build environment (release 6)
192
193* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
194- strip binaries.
195
196* Thu Mar 18 1999 Jeff Johnson <jbj@redhat.com>
197- Fix dangling symlinks (#1551).
198
199* Wed Mar 17 1999 Michael Maher <mike@redhat.com>
200- Top O' the morning, build root's fixed for man pages.
201
202* Fri Feb 19 1999 Preston Brown <pbrown@redhat.com>
203- upgraded to dump 0.4b4, massaged patches.
204
205* Tue Feb 02 1999 Ian A Cameron <I.A.Cameron@open.ac.uk>
206- added patch from Derrick J Brashear for traverse.c to stop bread errors
207
208* Wed Jan 20 1999 Jeff Johnson <jbj@redhat.com>
209- restore original 6755 root.tty to dump/restore, defattr did tty->root (#684).
210- mark /etc/dumpdates as noreplace.
211
212* Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
213- add build root.
214
215* Tue May 05 1998 Prospector System <bugs@redhat.com>
216- translations modified for de, fr, tr
217
218* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
219- added a patch for resolving linux/types.h and sys/types.h conflicts
220
221* Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
222- added prototype of llseek() so dump would work on large partitions
223
224* Thu Oct 30 1997 Donnie Barnes <djb@redhat.com>
225- made all symlinks relative instead of absolute
226
227* Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
228- built against glibc
229
230* Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
231- Moved rmt to its own package.
232
233* Tue Feb 11 1997 Michael Fulbright <msf@redhat.com>
234- Added endian cleanups for SPARC
235
236* Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
237- Made /etc/dumpdates writeable by group disk.